View Full Version : Brand new CD key invalid...(FIXED)

03-07-2008, 01:33 PM

I just bought "rainbow six: vegas" brand new from "game" today, (after playing a mates copy on my system to see if I could run it - which I can)

I installed the starforce update which was required to get it to work with 1.06 patch.

Every time I try to play online it tells me my CD key is invalid.

I've entered it correctly, there are no o/O/0's, 1/l's or anything like that... there are 5's and 2's, but they are clear...

03-07-2008, 01:33 PM

I just bought "rainbow six: vegas" brand new from "game" today, (after playing a mates copy on my system to see if I could run it - which I can)

I installed the starforce update which was required to get it to work with 1.06 patch.

Every time I try to play online it tells me my CD key is invalid.

I've entered it correctly, there are no o/O/0's, 1/l's or anything like that... there are 5's and 2's, but they are clear...

03-07-2008, 01:49 PM
Did you create an account the first time you went online?

03-07-2008, 02:26 PM
No, didn't go online with my mates copy.

Already had my own account with ubi, that's the one I tried registering the cd key to.

Have emailed UBI directly, sent DxDiag and a photo of box, game manual and reciept, hopefully they can give me a new key? Got the idea from another forum: http://aom.heavengames.com/cgi-bin/forums/display.cgi?a...5980&f=12,,0,10&st=0 (http://aom.heavengames.com/cgi-bin/forums/display.cgi?action=st&fn=12&tn=25980&f=12,,0,10&st=0)

And a copy of the email for others with the same problem to use...


Today I purchased a copy of Rainbow 6 Vegas, but I have a problem. The problem is that the CD key on the cover is apparently invalid whenever I attempt to play a multiplayer game online. My key is as follows on the front of the booklet; ****-****-****-**** (hidden for my security). This has left me unable to play a game online, which is the only reason I bought it in the first place.

I would like to request a new, unique CD key. If you require any additional information for validation purposes, please check the attached image, which is a photo of the boxed game with the manual and reciept.

Thank you. I look forward to playing this game online soon.


Please phone: ***********, or email:************@*******.com

The photo looks like this:


03-07-2008, 02:41 PM
Good Luck!

If you don't get a response, maybe try creating a whole new account and use that key?

03-07-2008, 02:44 PM
Just tried creating a new account, that won't accept it either http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

Only other time I've experienced this problem was while playing farcry a few years ago, whenever I switched servers I'd have to wait about 15 minutes for my key to be accepted, but seeing as I've had this problem from the start it seems as though someone else is already using my cd key? Or it's been printed wrong?

03-07-2008, 05:26 PM
Hey Funkymonkey,
Are you positive that there isn't one letter or number that you could be entering incorrectly?

The reason I ask is that I have registered 4 accounts on different computers and had the incorrect keycode message on every one on the first try.
On one I actually had to write down the key combos that I tried to finally get the correct combination, but that one was from a free game that came in a sleeve, and was kind of faded in spots.
But I also had problems with retail versions.

Will be building a new system for my oldest son tomorrow, and will be installing Vegas retail on that one, so hope it doesn't mess up like yours.

Good luck on a solution.

If you find something that works, or UBI sends you a new key, please post here to help others with this problem.

03-07-2008, 06:48 PM
Yep... positive.

The only one that letter I wasn't sure about was the 8th in the code; it's a Z with a horizontal line through the middle, I've tried swapping it for 2/z/Z/7etc... all to no avail.

I've edited the hex entry for KEYID in playerprofile.cfg. There was nothing to change, so it was a waste of time.

I'm not expecting a reply from ubi till monday now. It's damn frustrating that I purchase the damn thing and it doesn't work... Google has led me to quite a few people complaining that the games they have bought are having a similar problem, ubi exclusive "age of empires" is just one. That particular problem is caused by the same CD key being used repeatedly. So why don't the ubi servers allow the key to be used repeatedly?

If you're going to sell multiple items of software with the same CD key, but then only allow one of the said keys to use it, that's a little unfair don't you think? If I don't get a new, unique cd key I'll be returning my purchase and boycotting ubi games, which would be shame, as most of my favorite games are ubi. I'm eagerly awaitig assassins creed and splintercell convictions, but if ubi wants to pull cheap tricks like this I'll keep my money.

03-08-2008, 05:43 AM
ok... now i'm confused...

I jus wiped everything ubisoft from my reg, re-installed R6V, updated to 1.05 (as so many people are having problems with 1.06 patch) now I get the infamous "operation failed" message that I keep reading about on these forums... WTF are ubi playing at?!?

03-08-2008, 10:56 AM
Can I ask anyone having this problem (if you've not already) register a support ticket in the
Ubisoft Support Centre (http://ubisoft-en.custhelp.com/cgi-bin/ubisoft_en.cfg/php/enduser/std_alp.php?p_sid=uDwhAQVi&p_accessibility=0&p_redirect=&p_lva=&p_sp=&p_li=), in the meantime I'll see what I can find out http://forums.ubi.com/images/smilies/25.gif

03-08-2008, 10:17 PM
Well, we got my son's computer system built, installed Vegas, installed the 1.06 patch, and also the map pack.
Worked great in single player and LAN.
The went to multiplayer online, entered the key and that went through fine, then tried to create a new account and couldn't connect to the server. Tried on 4 computers and got the same thing.

Also went to Unisoft's site and tried to register and got the same thing.

Ubisoft really needs to correct this problem if they expect people to buy their games.

Will try again tomorrow but this is a little more than frustrating, as I was going to setup a server for 4 players and my son really wanted to play.

We got some people together and setup a 4 player LAN, but we shouldn't have to do that.

BTW: His system is pretty decent and runs the game great with everything turned up at 1600x1200.
Antec 900 case
Thermaltake 700 watt PSU with quad 12 volt rails
ASUS M2N32-SLI Deluxe Wireless Edition AM2 NVIDIA nForce 590 SLI MCP ATX AMD Motherboard - Retail
AMD Athlon 64 X2 6400+ Windsor 3.2GHz Socket AM2 125W Dual-Core Processor Model ADX6400CZBOX - Retail
GeIL 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400) Dual Channel Kit Desktop Memory Model GX22GB6400UDCA= - Retail
MSI NX8800GTS 512M OC GeForce 8800GTS (G92) 512MB 256-bit GDDR3 PCI Express 2.0 x16 HDCP Ready SLI Supported Video Card - Retail
Seagate Barracuda 7200.10 ST3320620AS (Perpendicular Recording Technology) 320GB 7200 RPM SATA 3.0Gb/s Hard Drive -Retail

Not top of the line, but very good price for performance.

03-09-2008, 08:35 AM
The Ubisoft registration server is back up this morning.
My son was able to create an account and logged in with no problem.

Why does Ubisoft have so many problems with their servers!!!!!

Sure wish someone could help find a solution for all those players who are unable to create accounts and log in, or can't even start a game.
They have payed for the privilege of playing this game, and they might as well throw their money out the window.
(It would actually be more entertaining)

Come on Ubisoft ... offer some help here with all the different problems!

03-09-2008, 08:44 AM
@ ms-kleaneasy, yep... did that on friday
(now sunday), asked a question on the support page, included my DxDiag and Photo of boxed game, receipt and manual... got an auto response, but nothing since, not really expecting an answer till monday anyway...

03-09-2008, 08:59 AM
ok... this is weird... with the 1.05 patch, when I try to get into an online game I get the "operation failed" error. After reading lethal's last post I thought I'd try again with 1.06... Works fine on LAN (did anyway) fine in SP (again did anyway), but I'm back to "CD key invalid" again...

This isn't frustrating, it's seriously F*CK*NG annoying... I've basically bought half a game...

I'm contemplating returning it to the store, I don't expect these sort of problems with games purchased brand new, especially when I can pick up second hand games for half the price and they work flawlessly, or borrow them off my mates and have no problems going online...

03-09-2008, 12:47 PM
just downloading the map pack now... I doubt it will make any difference, but it's the only thing I haven't triedhttp://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

03-10-2008, 07:57 AM
Nope, map pack didn't make a difference http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

This morning I have recieved an email from ubi tech support, asking for my login name and proof of purchase (even though I'd already sent proof of purchase). They're going to give me a new CD key... So hopefully I'll be online soon... yippee! I can't wait...

Cheerz to everyone who's tried to help, hopefully see you in game soonhttp://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

03-10-2008, 09:05 AM
The map pack wouldn't make any difference with the key problem, but you will need it to join servers online.

At least you got a response from Ubisoft and hopefully, you will get your problem resolved. Did they say how long this was going to take?

Please post in this forum if/when you get a fix as there are other players with the same problem.

03-10-2008, 09:58 AM
Not a clue how long it's going to take, hopefully it'll be today. The response was quicker than I expected, I thought I might have been waiting ages, but it was the first working day after I contacted them.

They wanted my ubi login name and proof of purchase, even though they've already had a photo of the reciept from me (what else can I give as proof of purchase?), and they should have my login name from my email address? I replied straight away with my login name and told them to look at the photo I'd already sent them for proof of purchase, hopefully that will do the trick?

Soon see I guess...

03-10-2008, 10:35 AM
You might of wanted to send them another copy of the photo just in case, with your last reply. Its never the same person working on the cases. I had 4 different people working on my CD key issue and i had to give them all the same info. They where not tracking who got what.

03-10-2008, 10:52 AM
yep, had to send the photo again, but not for that reason. I went to update the question, and I decided to check the photo, for some reason it's been replaced with my DxDiag, so they have my DxDiag twice... sent another photo... still waiting for a reply... it's nearly 5.00pm now though, so I probably won't hear from them again till tomorrow now http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

03-11-2008, 04:55 AM
Still nothing. I've emailed them AGAIN with ANOTHER copy of the photo... Hopefully someone will pay attention?

Maybe I shouldn't hold my breath eh? http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

03-11-2008, 06:30 AM
well, I phoned the ubi tech support line, some dude told me he was sorting it out right then http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

My tech support question was apparently updated around 11.30 (CD key? - no) but the last update I can see is my own at 10.45...

Been over an hour now since I spoke to them... still nothing... http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

I hope it's sorted out todayhttp://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

03-11-2008, 09:10 AM
Hang in there!

I was just thinking .. when you get your new keycode, (I'm thinking positive .. When you get it .. not if!!) you might want to go to your Ubisoft folder in "My Documents" and delete your old keycode in PlayerProfile.ini. (If there is one there)
That may help prevent a conflict when entering the new key.

03-11-2008, 10:19 AM
WAY ahead of you pal http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif cheers though :P

Just got my new key, so thanks to the guys at tech support, and everyone here... now it's time to go try it out http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

03-11-2008, 10:37 AM
Sure hope the new key works!!
Keep us informed!

Others with key problems can follow funkmonkeys lead since it appears he was successful with Ubisoft support, even though he had to follow up several times.

It seems persistance is the key to success with UBI.

03-11-2008, 12:12 PM
Hey Funky, sorry I didnt get back here sooner but I was away. Glad you've got it sorted though http://forums.ubi.com/images/smilies/25.gif

03-13-2008, 04:48 AM
Works a charm... http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

Once again thanks to everybody here...

Now I just need to stop playing TSS games with spoilt little brats who can't take losing... I don't have the problem when I'm playing Co-op...

03-13-2008, 11:26 AM
I gave up on UBi contacting me after sent in( I kid you not) 26 emails and not a single replay. I took it back to eb games and showed them every email i sent and demanded my money back. I got my money back a 30 percent discount for my troubles. I wait before i waste my time on the next game.

03-20-2008, 01:48 PM
Please could i borrow yopur reciept because i have the same problem but i have lost my reciept!

03-21-2008, 11:35 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by ADD99:
Please could i borrow yopur reciept because i have the same problem but i have lost my reciept! </div></BLOCKQUOTE>

I don't think so pal... nice try though...

That's why I put big blue boxes on the picture from the previous page, so other people couldn't use it... The picture I sent to ubi tech support didn't have the big blue boxes...

03-21-2008, 06:08 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by ADD99:
Please could i borrow yopur reciept because i have the same problem but i have lost my reciept! </div></BLOCKQUOTE>

Just registered? Ya.... buzz off eh!

03-28-2008, 10:03 PM
Zack.... are you the dude in the video you've linked to??? I hope not... How embarrasing if it is you...

03-30-2008, 08:23 PM
Lol... there's been nearly 750 hits on this thread... something tells me Ubi's been releasing a lot of keys recently that don't work...

03-31-2008, 06:31 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by funkmunky80:
Lol... there's been nearly 750 hits on this thread... something tells me Ubi's been releasing a lot of keys recently that don't work... </div></BLOCKQUOTE>

Well, it's the reason I've been led here. : (

&lt;/waiting for Ubi support to get back to me&gt;

03-31-2008, 07:00 AM
They should sort it out for you, they did for me, I just kept harrassing them because I'm an impatient SOB http://forums.ubi.com/images/smilies/mockface.gif

It worked though...

03-31-2008, 08:36 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by funkmunky80:
I installed the starforce update which was required to get it to work with 1.06 patch. </div></BLOCKQUOTE>

I am confused. I thought Starforce was only used on copies released in Russia. All English copies (as clearly seen on your store bill) should be Securom.

03-31-2008, 07:31 PM
consoles, (already covered this in a few other threads) yer I know... (DO they use it in russia???) weird one that.

I couldn't get the game to start with 1.06, my mate sent me a link to the starforce update (which he'd used to get his copy running, I downloaded and installed it, hey presto it works like a charm... A few other people have commented on Starforce not even being in vegas, but if it works, it works... fook knows pal...???


EDIT: Turns out it's a problem with the 1.06 patch that only affects some people... installing patch 1.05 then 1.06 works fine withouit the starforce update...

04-02-2011, 07:11 AM
ok today i bought rainbow six vegas 2 only for the online gameplay but CD key is invald.. so i need other key or some patch pls someone respone http://forums.ubi.com/groupee_common/emoticons/icon_rolleyes.gif

04-02-2011, 09:04 AM
Just a quick question. Do you have hard copy or digital download? There was a problem floating around in the forums a time back with some people getting a digital download with a none working cd key. When entering to cd key make sure you are getting it right. Not trying to talk down to you but companies are using a zero that can be miss took for the letter"O". So check it out to see if maybe that is the problem. If not you have two solutions 1. contact the place you bought the game and tell them you want a working key, or 2. go to "TechnoGods" and look around. If this fails stop back in for additional help from the smart people.

04-02-2011, 11:10 AM
Stryker is correct! http://forums.ubi.com/groupee_common/emoticons/icon_cool.gif

I have seen several instances of mis-reading the key.

The most mis-read are "O" (oh) for a 0 (zero) as Styker mentions, but others can be an "I" (eye) for a "1" (one) .. a "B" (bee) for an "8" (eight), etc.

If you have a hard copy, often the key is not very legible.

I have had to try several combos in the past to get one to work.

Good luck!!

04-02-2011, 03:01 PM
ok i will try something again i was busy today but i buy the game in store it was 10 euro so i dont care much but i buy the game for gameplay online i have it on ps3 but im slow there i need an mouse in my hand xD

04-02-2011, 03:07 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">If you are not part of the solution,you are part of the problem. </div></BLOCKQUOTE>

like your style =) ty i will try something more and else i go back to store or trow it away. i had it befor with other game i had one key but needed 3 key`s was 5 euro so i didnt care much i was to lazy and need other game xD but 3 weeks later i saw same game in store and i told the guy of it and he checked it and i was right so nah doesnt matter i will try something of your ativse StryKerN have an nice day

04-03-2011, 12:28 AM
ok u where right indeed one O was 0 so i was the problem xD ty anny way guys now i can enjoy it http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif yessssss http://forums.ubi.com/images/smilies/25.gif thanks and have an nice day all

04-03-2011, 11:30 AM
Glad we could be of service to a fellow gamer. Thanks for comming back and letting us know it worked out. Time is 1:30 P.M. Eastern Time here in the U.S. and the server has been down for some time now so at this point you may not be thanking us for getting you involved in the rotten world of UBI. Well good gaming to you when you can play.

04-03-2011, 12:54 PM
thanks alot and have an good life and much playing hour`s http://forums.ubi.com/groupee_common/emoticons/icon_razz.gif Greets The Phen for more info =) http://www.xfire.com/profile/neerlandshoop/