PDA

View Full Version : Sound is driving me nuts! Is this the way it should be, or am I set up wrong?



P51er
12-11-2009, 12:35 PM
Ok, when I have my headset on and I'm facing straight ahead, it sounds great. When I look left, the sound in my right ear still sounds great, but it's pretty much silent in my left, and vice verse when I look to the right.

Feels really unnatural and annoying having sound constantly cutting in and out of one ear when I look around, any fix would be greatly appreciated.

I've tried "Attenuation=1" in my conf.ini, doesn't help.

Using 4.09...

<pre class="ip-ubbcode-code-pre">
[sound]
SoundUse=1
SoundEngine=1
Speakers=0
Placement=0
SoundFlags.reversestereo=0
RadioFlags.Enabled=1
RadioEngine=2
MusicVolume=1
ObjectVolume=13
MusState.takeoff=1
MusState.inflight=1
MusState.crash=1
MusFlags.play=0
MasterVolume=14
Attenuation=7
SoundMode=3
SamplingRate=2
NumChannels=3
SoundExt.occlusions=0
SoundFlags.hardware=0
SoundFlags.streams=1
SoundFlags.duplex=1
SoundExt.acoustics=0
SoundExt.volumefx=0
SoundFlags.voicemgr=0
SoundFlags.static=1
VoiceVolume=5
Channels=2
SoundExt.extrender=0
SoundFlags.bugscorrect=0
SoundSetupId=8
ActivationLevel=0.02
Preemphasis=0.85
RadioLatency=0.5
AGC=1
PTTMode=1
SoundFlags.UseRadioChatter=0
SoundFlags.AutoActivation=0
RadioFlags.PTTMode=0
RadioFlags.PlayClicks=0
ActLevel=0
MicLevel=0
SoundFlags.forceEAX1=0
</pre>

P51er
12-11-2009, 12:35 PM
Ok, when I have my headset on and I'm facing straight ahead, it sounds great. When I look left, the sound in my right ear still sounds great, but it's pretty much silent in my left, and vice verse when I look to the right.

Feels really unnatural and annoying having sound constantly cutting in and out of one ear when I look around, any fix would be greatly appreciated.

I've tried "Attenuation=1" in my conf.ini, doesn't help.

Using 4.09...

<pre class="ip-ubbcode-code-pre">
[sound]
SoundUse=1
SoundEngine=1
Speakers=0
Placement=0
SoundFlags.reversestereo=0
RadioFlags.Enabled=1
RadioEngine=2
MusicVolume=1
ObjectVolume=13
MusState.takeoff=1
MusState.inflight=1
MusState.crash=1
MusFlags.play=0
MasterVolume=14
Attenuation=7
SoundMode=3
SamplingRate=2
NumChannels=3
SoundExt.occlusions=0
SoundFlags.hardware=0
SoundFlags.streams=1
SoundFlags.duplex=1
SoundExt.acoustics=0
SoundExt.volumefx=0
SoundFlags.voicemgr=0
SoundFlags.static=1
VoiceVolume=5
Channels=2
SoundExt.extrender=0
SoundFlags.bugscorrect=0
SoundSetupId=8
ActivationLevel=0.02
Preemphasis=0.85
RadioLatency=0.5
AGC=1
PTTMode=1
SoundFlags.UseRadioChatter=0
SoundFlags.AutoActivation=0
RadioFlags.PTTMode=0
RadioFlags.PlayClicks=0
ActLevel=0
MicLevel=0
SoundFlags.forceEAX1=0
</pre>

horseback
12-11-2009, 12:49 PM
That's sort of how it's supposed to work; if you look to your left, the engine (source of most of the noise) will be lined up with your right ear...

cheers

horseback

P51er
12-11-2009, 12:54 PM
Sort of, sure, I don't mind it being a little louder in my right ear, but if I'm in the cockpit of a plane, there's still going to be plenty of sound in my left ear too, not dead silence. It's really uncomfortable having sound come in and out like that for some reason.

By the way, I've tried hardware acceleration/EAS on and off, 3D sound engine maximum balanced and minimum, none of those options help.

na85
12-11-2009, 01:22 PM
I always thought that's just how the game handles cockpit sounds. I get the same effect.

horseback
12-11-2009, 01:37 PM
I agree that it is a bit exaggerated, but you have to remember that the game is over 5 years old. I usually play it with the default speakers, which in my case is 5.1.

Are you going from a 'stock' 2.1/4.1/5.1 speaker setup to headphones? If you're set for your system's default sound system , the game may trying to squeeze a surround sound setting into stereo headphones.

cheers

horseback

P51er
12-11-2009, 04:33 PM
No surround setup here, my sound is set to stereo headphones.

Stiletto-
12-11-2009, 04:35 PM
Just because this game is over 5 years old doesnt mean the surround sound should suck. If any of you have ever played Thief: The Dark Project, it still has great surround sound to this day, with reverb effects, etc.. and the game is from 1998.

I have had the effect where it completely goes from one speaker to the other if you look too far over your shoulder, and it sounds like crap. It doesn't always sound this way though, I think it is dependent on one or more of the in-game settings and maybe soundcard settings as well. It might be realistic occlusions toggled or what kind of speakers you choose but off-hand I can't recall.

BillSwagger
12-12-2009, 01:38 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by P51er:
No surround setup here, my sound is set to stereo headphones. </div></BLOCKQUOTE>

go into setup, under the sound tab, go to the 3d engine mode, should say "default".


or its the same as.......

Go to your config.ini and make sure it says

SoundMode = 0

I see you have yours set at 3.



Bill

P51er
12-12-2009, 11:11 AM
Thanks BillSwagger, but I tried that already to no avail.

FoolTrottel
12-12-2009, 11:34 AM
Make sure your Windows Speaker setup is set to match the speakertype you use, as well as the in game setting: Headphones in your case.

dwagener
12-12-2009, 01:18 PM
Run DirectXdiag or change directx sound accelleration, and reduce your sound accelleration a couple of notches to "basic". See if that helps. This fix has been posted here before and it worked for me. It might be "hardware accelleration" but its in DirectX.

Take care.

BillSwagger
12-12-2009, 02:28 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by P51er:
Thanks BillSwagger, but I tried that already to no avail. </div></BLOCKQUOTE>


really?

thats strange, cause thats usually the fix for exactly what you are describing.


can't say what it is then.

does your config. ini still say SoundMode=3

Just checking.


Bill

Art-J
12-13-2009, 11:56 PM
What Bill said. I had exactly the same problem, sounds like you have some 3D effects mode on. Strange that "default" option in 3d engine mode tab didn't work for you, must be some kind of Windows system setting then?

Cheers - Art

P51er
12-18-2009, 05:11 PM
Yes, my soundmode=0 now. Checked all the windows settings I can find, everything seems to be set up for 2 speakers/headphones.

HayateAce
12-19-2009, 09:14 AM
P51er,

I have this problem every time I have to reinstall and forget to save my settings file. I cannot remember what I do, but with the right combination of settings you'll get there.