PDA

View Full Version : Applying Partial Patch (Undo only what the patch messes up...)



maztec
11-04-2004, 01:24 PM
This is for people who know what they're doing. You can try things out if you want, but I nor anyone else is responsible for anything you do or don't mess up :P. Let us know if you do something good http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

---------

Ok. I thought to myself "Hey, this patch does fix some things!" But at the same time it creates all types of new interesting graphical problems. So I started playing around with the DLLs it updates. I took a guess that perhaps the "shader" affects were what was wrong, at least that's what was causing anomalies for me. My first guess proved correct, my graphical anomalies are now gone.

Steps to do what I did:

1) Go to your UBISOFT\MystIV - Revelation\bin folder (for windows, otherwise go to wherever myst is on a mac...)
2) Make a directory "bak"
3) Copy all *.dll and *.exe files to "bak"
4) Run the update.
5) From your "bak" folder copy the following file "m4_shaderlib_rd.dll" back to where it came from. For windows copy MystIV - Revelation\bin\bak\m4_shaderlib_rd.dll to MystIV - Revelation\bin\m4_shaderlib_rd.dll
6) Choose to overwrite the newer file with the older file.
7) Go try Myst out, did this take care of your graphical anomalies?

-------------

Getting Depth of Field working again... As far as I can tell, there is no way to do this without a full regression... It might be doable by playing with one configure file or another.. That's all I can figure.

--------------



-- If you have some amount of experience with playing around with files on your computer, you'll notice that the modified date on the DLLs that were replaced is 10/20/2004. If you have new problems caused by the update, pick a dll that sounds right, copy the older over the newer. Try it out. I'd make a backup of the "new" files also, so you can copy them back and try the dll files one at a time. --

The following list are the only files that were replaced by the update, as far as I know: (you can also get these files off the first DVD)
<UL TYPE=SQUARE><LI>m4_ai_all_rd.dll
<LI>m4_ai_global_rd.dll
<LI>m4_ai_thor_rd.dll (If you regress it with new EXE, old DLL, game won't start.)
<LI>m4_ai_w1_rd.dll
<LI>m4_ai_w2_rd.dll
<LI>m4_ai_w3_rd.dll
<LI>m4_ai_w4_rd.dll
<LI>m4_ai_w5_rd.dll
<LI>m4_ai_w6_rd.dll
<LI>m4_aisdk_rd.dll
<LI>m4_base_rd.dll
<LI>m4_dare_ext_rd.dll
<LI>m4_shaderlib_rd.dll (Regressing fixes shader problems.)
<LI>m4_snd_rd.dll
<LI>m4_thor_rd.dll
<LI>Myst4.exe
[/list]

If you don't have experience with doing such a thing, I don't recommend you try it. Just wait for those of us that do know to figure out what files help you in what ways, we'll post instructions regarding that.

If you find anything useful -- let us know what file it was and what it fixed or didn't fix.


Maz

walt_scRIVENs
11-06-2004, 09:22 AM
maz, I will have a go at it and will report back here.
Wouldn't it be helpful if the developers could part with some info about which files do what? At least with Uru, the file names were helpful!

walt

walt_scRIVENs
11-06-2004, 11:08 AM
maz, your approach worked. I copied back the old version of m4_shaderlib_rd.dll and the video is fine.
My system is a Dell Inspiron 9100 with a Mobility Radeon 9800, Driver Version 6.14.10.6483. It worked fine with the original installation, but was severely messed up by the service pack. I wanted to try the service pack since I am having trouble with one of the timed puzzles, and it supposedly corrects some timing issues.

walt

maztec
11-06-2004, 12:56 PM
Definitely fixes the timed issues.

Great to hear it's working for you walt.

Thanks for checking for me http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Maz

Lord Cecil
11-06-2004, 02:04 PM
Copied the original "m4_shaderlib_rd.dll" from the DVD and pasted it over the one the patch created. All problems solved. Thanks a ton.
(My other post concerning the uninsatall problem still remains however.)

Coronagold
11-07-2004, 02:05 AM
Why is Ubi/Cyan remaining mute on this issue? Did they all go to the Riviera for vacation recently? They leave the whole stinking problem for Maztec to unravel through Regedit. Why haven't we heard one peep from the Rev team since this happened? This is making the whole Uru debacle look like a good thing.

marae
11-07-2004, 10:51 AM
Thanks for the suggestion -- I just replaced the m4_shaderlib_rd.dll with the one from the DVD and am now off to see if it works (yes, I backed up the patch version). Got my fingers crossed.... http://forums.ubi.com/images/smilies/blink.gif

Yes! Yes! Yes! http://forums.ubi.com/images/smilies/25.gif http://forums.ubi.com/images/smilies/25.gif

Thank you, thank you, thank you. All I did was change the one file, and I can see again!

Maztec, you're the best. http://forums.ubi.com/images/smilies/11.gif

maztec
11-07-2004, 01:36 PM
Corona, didn't use regedit at all :P

Coronagold
11-07-2004, 02:42 PM
Thanks Maztec. Changing just the m4_shaderlib_rd.dll file to the older version worked. And no more CTD either. http://forums.ubi.com/images/smilies/16x16_smiley-happy.gif

However, was this patch supposed to add time to the Spire chair/crystals puzzle? Doesn't seem like it did. http://forums.ubi.com/images/smilies/cry.gif I am reeeeally stuck on this one.

maztec
11-07-2004, 07:50 PM
Yah, it added quite a bit for me.

So not sure why it hasn't helped you...

PhreekUhXoid
11-12-2004, 12:20 AM
ty sooo very much maz ... i copied the m4_shaderlib_rd.dll (From the installation disc), and it got rid of the blocky shader effects for me.

For any one with a ATi 9700PRO ... this works GREAT !!!

Thanks again

clynch
11-13-2004, 10:10 AM
Yes thank you Maztec.

Replacing that file with the original eliminated all the rendering issues I was having on my 9800 Pro.

GJ. http://forums.ubi.com/images/smilies/25.gif