PDA

View Full Version : Huh?



relcox
01-21-2008, 12:34 AM
Got fed up with the GC in Berlin at the end of a full German Centre campaign in '46 so I just kept starting and quitting (instant success on) and I just got mission after mission until the 28th April '45, Soviets had berlin and then instead of the usual war ended screen all was blank except the buttons for apply etc, no map was then found for clicking apply

Any thoughts?

relcox
01-21-2008, 12:34 AM
Got fed up with the GC in Berlin at the end of a full German Centre campaign in '46 so I just kept starting and quitting (instant success on) and I just got mission after mission until the 28th April '45, Soviets had berlin and then instead of the usual war ended screen all was blank except the buttons for apply etc, no map was then found for clicking apply

Any thoughts?

relcox
01-21-2008, 09:11 AM
no one had this happen?

FoolTrottel
01-21-2008, 12:05 PM
Click this link, it will take you to a post by Enjoyr, and it should lead you to his DGen patches... (http://forums.ubi.com/eve/forums/a/tpc/f/49310655/m/8451034535?r=6671074145#6671074145)
(Which should fix the problem, well maybe not for your current campaign though)

crucislancer
01-21-2008, 12:40 PM
We are having the same problem it seems, but on different campaigns. Please see the link from a thread I started on mission4today:

Dgen Problem (http://www.mission4today.com/index.php?name=ForumsPro&file=viewtopic&t=2774)

What version of the game do you have? Do you have any add-ons, like Battle over Europe? Did you install Enjoyr's Dgen patches?

It seems my problem didn't start until I installed Enjoyr's patches. WIth 4.07, 4.07 with BoE, and 4.08 with BoE, I had no issues.

relcox
01-22-2008, 12:10 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by crucislancer:
We are having the same problem it seems, but on different campaigns. Please see the link from a thread I started on mission4today:

Dgen Problem (http://www.mission4today.com/index.php?name=ForumsPro&file=viewtopic&t=2774)

What version of the game do you have? Do you have any add-ons, like Battle over Europe? Did you install Enjoyr's Dgen patches?

It seems my problem didn't start until I installed Enjoyr's patches. WIth 4.07, 4.07 with BoE, and 4.08 with BoE, I had no issues. </div></BLOCKQUOTE>

Sorry for getting back to you so late, you will be interested to know that I have not patched to Enjoyr's works, (every time I think about it I remember how difficult it was to install last time) I have got 1946 patched to 4.08m and BoE. this has only happened to the end of the war in the way I described above, started a new De fighter South campaign and have completed he 1st 2 Crimea chapters. The only thing I have done is
modify the planes.dat file for these Dgen campaigns although in the affected campaign I talked about I was using the ME262 which is allowed with the stock game. I do wonder however
if maybe a crash like that will occur if the dat file is too long or a certain plane is no longer in it's oringinal position on the list, if so I should find out soon as I have added lots to these files to spice up my campaign, never flown an A6/A9 in campaign for eg,

Anyway, read the thread you linked, maybe this info may help, no one else apart from us has posted about this yet so maybe take sometime to solve.

crucislancer
01-22-2008, 12:37 PM
No worries. I seem to have stumped them with this error. Mine seems to be related to the Enjoyr patch, or what was in it, and most likely involves the TruePacific dgen add-on.

It seems your error was corrected with the Enjoyr patch, but I can see your reluctance to install it if you made changes that would undoubtedly be removed. The problem with these dgen campaigns is that they are difficult to bug check. If the campaign works at first, the thought is that it will work until the end. But if it doesn't, you're stuck. I think there is a way to go back, you might be able to save your campaign but editing the campaign.ini file, and making the next mission in the series exactly like the last one that worked.

Have you looked at your dgenerror.log? That might tell you what the problem is. I had different errors each time, from not finding the .mis files, to missing planes, both of which made no sense.

relcox
01-22-2008, 09:43 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">dgenerror.log </div></BLOCKQUOTE>
http://forums.ubi.com/images/smilies/blink.gif Where?

crucislancer
01-22-2008, 11:09 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by relcox:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">dgenerror.log </div></BLOCKQUOTE>
http://forums.ubi.com/images/smilies/blink.gif Where? </div></BLOCKQUOTE>

Oh, it's in your IL-2 root directory. Sorry.

mortoma
01-23-2008, 09:35 AM
Dgen has always had problems with giving you the "End of war" debriefing. Sometimes you get it, sometimes ya don't. If you fly the Berlin campaign, especially as German, you rarely get it.
About half the time as Soviet. I ought to know, the Berlin campaign has always been my fav, and I have flown it a lot. I don't use Enjoyers patches because I have made so many changes to the Dgen files it would mess up my work if I did!!

relcox
01-23-2008, 09:50 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by mortoma:
Dgen has always had problems with giving you the "End of war" debriefing. Sometimes you get it, sometimes ya don't. If you fly the Berlin campaign, especially as German, you rarely get it.
About half the time as Soviet. I ought to know, the Berlin campaign has always been my fav, and I have flown it a lot. I don't use Enjoyers patches because I have made so many changes to the Dgen files it would mess up my work if I did!! </div></BLOCKQUOTE>

It was a 1st for me, so there is no fix? Just chance?

crucislancer
01-23-2008, 10:13 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by relcox:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by mortoma:
Dgen has always had problems with giving you the "End of war" debriefing. Sometimes you get it, sometimes ya don't. If you fly the Berlin campaign, especially as German, you rarely get it.
About half the time as Soviet. I ought to know, the Berlin campaign has always been my fav, and I have flown it a lot. I don't use Enjoyers patches because I have made so many changes to the Dgen files it would mess up my work if I did!! </div></BLOCKQUOTE>

It was a 1st for me, so there is no fix? Just chance? </div></BLOCKQUOTE>

I don't know. I've been working with someone on the problem I was having, which seems to be similar, and it seems he might have found a fix. It could be that there is a fix for your problem as well, as they seem very similar.

It's very rare for me to actually finish a Dgen campaign, but when I do I've never had any issues with it.

Just from what little I know about the Dgen folder structure, I can see how something could go off at some point. Dgen seems to call to a lot of different files per campaign, and some of those files could react with each other in unexpected ways, like campaigns crashing. I see all kinds of stuff like that. I've got a RAF campaign going that fouls up the rank and award names. A USAAF P-400 campaign in Guadalcanal (from the TruePacific dgen campaigns) that says I'm a Marine. A Luftwaffe campaign in Africa that said in one mission that I was attacking a Russian airbase, and to look out for MiGs. Stuff like that.

relcox
01-23-2008, 03:07 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">It's very rare for me to actually finish a Dgen campaign, but when I do I've never had any issues with it. </div></BLOCKQUOTE>

Same, those I have completed ended correctly. Keep me posted on the possible fix, found the dgen error log can post it if you want as I don't know what to look for.

crucislancer
01-23-2008, 03:17 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by relcox:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">It's very rare for me to actually finish a Dgen campaign, but when I do I've never had any issues with it. </div></BLOCKQUOTE>

Same, those I have completed ended correctly. Keep me posted on the possible fix, found the dgen error log can post it if you want as I don't know what to look for. </div></BLOCKQUOTE>

Cool. I just sent you a PM with my e-mail addy in it.

relcox
01-23-2008, 04:07 PM
got your pm, and sent you email