PDA

View Full Version : frames per second



chrisjones1970
02-26-2007, 02:24 AM
Why does the frame rate for graphics on il-2 complete edition slow drastically as soon as I try to play the Pacific Fighters section of the game,seems especially bad while flying off a carrier.
How do I improve this? I am using a Dell PC,model G7P2C1S.I have upgraded the computer with a DVD Combo drive,and also the memory,now 768MB of ram.

chrisjones1970
02-26-2007, 02:24 AM
Why does the frame rate for graphics on il-2 complete edition slow drastically as soon as I try to play the Pacific Fighters section of the game,seems especially bad while flying off a carrier.
How do I improve this? I am using a Dell PC,model G7P2C1S.I have upgraded the computer with a DVD Combo drive,and also the memory,now 768MB of ram.

stansdds
02-26-2007, 04:08 AM
Are you running in perfect mode? If so, what is your water setting?

AnaK774
02-26-2007, 05:17 AM
Also having 3d gunners active slows it down especially on carriers

flox
02-26-2007, 04:58 PM
A little clarification for you Chris: there are many "hidden" graphics settings contained within the file conf.ini that can be found in your main il2 directory.

For example, you can find your water setting by going to the [render opengl] or [render directx] section (depending on which you have chosen to use-- opengl is the way to go by the way) and looking for the line water= x. The value could be 0,1,2, or 3 (0 being the best in terms of fps but worst looking, 3 being the highest setting).

3DGunners is another line to look for-- having it set to "1" (ON) will cost you some frames.

Hope thie helps, and welcome to the boards!

chrisjones1970
02-28-2007, 12:41 AM
Hi,thanks for your help.I feel really silly even asking, but how do I open the conf.ini files for water rendering etc in the game directory.I don't know where to look,as you have probably guessed I am pretty new to computers but I am getting hooked on this sim game,its great.
Thanks for your help so far,

Chris.

MrMojok
02-28-2007, 01:05 AM
Assuming windows XP, click start-mycomputer. Double-click the C: drive(might be named "local disk C), double-click "program files", then double-click "IL2 Sturmovic Forgotten Battles", and in here you should see a file called "config.ini". Double-click that one, and you should find the settings they are talking about.

Dogfighter1969
02-28-2007, 04:54 AM
Chris,
Must tell you that I had same problem. Have both Forgotten Battles and Pacific Fighters stand-alone games. FB gives me no problems but PF does same as what you have experienced. I went into confi, set everything at 0 where possible. Still did not work. I have PF version 3.00 or something, which is bloody old. There are lots of patches available to upgrade to higher versions. Maybe one of the patches could sort out the problem but I haven't tried it because I decided to rather wait for 1946 which is becoming available in my country only towards the end of March. However, maybe you would like to give it a try to download the patches. If you get it right let us know as a matter of interest.
Cheers

Monterey13
02-28-2007, 08:28 AM
I have seen in more than one post where "3dgunners" is mentioned. I have looked in conf.ini several times, and it doesn't exist.

ratchet1961
02-28-2007, 03:35 PM
I have the same trouble in pf, when it gets busy it nearly comes to stand still, what type of system are you running, `iam seriously of an building a new system

badatit
03-01-2007, 03:47 AM
In the game folder, there is a file named ReadmePF.
This is copied and pasted from that file.


3d models of humans

PF includes 3d models of human gunners manning most of our guns on ground and sea objects, such as ship and land-based flak and artillery guns, drivers and other troops inside trucks and amphibious assault vehicles, etc. However these objects cause a decrease in game's frames per second when shown, especially when related to large ships such as aircraft carrier which can have a hundred or more of these gunners in close proximity.

Therefore we've made this feature turned off by default.

If you wish to turn it on, you'll need to open the conf.ini file inside your game's root directory with notepad, locate the
[game]
section, and insert the following line there:
3dgunners=1
If the line already exists and you wish to turn the feature off, replace the 1 with a 0, i.e
3dgunners=0

Dogfighter1969
03-02-2007, 04:38 AM
Hi again Chris,
In continuation of my earlier post, I decided to give the patches a try as a matter of interest. I downloaded patch Version 3.03. My problem seems to be solved with the fps except when I gave Pearl Harbour a try it got slow again but not as slow as what it used to be. Also the Zero I flew in was doing OK except when passing over the harbour area with the ships in the picture. There was a lot of smoke in the air and that slowed things up. Maybe I can fix that by setting my video at low on the different settings.
Previously I had very bad fps when flying over the sea with nothing in sight except the rest of my squadron. That same mission (Coral Sea campaign) is now working perfectly. I think V3.03 definitely helped. I will now try the patches after that as well. Maybe even Pearl Harbour even gets better.
I don't believe the problem is with my pc. I have 2.5 Ghz CPU, 1.25 Gig RAM, 128 mb Video card (maybe this card is a bit low, to be upgraded next). The game box stipulates minimum 64 mb videocard. If this is correct, the 128 mb should still be OK I hope.