View Full Version : Game freezes at menu

10-09-2004, 02:00 PM
Just bought the game, installed no probs... started it and then the game just stops at the menu screen with no cursor.. just like here: http://forums.ubi.com/eve/forums?a=tpc&s=400102&f=580100736&m=758106306

Have anyone found a solution yet?

10-09-2004, 02:49 PM
You hardware info please.

10-09-2004, 03:58 PM
Abit IC7-MAX3
GeForce 6800NU
Win XP pro sp2
SB Audigy

Everything with the latest drivers.

10-10-2004, 01:36 PM
Yep, same here. Two machines, different hardware.

Strange side effect: on one machine I can play normal with one user account, switching to any other user account the game fails...

regards, johoe

10-10-2004, 02:26 PM
Thanks johoe!!! you just solved my problem... i just created another non-administrative useraccount... and it works! ... I love you man!... http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

10-10-2004, 02:51 PM
Ok, same problem as has been reported elsewhere then. It's a permissions problem.

10-12-2004, 01:29 AM
hello jake,

glad that I solved your problem - I still can't play on my pc at home. Neither admin account nor a restricted user account helps...


dont' understand "permissions problem" - too much permissions as system administrator?

regards, johoe

10-12-2004, 11:13 AM
http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif No, too confusing permissions. System Admin doesn't give you access or the programs you run access to everything necessarily. It's likely it's having issues reading and writing from the My Documents directory.

10-12-2004, 12:32 PM
Well Maz?

Doesn't look like I was the only one, huh?
And the thread you just locked was still pretty up to date: read back & notice many more people experiencing the same problem...

we need a fix~!
and be sure the final game doesn't have the same bug.

10-12-2004, 01:16 PM
LiquidTV, I'd appreciate it if you'd not be your snide self for a moment some day.

Off of that note:

In order to help Ubi create a patch to this problem please use item #2 on this page: http://forums.ubi.com/eve/forums?a=tpc&s=400102&f=580100736&m=6651093922&r=6651093922#6651093922

By submitting a report to Ubi you will help aid them in recreating the problem so they can in turn create a solution for it in an upcoming patch.

I am not sure as to what is causing this problem.


On another side note -- this problem appears to be similar to the permissions problem experienced by many other users and discussed throughout the threads. It is not necessarily the same problem as that experienced with the Demo.

10-12-2004, 01:45 PM
I cannot see how permissions can prevent a mouse cursor from working correctly.

when I transfer the save games from my office computer (there the game works with my admin account, and ONLY with this account), including all the ini files in the save game folder to my home pc, the mouse curor is shown. Moving the mouse ends with the "hand" at the left screen. There I can move it up and down, but not to the left or right.

Really strange.

regards, johoe

10-12-2004, 02:18 PM
joehoe, Oh, with how you described the problem. That is useful.

Try ALT+TAB and ALT+TAB to exit and re-enter the problem. If alt-tab doesn't drop you out of it use CONTROL+ESCAPE (CTRL+ESC) and then alt+tab back into the game. See if that makes the mouse reappear.

I made the mistake of reading this as "Game freezes at menu" and the read the description in that light.

Still see item #2 for a patch.

Also, to narrow down potential reasons for the problem give the following a whirl -- after trying the above:
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>If you have the demo, do this, it's simple.

Copy and paste the game.dsc file from the "path_to_the_demo/bin/" to "path_to_the_full_game/bin/"

And now edit that file, and change the "full_screen ( true )" line to "full_screen ( false )"

Also, remove "demo" from the window title.

Seems that is working, but not officially supported.

This file is not present in my full installation, but seems that the game is still reading it.

If you don't have the demo, the game will succesfully start in windowed mode only creating a file called game.dsc in the bin folder where the game is installed with these contents.


full_screen ( false )

Let me know if that works.

10-12-2004, 03:25 PM
I tried all these things before, and tried it again now, result: the game seems to work, only this f****** mouse pointer does not show up.

My only conclusions are, that this is not a hardware problem, because home and office pc's hardware are completly different. As I mentioned before office pc it runs perfect under my normal "admin" user account - any other account (existing ones, created new ones) fails.

I also would have thought the game freezes, but when I transfer the save game I can see this mouse cursor, just able to move it up and down on the left side of the screen. I don't have to load a game (I would not be able to, because of this mouse problem) - the "options.m4o" file is enough to make the mouse appear...

I reported this to support...

regards, johoe

10-12-2004, 04:14 PM
Good to hear you reported it to support. I'm a bit confused as to what the problem is I guess.

The options.m4o file makes the mouse appear? This problem always happens on the system or only when transferring saved games?


10-13-2004, 12:51 AM
Got 2 machines. First I installed the game at work. Run without a problem. Played a little, made a backup of my save game folder to take it home for having a nice gaming evening.

Installed the game on my second machine no problem. Run the game - no mouse. Installed some new graphic drivers, reinstalled DirectX - no go. I imported my saved game, started the game - mouse pointer showed up as supposed. Very happy I moved the mouse - this thing jumped to left side of the screen and stayed there, just able to move it up and down, not right or left.

The other day, back in the office I decided to play a little Myst instead of work:-), using my "gaming" user account to free up more ressources - started the game - no mouse! Switched back to my "admin" account - no problems. Tried to figure out the differences (user priviledges, services etc) - found no solution for the problem.

So I have never been able to play the game on my home pc - can play it at my office with the "admin" account only!


10-13-2004, 02:54 AM
Thanks johoe -- that explains a lot more.

Sounds like an issue with the DirectInput interface. Can you verify for me which version of DirectX you have installed? Go ahead and reinstall the latest as a double check.

Also, what type of mouse do you have? Is it USB/PS2, what?

Thanks http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

10-13-2004, 05:38 AM
hehe, I reinstalled directx 9c first of course.

Unplugged and uninstalled all mouse devices. Reinstalled a simple MS wheelmouse PS/2. Normal I'm using a logi mx1000 on USB. Tried to use the USB -> PS/2 adaptor.

None of these things helps.

On the office pc the game is working using the "admin" account, does not matter which mouse is installed and it is not working using any other user account and other mice, drivers etc...

10-13-2004, 06:06 AM
ok maztec, here a new one:

two useraccounts at my machine:
"joho" - do the regular work whith this
"gamer" - gaming is done with this one
both accounts are "admins"

logged on as "joho" - game runs with no problems. starting the game with "run as" gamer - no mouse.

logged on as "gamer" - game starts with no mouse. starting the game with "run as" joho - working perfect!

Only conclusion for me: no hardware or driver conflicts - just something wired with the user profiles maybe ...

no ideas left!! you?

10-13-2004, 06:34 AM
Registry settings. Or something that doesn't carry between the different users.

Which user did you install the game with?

Check what all Myst IV related registry entries both suers have. All the same? Some different?


Might also want to look in the HKLM\SYSTEM\ControllSet*'s for MYST stuff..

See if there is something differnet under HK_USERS\*

Dunno, probably something in there somewhere. Heck, my bet is it's as simple as who has full write access and all attributes access to the journals and MyDocuments folder that the game was installed under.

10-13-2004, 01:47 PM
I've tried every user, admin, root admin, nothing works here. I've checked the security settings and added "everyone" full access to the folders, still no mouse cursor.

10-14-2004, 04:07 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR> By submitting a report to Ubi you will help aid them in recreating the problem so they can in turn create a solution for it in an upcoming patch. <HR></BLOCKQUOTE>

support should already be on it since 13th of august:

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>
Moderator &

posted Fri August 13 2004 16:15
I can't help, but I've summoned our tech mods over from the Uru forums... hopefully they can give some advice.



13th of august~!!! that's 2 months ago...

tip: next time get some beta-testers before releasing a game.

i'm off... checking again to see if this bug is fixed the moment the game is low-priced.

10-14-2004, 09:19 AM
LiquidTV, once again this is a different problem than you were originally observing.

Once again you don't even have the game yet. So you don't know if you're still affected by this problem or not.

And I am working on getting them to release an updated version of the Demo.

And, I am a volunteer, stop being a pain in my side.

10-19-2004, 12:46 AM
@LiquidTV: support told me, that they never heard about this problem before I reported it to them.

they have no solution, support reported it to development team.


02-16-2005, 02:55 PM
Well I hate to resurrect a long-dead thread, but I just bought the game and am having the same problem. I was hoping that it would be resolved in the full version (I had the issue in the demo) but it's still there, annoying as ever.

I've tried everything in this thread, even reinstalling my mouse to just vanilla windows drivers, but nothing works. I'm currently 40$ out on a game I can't play http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

08-03-2005, 04:37 PM
Hi all,

I'm havng exactly the same problem. The game worked perfectly on my system until I had a harddisk crash. I managed to make a copy of the save files. I installed a new harddisk and reinstalled the system. When I installed Myst 4 again I had no cursor in the startup screen. After copying my old save files I got the cursor but like with johoe. It is only moving up and down at the left side of the screen.

Even with patch 1.3 I have this problem. Has this been solved ?

08-05-2005, 12:09 PM
Suggestions, to do in the order shown:

1. Use your anti-virus software to do a complete virus scan of your hard disk, not just the bootup quickie.

2. Do complete spyware and adware scans of your hard disk, not just the bootup quickies. I use and recommend:
-- Spybot - Search & Destroy (http://spybot.safer-networking.de/en/download/index.html)
-- Ad-aware SE (http://lavasoft.element5.com/software/)

Both have free versions!

3. Clear your Internet Explorer caches.
-- a. Close all open applications.
-- b. Open a single Internet Explorer session.
-- c. Click on Tools > Internet Options.
-- d. Click on Delete Cookies > OK.
-- e. Click on Delete Files (check the 'Delete all offline content' box) > OK.
-- f. Click on Clear History > Yes.
-- g. Click on OK to exit.
-- h. Start Revelation.

4. Use Windows Explorer to search your hard disk for \temp, \tmp, and \temporary folders, and delete any files in these folders that aren't currently in use.
-- a. Click on Tools > Find > Files or Folders.
-- b. Type temp or tmp or temporary in the Named: box.
-- c. Click on the arrow at the right end of the Look in: box and then click on the disk drive to be searched.
-- d. Click on Find Now to start the search.
-- e. Click on the temp (or tmp or temporary) folders found to open them.
-- f. Delete any files in these folders that aren't currently in use.
-- g. Close Windows Explorer, and start Revelation.

5. Install the latest driver for your video chipset. Download the driver from your PC manufacturer's website, from the ATI website (https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27), or from the NVIDIA website (http://www.nvidia.com/content/drivers/drivers.asp).
-- a. Before installing the video driver, install or re-install DirectX 9.0c, available here (http://www.microsoft.com/downloads/details.aspx?FamilyID=0a9b6820-bfbb-4799-9908-d418cdeac197&DisplayLang=en), and reboot.
-- b. Disable your virus protection software before installing DirectX and the new video driver.
-- c. Before installing the new driver, especially if it's an NVIDIA driver, uninstall the current driver:
----- 1. Click on Start > Settings > Control Panel > Add/Remove Programs.
----- 2. In the programs list, find the current driver and click on it to select.
----- 3. Click on Add/Remove....
----- 4. When the removal process is complete, close Control Panel back to the Desktop.
----- 5. Reboot, and select 'Standard PCI Graphics Adapter (VGA)' when the Wizard asks which hardware to install a driver for.
----- 6. Reboot, then install the new driver.
----- 7. Reboot when the installation process is complete.

If you don't know exactly which video chipset you have, run DxDiag and save the results in a DxDiag.txt file. Then, look in that file under 'Display Devices - Card name:'. (See [Posting Guidelines] Help! I'm Having Technical Problems and I Don't Know Why!?! (http://forums.ubi.com/eve/ubb.x?a=tpc&s=400102&f=580100736&m=1291074922) under To post a DxDiag report for a how-to).

6. Download and install the latest driver for your mouse.

7. Do a complete/full Revelation re-install, from a clean boot and to a User Account with full privileges. First, uninstall Revelation using Control Panel's Control Panel's Add or Remove Programs.
-- a. Copy the Program Files Revelation \save folder or the \My Documents\myst4-revelation savegames folder to another location on your hard disk.
-- b. Remove Revelation.
----- 1. Click on Start > Control Panel, then double-click Add or Remove Programs.
----- 2. In the Currently installed programs box, click on the Myst IV - Revelation entry.
----- 3. Click on Change (or Change/Remove).
----- 4. If prompted to confirm the removal of the program, click Yes.
----- 5. Close Control Panel back to the Desktop.
-- c. Use Windows Explorer to remove any remaining Program Files Revelation files and folders. For example, if it exists, delete the folder "\UBISOFT\Myst IV - Revelation" in "C:\Program Files\UBISOFT\Myst IV - Revelation".
-- d. Reboot, and log into Windows with full Administrator privileges..

Then, do a complete/full Revelation re-install, to a User Account with full privileges:
-- a. Log into Windows with full Administrator privileges.
-- b. If you didn't do so above, use Windows Explorer to search all drives for \temp, \tmp, and \temporary folders. Delete any files in these folders that aren't currently in use.
-- c. Click Start > Run.
-- d. Type msconfig in the Open box, then click on OK.
-- e. Click on Selective Startup on the General tab.
-- f. Under Selective Startup, clear the check boxes for:
----- 1. Process SYSTEM.INI File
----- 2. Process WIN.INI File
----- 3. Load Startup Items
-- g. On the Services tab, click the Hide All Microsoft Services check box, then click Disable All.
-- h. Click on OK, and then click on Restart.
-- i. Using Start > Run, install Revelation, accepting the defaults for a complete install.
-- j. Restore the settings you changed in steps c. through h.
----- 1. Click Start > Run.
----- 2. Type msconfig in the Open box, then click on OK.
----- 3. Click on Normal Startup - load all device drivers and services on the General tab.
----- 4. Click on OK, and then click on Restart to reboot into normal Windows.
-- k. Copy the saved \save folder to its proper place in the Revelation Program Files or \myst4-revelation savegames to the \My Documents folder.
-- l. Play Revelation. If the game doesn't play properly, install the patches.

8. Re-install the Revelation patches, both available here (http://www.ubi.com/US/Downloads/Info.aspx?dlId=708).

9. You may have processes or applications running in the background that are interfering with Revelation. Use Windows Task Manager to close everything except for Explorer.exe, Ctfmon.exe, and whatever your hardware needs before starting Revelation:
-- a. Press Ctrl+Alt+Del once and then click on Task Manager.
-- b. Select the Applications tab.
-- c. Click on the desired application to highlight it.
-- d. Click on the End Task button at the bottom of the tab.
-- e. Repeat this procedure until all unnecessary applications and processes are closed. If you aren't sure which background processes or applications can be closed using Task Manager, check out the AnswersThatWork Task List Programs index (http://www.answersthatwork.com/Tasklist_pages/tasklist.htm). The most common tasks are described, and which ones are essential and which can be safely closed are noted.
-- f. Play Revelation.


04-23-2012, 04:07 AM
I searched for years for a satisfactory solution for the disappearing cursor issue. In the end, it has to do with the default DCOM security permissions that were changed as of XP Service Pack 2. This MS article (http://msdn.microsoft.com/en-us/library/windows/desktop/ms679714(v=vs.85).aspx) explains the registry changes made that you can roll back to their prior settings, on XP or Win7.

This makes Myst IV work perfectly, with no need to install in one user and then create another, etc (fixes that never worked for me, btw.)

Because this decreases security on your machine, you might want to restore the default settings when not gaming. In my case I installed XP in a virtual machine supporting DirectX and play on that compromised yet sandboxed environment.

I just enjoyed the intro video for the first time in years, so no time to write up a guide for you just now.