PDA

View Full Version : renown bug?



Weisia
12-22-2008, 03:47 AM
Here is my problem:

I ran into a huge convoy with two large tankers and two medium tankers ( and a lot of cargo ships).

I hit one medium tanker and it blew up. I also fired a torp on the second medium tanker (scored a hit) and also a FaT and this one hit the large tanker.

The medium and large tanker were still able to continue course although i expected that they would sink, all i had to do is wait. So I stalked to large tanker until it finally sank.

But: the 'ship sunk' icon did appear on the map but not in my log. In previous patrols I had a similar problem: the 'ship sunk' icon did not appear on the map, but the tonnage was included in my log. So do I now get the renown of the juice tanker or not? And is there any patch or something like that to fix this buggie.

edit:
I know realize that this whole situation might be the result of me altering the renown value's

finally I got the targets I have been searching for after 3 patrols of stormy weather and now this happens...

Weisia
12-22-2008, 03:47 AM
Here is my problem:

I ran into a huge convoy with two large tankers and two medium tankers ( and a lot of cargo ships).

I hit one medium tanker and it blew up. I also fired a torp on the second medium tanker (scored a hit) and also a FaT and this one hit the large tanker.

The medium and large tanker were still able to continue course although i expected that they would sink, all i had to do is wait. So I stalked to large tanker until it finally sank.

But: the 'ship sunk' icon did appear on the map but not in my log. In previous patrols I had a similar problem: the 'ship sunk' icon did not appear on the map, but the tonnage was included in my log. So do I now get the renown of the juice tanker or not? And is there any patch or something like that to fix this buggie.

edit:
I know realize that this whole situation might be the result of me altering the renown value's

finally I got the targets I have been searching for after 3 patrols of stormy weather and now this happens...

Foehammer-1
12-22-2008, 08:39 AM
Yes, it is a bug due to bad weather.

The game registers the "kill" based on the last damage received. If you made the ship reach its HP if you will, then you'll get the credit. If you're firing on a ship with a deck gun, and a battleship on the other side tries to fire on you and scores the killing blow on the ship by accident, you won't get the kill.

Bad weather tends to damage some ships a little bit. The longer you wait, the more damage accumulates. And the weather gets the kill. Dumb, I know, but that's how it works.

BUT

You can also use this to your advantage (mind, it doesn't work with GWX mods). Fire on a destroyer with the deck gun and score a hit (from far far away). Then dive to persocope depth. the DD will chase you. Make sure it hits the flak gun on your wintergarten. It's hard but doable.
The ship will sink, but the damage doesn't count if it rammed you. BUT, you caused some damage with the deck gun earlier, so you'll get the kill, and only have a destroyed flak gun.

Phew, hope that made sensehttp://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

[edit] There are some ships that happen very very rarely (I've had about 4, one of them a passenger liner http://forums.ubi.com/groupee_common/emoticons/icon_mad.gif), that don't register as a kill. Ever. No matter what you do. Just reload a saved game and let them go.

Privateer_GWX
12-22-2008, 06:27 PM
Things like this is what I try to track down and solve.
It's a thorn in all modders sides to have things like this happen.
(If We don't understand why it happens?
it just bugs the crap out of us!!)
After GWX 3.0 is released, I'll look closer at this.

Anyone that can point out a ship that does this EVERY time?
Please let me know of it.