PDA

View Full Version : X1650: No perfect water in DirectX and near total blackness in OpenGL



flakwagen
10-06-2007, 08:27 PM
I just reinstalled everything on my computer. When I use OpenGL mode, everything but the airplane and the sun is black. When I use DirectX mode, I can't get perfect water. I've always played with maximum settings, so I know it is possible. I have an ATI X1650 AGP card with 256mb of RAM. Any useful information would be appreciated. I've played for years without encountering this problem.


Flak

flakwagen
10-06-2007, 08:27 PM
I just reinstalled everything on my computer. When I use OpenGL mode, everything but the airplane and the sun is black. When I use DirectX mode, I can't get perfect water. I've always played with maximum settings, so I know it is possible. I have an ATI X1650 AGP card with 256mb of RAM. Any useful information would be appreciated. I've played for years without encountering this problem.


Flak

flakwagen
10-06-2007, 08:39 PM
I get to answer my own post. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif I deleted the 'render opengl' portion of my confi.ini and reran the Setup program. Some more specific ATI card choices made the difference- they're a bit vague as to whether they work specificall with an X1650, but if you switch to the "Video" tab and select the option that begins with "X800/9800.. (etc)" that'll solve water rendering problems.

Flak

MaxMhz
10-10-2007, 12:55 PM
This works for my X1950:
<pre class="ip-ubbcode-code-pre">

[Render_OpenGL]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=1
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1

TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=0
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=0
TexFlags.TextureShaderNV=0

HardwareShaders=1

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
Water=2
Effects=1
ForceShaders1x=0

PolygonOffsetFactor=-0.0625
PolygonOffsetUnits=-1.0
</pre>

Alien-Evo
10-14-2007, 05:05 AM
hey,buddy,there is something you need to know

from il2 fb to now 4.08,whatever video card you use,if you set the "multitexture" checkbox in il2setup.exe empty,then there will always comes the black screen(but planes and sun) issue.


and I seems to remenber that IL2 can not run Perfect mode in DirectX mode

stansdds
10-14-2007, 07:51 AM
You will never get perfect water in DirectX as perfect water can only be rendered in OpenGL.