PDA

View Full Version : Plz help me with water



domenlovrec
12-30-2005, 03:28 PM
hi

I have GeForce6800GT, and i've trying to set water=3, but as you can see...

This is a result:

http://freeweb.siol.net/gotovlje/img/water.JPG


Cause i don't know what to do i paste this:

[Render_DirectX]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=0
TexFlags.TexCompressARBExt=1
TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=0
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=0
TexFlags.TextureShaderNV=0

HardwareShaders=0

Shadows=3
Specular=3
SpecularLight=3
DiffuseLight=3
DynamicalLights=3
MeshDetail=3
VisibilityDistance=3

Sky=3
Forest=3
LandShading=3
LandDetails=3

LandGeom=3
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=4
ForceShaders1x=0
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0

[Render_OpenGL]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=3

Shadows=3
Specular=3
SpecularLight=3
DiffuseLight=3
DynamicalLights=3
MeshDetail=3
VisibilityDistance=3

Sky=3
Forest=3
LandShading=3
LandDetails=3

LandGeom=3
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=3

ForceShaders1x=0
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0
Water=3
Effects=3
[FBVWPS]
Path=c:\program files\igre\ubi soft\il-2 sturmovik forgotten battles\fb view plus
[DeviceLink]
IPS=192.168.1.2
port=10000

This is how my graphic part of conf file looks like.

chris455
12-30-2005, 03:49 PM
Hint: requests like this are best posted in community help- http://forums.ubi.com/images/smilies/16x16_smiley-wink.gif

BUT- since we're already here:
PF is not recognizing the command

HardwareShaders=3

Because it is a switch. Set to "1" for "on" or "0" for "off".
As it is now, the program doesn't know what you're telling it to do, so it is defaulting to

HardwareShaders=0

This makes it impossible to acheive Perfect water.

Set it to:

HardwareShaders=1

and all should be well.

JSG72
12-30-2005, 04:00 PM
Hardwareshaders=1? On these settings?
'Twill be moved.
You cannot run all settings at =3
on a 6800gt and expect anything!
Card/CPU would doubtfully handle it at anywhere near playable. http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

domenlovrec
12-30-2005, 04:51 PM
Yes, i know it won't work fast with everything on 3. Now I have problem, cause i don't have default conf file...

Tnx for the water, it's perfect now (but too low FPS).

chris455
12-30-2005, 04:59 PM
Then switch to "excellent" in the in-game settings and work from there-
but first, try
Water=0
in config.ini
may do the trick-

Brain32
12-30-2005, 05:23 PM
Don't give up yet, go to here: http://forums.ubi.com/eve/forums/a/tpc/f/63110913/m/8891044193
Download those dll's, use water=2(see my post in that thread), you should have very good fps with that card, IF the rest of you rig corresponds to your gfx card power...