PDA

View Full Version : Assassin's Creed Brotherhood - Stuttering on a High End System



Rea1SamF1sher
05-10-2011, 07:39 AM
Hello everybody!

I have some stuttering issues with ACB and actually with the other AC titles too. The thing is it's really only these games where I have FPS problems. I have done a lot of already like turning of Anti Vir or the defragmentation of my hard disk but it hardly helps. The game doesn't run fluently. The stuttering is mostly noticeable when moving the mouse. It also looks like there is a problem with handling so much NPCs although my PC should be more then capable to manage that. I have also another PC title from Ubisoft where I haven't got such problems, which is Splinter Cell Conviction. I want to solve this issue not just because I want to have a better entertaining experience but also to be able to record and make Walkthroughs with Fraps.

My System:

Windows 7 Ultimate 64Bit
Intel i5 750 @ 4x 3,56 Ghz
Sapphire Toxic HD 5850 1024MB (Catalyst 11.4)
G-Skill 4096MB (2x2048MB)
Gigabyte GA-P55-UD4 (Bios: F9 up to date)
1000 GB harddisk

Edit:
This is maybe the major problem for me:

Assassin's Creed: Brotherhood Mouse Acceleration / Sensitivity

Not only does AC:B suffer from mouse problems, but so does Assassin's Creed: 2. It may feel like the mouse movement is lags / is lagging, or is jumpy / jumping around. Some people call it mouse movement stuttering. At the moment, we do not know of a good fix for this, but we're actively looking. Many games allow you to modify their INI files to fix this, but this very well may not apply to this game, nor Assassin's Creed 2. Let us know if you have any solutions for this. We will be actively looking.

Johnny42320
05-10-2011, 08:01 AM
If this problem only happens when you move the mouse, it's not just you who suffers from such an issue. You may find this problem in many other games. As far as I know professionals have been working on this and unfortunately waiting is our only option http://forums.ubi.com/images/smilies/16x16_smiley-sad.gif
Be patient.

KingDaniel0
05-10-2011, 08:11 AM
Originally posted by Andre202:
Hello everybody!

I have some stuttering issues with ACB and actually with the other AC titles too..

Yes, this is a Known with this game. There are few more threads on this Same subject......

Which Mouse Model are you using, by the way ? Some Gamers, not all, have told that they don't face any kind of LAG/stutter while gaming, and they were using a simple Mouse Model, as told by them. So maybe this Lag is related to some particular Mouse Model/series ? Not sure though.

Have you updated all your Drivers ? Is your Game Patched to the Latest version ?

In the meantime, can you try this 'Old-School' method ? I know this is not needed for AC:B, and it supports Win 7 too, but just give it a try.

Play the Game under 'Windows XP SP2 Compatibility Mode', by making a shortcut of the Game's EXE i.e. ACBSP.exe. But when you do this, also look here under the Compatibility TAB, and check and tick the options 'Disable Desktop Composition', and 'Disable Visual themes'. Now click on this .exe and run the Game.



------------------------------------------------------------------------------

Rea1SamF1sher
05-10-2011, 08:28 AM
I have the Logitech MX518. No special drivers for the mouse, it's just plugged in with USB. I also know there are a lot of threads about that, I want to push that subject further though. I don't know if Ubisoft already acknowledged the mouse problem. I don't have these mouse problems in any other game except the AC games.

I will try out the Compatibility Mode. All drivers are up to date, just as ACB is.

Thanks for the tips, I will report soon if it helped.



EDIT: The Compatibility Mode didn't help much.

Bibendus
05-14-2011, 01:54 PM
I have the same mouse issue, it's not a normal mouse acceleration, its WORST!
Moving the mouse slowly will barely rotate the camera while moving the mouse a bit will cause a heavy camera rotation of 180 and btw the rotation is quite choppy.
That makes the game UNPLAYABLE in single player... in multiplayer it works damn good!

I'm using a razer lachesis

RasGhi
05-14-2011, 09:16 PM
I have the same stuttering issue.

Bibendus
05-15-2011, 04:55 PM
I tried to open a question in the ubisoft support section... let's hope someone will answer :|

http://ubisoft.custhelp.com/ap.../detail/i_id/1220318 (http://ubisoft.custhelp.com/app/account/questions/detail/i_id/1220318)

Michaeljcox24
05-16-2011, 11:03 AM
it's a common fault with the game. It doesn't really stutter with the game pad, but performs nowhere nearly as good as it should on a high end machine.

Being as a complete engine overhaul would be required, I don't think we will see a solution any time soon (and possibly not even for assassins creed revelations tbh mate)

RasGhi
05-17-2011, 03:23 AM
Originally posted by Michaeljcox24:
it's a common fault with the game. It doesn't really stutter with the game pad, but performs nowhere nearly as good as it should on a high end machine.

Being as a complete engine overhaul would be required, I don't think we will see a solution any time soon (and possibly not even for assassins creed revelations tbh mate)

Seriously? Oh c'mon Ubisoft. You made this problem now fix it. I want to play AC:B so bad. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

iN3krO
05-18-2011, 01:06 PM
Try to open task manager and see how much memory ac:B cost to your pc see too how much is the CPU % used by it...

I don't know if this could apply to you but GTA:SA had a problem with MultiCore CPU and maybe AC do so with i5's CPUs... try to disable CPU 1, 2 and 3 only letting CPU 0 manage the game...

Also, if you have any game booster try to desactivate it...

Could you tell me if you play AC via steam or non-steam?

Rea1SamF1sher
06-03-2011, 02:34 PM
I play non-steam. The thing is, the game runs actually very fluent (50-60FPS all time) but if I move the mouse it's starting to feel "laggy".

This is the case for Assassin's Creed 2 and the SINGLEPLAYER of Assassin's Creed Brotherhood. It's not a problem in Assassin's Creed 1, nor in the Multiplayer of Assassin's Creed Brotherhood. Which is quiet ridicolous, isn't it? Because both MP ans SP use the same engine.

But one thing all three titles have in common are the big stuttering problem when I try to record the game with Fraps. I cannot simply because it's lagging all the time. I imagine it's because of the huge .forge data the game loads from the Hard Disk. So when I start recording there is a confrontation in loading the .forge data and in writing the uncompressed video data on the Hard Disk at the same time. Nowhere did I have such big stuttering problems while recording with Fraps. Even GTA IV (which is really bad optimized for PC) runs "smoothly".

machinista
06-03-2011, 02:46 PM
Yup, I have the exact same problem. I'm on a high-end PC that runs new releases on near-max settings very fluidly, and yet the single-player of AC:B is all messed up. It's annoyed me to the point where I've completely given up on trying to play the game and just stick to the multiplayer, which for some reason works perfectly.

Rea1SamF1sher
06-03-2011, 05:28 PM
Try to change the mouse sensitivity, both to 1 or 10. It doesn't really fix the issue but I haven't got as much laggs anymore.

iN3krO
06-03-2011, 05:54 PM
Originally posted by Andre202:
I play non-steam. The thing is, the game runs actually very fluent (50-60FPS all time) but if I move the mouse it's starting to feel "laggy".

This is the case for Assassin's Creed 2 and the SINGLEPLAYER of Assassin's Creed Brotherhood. It's not a problem in Assassin's Creed 1, nor in the Multiplayer of Assassin's Creed Brotherhood. Which is quiet ridicolous, isn't it? Because both MP ans SP use the same engine.

But one thing all three titles have in common are the big stuttering problem when I try to record the game with Fraps. I cannot simply because it's lagging all the time. I imagine it's because of the huge .forge data the game loads from the Hard Disk. So when I start recording there is a confrontation in loading the .forge data and in writing the uncompressed video data on the Hard Disk at the same time. Nowhere did I have such big stuttering problems while recording with Fraps. Even GTA IV (which is really bad optimized for PC) runs "smoothly".

There are 2 options:

1 - You are not used to less than 30 fps? (i play with 24 fps o.o)

2 - Your GPU/CPU are not fully updated...

For the mouse aceleration, i don't suffer this problem so i cant tell you anything o.o

Rea1SamF1sher
06-03-2011, 06:59 PM
Originally posted by daniel_gervide:
1 - You are not used to less than 30 fps? (i play with 24 fps o.o)
I am used to low FPS, if I really have a crappy machine. Which I had a year ago. It could run Assassin's Creed on Max though. I played Splinter Cell Conviction with 17 FPS. The thing is I have over 50 FPS and it still feels laggy, because of the mouse stuttering, I don't know if you have that bug. There is also the porting thing which you notice in all Ubisoft PC games. If the game goes under 50FPS, it feels like your are playing with 20FPS.


2 - Your GPU/CPU are not fully updated... Did you update your CPU once? Try to find drivers for Intel i5 750. Even on the official website they offer just Intel Graphics driver but not an actual processor driver.
For the GPU I have Catalyst 10.4 since 10.5 is making problems.

robertverr
06-23-2011, 10:09 PM
My system is:
Windows 7 64, I7 920, 6 gigs ram, GTX275, updated drivers.

Assassins Creed II was working absolutely flawlessly at max settings. Brotherhood is totally unplayable. Even the very first screen where you must press enter to go to the menu screen is stuttering, same thing in the menu.

The game is unplayable on my system where the actions stops for few longs seconds and this happens non stop.

This is simply unplayable and it does the very same thing with all graphics options at minimum.

Update:

Uninstalling the game and reinstalling now works fine at max settings. The only difference, it appears that the first time, I closed the update box prematurely. The patching process may have not completed . Now all is fine with me. Good luck to those who stil have a problem, the game is awesome.

sblubfouffy
08-31-2011, 02:36 PM
I've got a high end PC (all actual games work well with max settings), and I have horrendous stuttering/freezing problems with AC Brotherhood... it's just unplayable!

I've tried anything : reducing graphic options, XP compatibility mode, running as admin, reducing my 8-core processor to 2-core only, turning off my internet and anti-virus, and most combinations of all of that... but nothing of all these worked. Also, I've updated the game to v1.0.3, and my GPU drivers are up to date.

In desperation, I tried to use cracked files by Skidrow, replacing the original .exe, and to my surprise, I've no more stuttering, the game play very smoothly with all settings to max!

So, I come with a question, how is it that original game works so lamely, and that it works fine with cracked files?

I sincerly hope Ubisoft comes with a good patch adressing this issue soon, as I would prefer playing the game without being "illegal"!

Michaeljcox24
08-31-2011, 03:01 PM
if you've paid for your own copy of the game then in my eyes, you can do what you want.

sblubfouffy
08-31-2011, 04:00 PM
Yes, I've bought my own copy of the game (Auditore Edition)... But I don't think it's normal having to resort to a cracked file to be able to play a legally acquired game!

Rea1SamF1sher
09-04-2011, 07:23 AM
Originally posted by sblubfouffy:
Yes, I've bought my own copy of the game (Auditore Edition)... But I don't think it's normal having to resort to a cracked file to be able to play a legally acquired game!
Maybe you just found the problem. In AC1 after a while the game would try to upload reports when you are in a fight with a group of enemies. These uploads caused stuttering or more often laggs and there may be the possibility that AC2 and ACB also tries to upload a report of what actions you are using more often to give the devs a better feedback. Now we need to find out if ACB or AC2 tries to upload these datas trhough the Ubi Launcher or through another IP address and in the end we could block this IP address so there won't be any stuttering anymore.

Michaeljcox24
09-04-2011, 11:54 AM
Bottom line is the game is massively CPU intensive and doesn't run very well unless you have a high spec machine. For the level of graphical intensity compared to crysis, or warhead, or something like that, you get a lot less bang for buck for an equally specced rig.

TheLeoCrow
09-08-2011, 05:13 PM
Originally posted by Andre202:
Sapphire Toxic HD 5850 1024MB (Catalyst 11.4)


Try updating to catalyst 11.8. That mostly solved it for me after I installed my new gpu (HD 6770). Before updating it, i would go from 40 to 3fps when i moved the mouse. Now i go from 40 to 24 which is better, though not perfect.

AdsarthaM
09-09-2011, 01:15 PM
Bottom line is the game is massively CPU intensive and doesn't run very well unless you have a high spec machine.

Yes that's true. My game improved a lot when I overclocked my core i5 processor to 4 Ghz, although at first I thought that my gpu might be the bottleneck (nvidia GTX 460). With processor overclocking and also gpu overclocking to 850 Mhz runs perfectly with highest graphics settings and high resolution (1920*1080) - fps's shown by fraps have been 30 at lowest and usually much higher.

Rea1SamF1sher
09-11-2011, 04:54 AM
Originally posted by TheLeoCrow:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Andre202:
Sapphire Toxic HD 5850 1024MB (Catalyst 11.4)


Try updating to catalyst 11.8. That mostly solved it for me after I installed my new gpu (HD 6770). Before updating it, i would go from 40 to 3fps when i moved the mouse. Now i go from 40 to 24 which is better, though not perfect. </div></BLOCKQUOTE>
I have Catalyst 11.7 because 11.8 seems to have some problems. So I am waiting for the Catalyst 11.9 to release.

Overclocking doesn't solve the problem for me. I am not able to go up to 4Ghz though since I don't know how to overclock CPU and RAM asynchronous.

Maybe I can contact Boris who is the developer of the ENB Mod for GTA IV. He was able to solve a similar stuttering issue in the new Deus Ex Human Revolution. The problem is the shader which the game is using. He says it may be the problem since it isn't coded the way it should be in a PC game. Now I am not an expert here but does the Multiplayer of ACB use another shader then the Singleplayer? Multiplayer works fine but the Singleplayer doesn't.

Ben21XX
11-21-2011, 09:26 AM
For all of us PC users - If your PC meets and exceeds ACB hardware requirements, but yet your PC is suffering from lots of lags and stuttering.
I fixed this issue by doing the following:
1. start the game till you see the "Start"
2. minimized the game.
3. Open task manager
4. Under processes find ACB and set to use the following CPUs, 0,2,4,6..etc.

I think the problem may be with all i7,i5 and i3 Intel. the game does not uses the Hyper-Threading Technology.

Rea1SamF1sher
11-24-2011, 04:22 AM
The Problem isn't as noticeable when I follow your instructions. But I think it has to do with something that causes negative mouse accelaration and so you have this "stuttering" feeling. This problem isn't present in the Mutliplayer part, so actually it can't be the Hyper-Threading Technology. When you disable some CPUs the game won't reach very high FPS. The stuttering isn't as noticeable at 30-40 FPS but if you play with 60 FPS and above you will notice the stuttering again.

Rea1SamF1sher
03-31-2012, 01:47 PM
Is there anyone who is able to do a mod or something similar to disable the negative mouse accelaration? I think that's the cause of the whole mouse stuttering problem and it seems like they won't fix it for AC3 too. The reason I believe that this is the cause of stuttering is that you can play with a controller or with the arrow keys without any problems while when moving with the mouse it causes stuttering since you move the mouse always with a different speed and the game cannot convert this properly, so we get the stuttering!

spectatorx
04-01-2012, 02:58 PM
Did anyone of you having intel i3/i5/i7 cpus tried to disable hyperthreading? Usually disabling it solves problem with stuttering in assassin's creed serie, battlefield 3 and few other games.

Rea1SamF1sher
04-03-2012, 07:29 PM
Not all Intel CPU from the i3, i5 and i7 series have Hyper Threading. It doesn't solve the problem and it's actually a known problem under the PC Community that the Mouse Controls are very jumpy and not really clean.

Crowtje
04-03-2012, 10:36 PM
Read every forum, and tried about every setting, But Brotherhood kept stuttering.

I have a Windows 7 x64, i7 920, clocked at 3,4Ghz. 6GB memory and a GTX 285 graphics card.
Running ACBH at ultra low crappy graphics gave the same stuttering result as everything completely maxed out.

At this point I'm running ACBH:
- As administrator.
- In XP SP3 compatibility mode.
- NVIDIA Inspector Profile for ACBH, with Antialiasing compatibility set to: 0x000012C1

What fixed the problem? Setting CPU affinity to only the first four (0,1,2,3) cores / threads / logical CPU's reported by Windows.
Every graphic setting is on max en the game runs absolutely smooth... the i7 is probably to powerful ?!?

Staring the game with this command in the shortcut:
< C:\Windows\System32\cmd.exe /c start "Assasins Creed - Brotherhood" /HIGH /affinity 0f "C:\Program Files\Assassin's Creed Brotherhood\ACBSP.exe" >

/HIGH is optional, for me the game runs just as good with or without priority set.
0f is the hexadecimal value for CPU's 0,1,2,3 (3 = cpu 0,1 # f0 = cpu 4,5,6,7 # fc = cpu 2,3,4,5,6,7)

Hope it helps!

Rea1SamF1sher
04-05-2012, 04:12 AM
It doesn't work for me. The stuttering is noticeable when playing with the mouse and I think it's only fixable if Ubi gives the option to turn off the negative mouse accelaration.

Crowtje
04-10-2012, 09:26 PM
Read every forum, and tried about every setting, But Brotherhood kept stuttering.

I have a Windows 7 x64, i7 920, clocked at 3,4Ghz. 6GB memory and a GTX 285 graphics card.
Running ACBH at ultra low crappy graphics gave the same stuttering result as everything completely maxed out.

At this point I'm running ACBH:
- As administrator.
- In XP SP3 compatibility mode.
- NVIDIA Inspector Profile for ACBH, with Antialiasing compatibility set to: 0x000012C1

What fixed the problem? Setting CPU affinity to only the first four (0,1,2,3) cores / threads / logical CPU's reported by Windows.
Every graphic setting is on max en the game runs absolutely smooth... the i7 is probably to powerful ?!?

Staring the game with this command in the shortcut:
< C:\Windows\System32\cmd.exe /c start "Assasins Creed - Brotherhood" /HIGH /affinity 0f "C:\Program Files\Assassin's Creed Brotherhood\ACBSP.exe" >

/HIGH is optional, for me the game runs just as good with or without priority set.
0f is the hexadecimal value for CPU's 0,1,2,3 (3 = cpu 0,1 # f0 = cpu 4,5,6,7 # fc = cpu 2,3,4,5,6,7)

Hope it helps!

*SIGH*

I thought I had it fixed,.. somehow setting affinity to the first four CPU's doesn't do the trick anymore.
Change affinity to the "real" Cores 0,2,4,6 avoiding multithreading as posted earlier by Ben21XX. Loads look better, play through is smooth again.
Restarting the game ends up one core overloaded en total crap again, restarting again and everything is fine... I'm confused......
Now playing without problems, with affinity set to hex 55 = cores 0,2,4,6 I hope it lasts.

Btw. I'm using a wireless MX620 logitech mouse, without problems.

Rea1SamF1sher
04-10-2012, 10:59 PM
Do you have the Drivers installed for the mouse? I have a MX518 and do have these mouse stutterings.

Crowtje
04-11-2012, 01:40 PM
I have the Logitech Setpoint drivers installed, a pretty recent version, I'm using custom buton assignment, the rest is default.
I did have a jamming/non responsive mouse in other games, I solved this by putting the radio on an USB extension cord, hidden behind my monitor.
There is lots of metal in the frame of my desk, I believe it interfered with the mouse signal, it is not completely flawless but it works fine now.

For me it is not a mouse issue, when the system stutters, I see one CPU spiking 100%, GPU usage drops to zero, when the game resumes and feels decent again, CPU is at normal to high load and GPU is also under normal load.
Yesterday evening I played fine for hours, affinity set to every first (real) cores, so 0,2,4 and 6 load evenly balanced and no weird spikes.
When the stutter occurs usually I also see extreme loads on one or two CPU's instead of equally distributed load. Quieting and restarting the game seems to solves this. :confused:

(Game keeps being weird with it's multicore: Sometimes the games runs crap, from the Task Manager I switch CPU affinity from 0,2,4,6 to 1,3,5,7 press OK, change affinity back to 0,2,4,6 and press OK again. Afterwards the game runs fine on the cores I originally started the affinity with ?!?)
:confused: :confused: :confused:

Tried this for several days, It's not as clean as I would like, but at least I now have a method that works 100% for me with this game so I can play without annoying hikkups.

leomontenegro6
10-09-2014, 12:54 AM
Bought ACB today on Steam, and I confirm it's stuttering even on high end systems.

Here's my specs:

- MOBO ASUS Maximus 3 Formula;
- Intel Core i7 processor with 3.5ghz;
- 8gb RAM Memory (DDR3);
- NVidia Geforce 9600GT.

Using these specs, I could play both AC and AC2 games. However, the only workaround I found was changing process affinity, in a way to force ACBSP.exe to use only two cores. It's working, but not out of the box as it should be, and pressing Ctrl+Alt+Del just to find ACB.exe process and change its affinity everytime I want to play the game, it's really awful.

Why isn't there any update from Ubisoft to fix those issues?

Anykeyer
10-09-2014, 07:22 AM
Doesnt stutter for me and I dont use any affinity workarounds. If you have to its likely caused by your motherboard. Try updating BIOS, disabling HT and/or core parking.
And 9600 is low end GPU by now. I remember that ACB used to run good enough only with 8800/9800 or faster newer card.

YazX_
10-10-2014, 11:59 AM
Doesnt stutter for me and I dont use any affinity workarounds. If you have to its likely caused by your motherboard. Try updating BIOS, disabling HT and/or core parking.
And 9600 is low end GPU by now. I remember that ACB used to run good enough only with 8800/9800 or faster newer card.

Correct, i had 8800 GT and the game ran very smoothly, 9600 is low end now as you said and i wonder on what resolution he is playing on,

leomontenegro6
10-10-2014, 11:46 PM
Doesnt stutter for me and I dont use any affinity workarounds. If you have to its likely caused by your motherboard. Try updating BIOS, disabling HT and/or core parking.
And 9600 is low end GPU by now. I remember that ACB used to run good enough only with 8800/9800 or faster newer card.

I don't think it's something related to my motherboard. But let me explain my issue better:

Recently I beated AC2 with this same computer, and with my Geforce 9600GT on 1440x900 resolution and most graphic settings on medium, I could play the entire game on at least 30fps.

However, on ACB I noticed the game tries to stay on 30fps, but on each 2 seconds, the framerate drop to 5fps, thus the stuttering. Maybe that stuttering happens only on non-high end GPUs, but it still is a weird issue.

Assuming this issue disappeared after changing process affinity, the only thing I can deduce is that the PC game port of this game is a bit lacking. I mean, why this issue is happening on ACB but not on AC2, since both games seems to use same engine?

For now, I can simply create a custom shortcut that changes affinity before running the game. But a fix update would be very welcome (although the game is rather old).

strigoi1958
10-11-2014, 03:28 AM
Unfortunately as Yaz pointed out the 9600 gt is nearly 7 years old and although ACB came out over 3 years ago Nvidia said the 8800 would almost be minimum requirement. Your system is not bad but your Graphics card is very weak. If money is tight you could pick up an nvidia 560 Ti on ebay pre- owned for 20 / 25 euros and up and that is far superior

Anykeyer
10-11-2014, 08:31 AM
The engine is very similar but they put some visual upgrades. The most apparent changes are more complex lighting/shadow system and much higher resolution textures. ACB uses about 1.5x more GPU power and VRAM
Most affinity problems are caused by motherboard failing to properly sync CPU cores. But In your case I would start with GPU first.

jeffies04
10-11-2014, 11:22 AM
I just went back and played the first couple of hours of ACB today, and didn't have any problems. It ran topped out for having v-sync on with no suttering, even on the horses. My old system when I first played ACB only dropped in frames a little bit when I galloped through the countryside on a horse. I'm running a EVGA 780 FTW, an i7-3770k, and 16GB RAM.

I don't think this is a universal problem.

Locopells
10-11-2014, 03:08 PM
Is anyone running this on a SSD?

Alphacos007
10-11-2014, 03:44 PM
I am, why?

Locopells
10-12-2014, 12:00 AM
Can you gallop in the main Rome map? I mean actually full gallop, not just the high speed trot.

Basically, I want to know if this:


https://www.youtube.com/watch?v=iWcIEkrsRks

works.

Alphacos007
10-12-2014, 02:54 AM
I'll check it out as soon as I can, I'm not at home right now, but I believe I could always do that, even when it wasn't installed in the SSD.

Locopells
10-12-2014, 03:33 AM
Thanks. Maybe you always had a high speed HDD? I've just never spoken to anyone who had actually done this...

Alphacos007
10-12-2014, 04:02 AM
Just tryed it, I do indeed have the Gallop option, as seen on the screenshot:

http://puu.sh/c8WjZ/86d384aecb.jpg

I just deleted the game and put Steam to install it on the HDD just to check out if the Gallop option appears there as well. It'll finish the download in around half an hour so I'll post the results as soon as it finishes.

Edit: OK, just confirming that when installed on the HDD, the Gallop option does not appear.

http://puu.sh/c8ZUw/701f8feea0.jpg

I had never actually heard about that difference, very interesting to know haha

Anykeyer
10-12-2014, 08:31 AM
It appears that ACB checks loading speed before allowing galoop. The good part - there are no explicit checks for SSD or brands (that video is an ad of Intel SSDs after all)
Im using dual samsung hdds in raid 0 aided by a single samsung ssd serving as SRT cache. For all software without low level access it looks like a single hdd volume. Dual samsung hdd in raid 0 is faster than any single sata hdd on the market but its not enough to see galoop option, it doesnt appear if the game isnt cached first. SRT cache works automatically so the only thing I have to do is restarting ACB. Then galoop option appears and stays here for as long as ACB remains in cache (there are no time limits, only size of other apps I run matters).

Locopells
10-12-2014, 12:14 PM
Thanks 007, that's excellent to hear - and thanks AK, that answers my other question about brands and unlocking procedure for the feature!

Looking to get a SSD in my next rig (when I can afford it...), so good to know!

strigoi1958
10-12-2014, 01:02 PM
I wonder.... if you had enough ram and made a ramdisk and installed it to that would it work as a ramdisk is a lot faster than my SSD isn't it ?

Anykeyer
10-13-2014, 06:15 AM
It would work but its pointless. ACB loading times (animus white room) are CPU-limited on most systems.

strigoi1958
10-13-2014, 08:13 AM
Yes but I just wondered if someone with a lot of DDR but no SSD could get the gallop :D. I see people with 32gb ram and wondered why... I'm sure they have a reason but this would be another.

jeffies04
10-13-2014, 04:02 PM
I have the gallop and it's installed on an HDD. Just depends on the system.

If you're having to get THAT creative for a game that's 5 years old, it's time to upgrade your system. :)

Anykeyer
10-13-2014, 04:27 PM
I have the gallop and it's installed on an HDD.

No, you dont.

Alphacos007
10-13-2014, 08:35 PM
No, you dont.

What is the problem if his HDD is fast enough? On my Desktop I do have it installed on the HDD and it does have the Gallop option. Unfortunately my GPU broke and I'm currently only using the Notebook, which makes me have to install it on the SSD to have the Gallop option.

jeffies04
10-14-2014, 03:58 AM
No, you dont.


What is the problem if his HDD is fast enough? On my Desktop I do have it installed on the HDD and it does have the Gallop option. Unfortunately my GPU broke and I'm currently only using the Notebook, which makes me have to install it on the SSD to have the Gallop option.

No, he's right. I don't have it I just tried it with my new playthrough once I got to Rome. I must have had it on a different drive when I played before or with lower settings. I used to be able to gallop from one end to the other knocking everybody over, but now I can only fast trot. Weird.

Anykeyer
10-14-2014, 06:08 AM
What is the problem if his HDD is fast enough? On my Desktop I do have it installed on the HDD and it does have the Gallop option. Unfortunately my GPU broke and I'm currently only using the Notebook, which makes me have to install it on the SSD to have the Gallop option.

My logic is simple. If dual fast hdds in raid 0 isnt enough then no single sata hdd is. Maybe sas 15k rpm is enough but definitelly not your usual sata 5-7k.
Sometimes (very rarely, i think its triggered by finishing some missions) game glitches and has galoop in Rome regardless of your hdd/sdd but this ends after fast travel.

leomontenegro6
12-12-2014, 12:55 PM
Solved my previous issue with ACB stuttering on my computer. Firstly, I bought ACB and ACR from Steam, and in the beginning, everytime I played ACB, it wasn't opening Uplay. Instead, it was opening the game standalone. After beating this game by using a affinity fix, I realized that since Uplay wasn't being opened together with ACB, I couldn't play "Da Vinci Disappearance" DLC. Then I realized the game wasn't even installed to my Uplay account.

Well, after I inserted my ACB serial to Uplay, I opened the game without affinity patch (since this patch seems to disable Uplay), and that's it: All stuttering was gone! It seems that the stuttering on ACB was happening because I was playing the entire game offline, without logging to my Uplay account before start playing.

So if anyone is still having stuttering on high end systems, check if you're using a steam copy, and if you opened the game though Uplay. That solved for me.

Now I can play the rest of the game without stuttering, although there's not much left to do. Da Vinci DLC has a few missions and Cristina memories are close to an end.