PDA

View Full Version : DGEN apparently bugged? It seems so.



SeaFireLIV
06-22-2005, 04:53 PM
There`s a bug in DGEN. This is not really Oleg`s fault, but I cannot get onto SimHQ:

Basically, I was flying Berlin in the la7 early 1945 over Frankfurt an Der Oder. In this situation I accidentally nosed over my LA7 and had to bail on take off so I watched the rest of the mission.

P47s in invasion stripes(?) were attacking 109s trying to take off at the same time as when I bailed. The lead P47 disabled the lead 109 on take off. After this, every 109 simply crashed into it, the entire group being decimated.

Eventually I Escaped out and back to debrief. I hit Apply and I saw the red light of the HD accessing as DGEN worked out the results. This took a long while, perhaps 4 minutes.

Then nothing. I did to go make a cup of tea. I returned still nothing. The screen seemed to have frozen; it had now been about 10 minutes.

I was forced to press CTL-Alt_del and quit out. Task bar said that IL2/FB was not responding. I tried to take a screenshot, but of course it did not work.

When I restarted the next mission screen was blank. My whole career blown. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

Please can Starshoy fix this problem or someone in the Dev team get this message to him. Thankyou.


p.s BTW I have not installed DCG(by Lowengrin) or have had it installed since a fresh install with 4.01m.

VW-IceFire
06-22-2005, 05:15 PM
P-47s and P-51s (and maybe P-38s) do show up on the Berlin map. And yes they do wear invasion stripes as the default skins aren't very sophisticated and are often incorrect for the timeperiod.

Atomic_Marten
06-22-2005, 06:21 PM
First off, was that happened to you?

Also where is the DGen bug in that story I fail to see it?

Like Ice said P47 is not a bug in Berlin map, they are supposed to be there.
Bf109s crashing onto each other is maybe an AI bug, but certainly not DGen bug.

BTW I had the described bug (frozen screen on 'Apply' and then blank briefing screen of the new career mission.)
Several times.
Cause: to me unknown.

Since then I have finished 4 careers without problems after last 'bug' (well over 500 missions), so I suppose that this kind of problem is not that common.
And I would not be surprised if that is related to some action that I was to blame not DGen or else.(custom campaigns, changing default settings etc.)

And yes, regardless of all that, my old habit has been proven right again -- always back up your career (at some points, 10 missions, 20 missions completed etc.)

A.K.Davis
06-22-2005, 07:14 PM
Have tried going in and deleting the last mission from the campaign? I can't remember exactly how to do this, but I know it's possible.

Sounds like your computer locked-up while DGEN was writing mission files, screwing up the files.

marcocomparato
06-22-2005, 07:50 PM
i sometimes crash at that summary page (i wish one could toggle the drawing of the flight paths since that is where the overhead is and makes scripted campaigns much more pleasant when u end the mission. its very inconsistent and i assume its due to my 3rd party DGEN.EXE (which u may have too and not know it. some retail campaign CDs stupidly overwrite the original or often more up-to-date version with their own.

i dont run Oleg's DGEN and havent in a long time. Starshoy or Lowengrin's are much better and customizable but a bit less stable.

but if you find that youre unable to create a new campaign, you can open the MISSIONS/CAMPAIGNS and go in that nationality to find the dgen-generated folder. u will know it when u see it because its named oddly. u can delete that entire folder. sometimes it seams those arent overwritten properly and also are not deleted and can fill up.

Atomic_Marten
06-22-2005, 10:35 PM
BTW did you by any chance look under root FB folder for a file named DGenErr.log or so?(I suppose this 'crash' has happened to you http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif).
In most cases game produces this file when after 'crash'.

The explanation why it crashed should be in that file (although a little complicated to understand http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif).

SeaFireLIV
06-23-2005, 01:32 AM
Originally posted by Atomic_Marten:
First off, was that happened to you?

Also where is the DGen bug in that story I fail to see it?

Like Ice said P47 is not a bug in Berlin map, they are supposed to be there.
Bf109s crashing onto each other is maybe an AI bug, but certainly not DGen bug.


Ok, the reason I explained the whole story was to give an idea in case Starshoy was reading and might wish to know the general scenario situation. I wasn`t complaining about the P47 stripes (although it is out of time) or the crashes - it was just to give Starshoy some background that may help.

The complaint was only about the freeze and crash. I was somewhat frustrated because I spent a long time on this Campaign all the way from Barborossa and was looking forward to finishing and then going onto the Pacific.

Anyway, I also sent a message via the DGEN `bugs` thing in the Readme and to my surprise got a quick response. So I`m talking to him about it at the present time. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Atomic_Marten
06-23-2005, 07:24 AM
OK

I suspect that the reason may be in adding some lines to [DGen] section in conf.ini, I have added some to that section..

[DGen]
OperationVictory=3000
OperationDefeat=-3000
WarVictory=30000
WarDefeat=-30000
SlowFire=1.0
HistoricalRanks=1

..but I'm not experiencing any kind of problems with this settings, both on ETO and PTO careers (4.01, also 3.04 used without HistoricalRanks=1 line). Everything else is on default.

BTW please post if Starshoy tells you what was the problem, so the rest of us can avoid it better. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Aeronautico
06-23-2005, 08:20 AM
I have had lots of corrupted campigns lately. Static and dynamic. Just deleted them 'cause they were not "important" but hope it won't happen with the ones that matter, and of course I'd become more vocal if that will be the case.

jeroen_R90S
06-24-2005, 05:26 AM
Originally posted by Atomic_Marten:

BTW I had the described bug (frozen screen on 'Apply' and then blank briefing screen of the new career mission.)
Several times.
Cause: to me unknown.


I had that also, a workaround is to hit 'refly' (somehow THAT button still works) and quit the mission. Then hit cancel to return to the main menu, exit IL2, reboot the system and try again, it should work now.

If it does not, get into the mission and CTRL ALT DEL out of IL-2. It seems it's not mission related, but something else is overflowing or getting corrupted and causing the next mission to be corrupt.

Your campaign is still usable. I tried deleting the new generated mission as well, but that does not always work.

Jeroen

73GIAP_Milan
06-24-2005, 07:56 AM
hmmm could this

http://forums.ubi.com/eve/forums/a/tpc/f/63110913/m/7731057923

be related??
Since you had some odd experiences in that thread aswell, SeafireLIV

Enforcer572005
06-24-2005, 10:35 PM
i dont even fool wiht the dgen thingy anymore...its so boring that i nearly fell asleep flying its stale products.

I knew it was pretty lousy when I was flying a B-25J over N.guineau in 42....those things werent in service till 44 or late 43. so i stick with user made cmpns . no way the dgen can compare. I jsut dont like it.

SeaFireLIV
06-25-2005, 11:47 AM
Originally posted by 73GIAP_Milan:
hmmm could this

http://forums.ubi.com/eve/forums/a/tpc/f/63110913/m/7731057923

be related??
Since you had some odd experiences in that thread aswell, SeafireLIV

Hi guys. Sorry I couldn`t respond earlier. My PSU (crappy Q-Tec, why the hell did I buy it?) fried my Motherboard Thursady night.

Anyway, yes that problem was with 4.00 so since it was unofficial I didn`t complain too much about it.

The response I had by email asked me how much Ram I had. I sent a reply (before my motherboard died), but today no response when I checked mail...

73GIAP_Milan
06-25-2005, 12:54 PM
I sure hope you can get this to Starshoy's attention http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Atomic_Marten
07-02-2005, 08:41 AM
Maybe this thread will help someone with crashed campaign

http://www.simhq.com/cgi-bin/ultimatebb.cgi?ubb=get_topic;f=98;t=006393

money_money
07-08-2005, 08:50 AM
dont know if this will help but i had the blank briefing screen thing which i think u are describing. anyway mine was caused after i was changing some of the default skins in the dgen data base files and accidentally put a space where it shouldn't have one.
i had
6 JU_52_3MG 4E
should have been
6 JU_52_3MG4E


$