PDA

View Full Version : Spire puzzle error



Kehra
10-05-2004, 07:35 PM
I looked but didn't see this particular error.

After reaching the third level of the chair puzzle, I moved the sliders up and after I moved all three, the game hit a glitch where it repeated the background music (like a record player would) and I got an error message. I don't recall what the message was because I had hoped that restarting the game from my saved position (which happened to be right before I moved the sliders) would fix it. But the game hitches in the same spot, just doesn't give me the error message anymore.

I'm not sure what information is needed other than that, as I don't have problems with these games very often.

Kehra
10-06-2004, 07:10 AM
After fiddling with it this morning I finally got it to recreate the message.

Sound Display Error: Error #21
Message:

Filename: \Myst4\dev\common\src\m4\dare_ext\error.cpp
LineNo. 26

Press 'Retry' to debug.

However, when that message appears the game locks up so I can't do anything with it.

Randomos
10-08-2004, 11:05 AM
Thanks for reporting this Kehra, it's the first I've heard of such a problem. I've passed it along to the technical team.

Can you tell us more about your system? What kind of sound card are you using would be a help, and does it have the latest drivers?

Thanks again, and we'll try to help you as quickly as possible.

best,

randomos

Kehra
10-08-2004, 01:13 PM
Thanks

XP, P4
768 MB RAM
Audigy 2, latest drivers
Radeon 9800 Pro, latest drivers

I have heard of mixed problems with the Audigy 2 sound cards, but so far throughout the game this is the only place I have this problem.

UncleBenny4
10-09-2004, 08:32 PM
Hi all
ok had the same problem here game froze up with the exact same errror. except mine did it when I returned to the seat and lowered panel to set to 12 12 12 to set offf the explosion in the bomb factory thought it didnt matter much but now that im on the colored marble puzzle I need to get to the amulet to get the colors.

compaq p4
sound is puter controled intel chip
Gforce 4 graphics
512 meg ram

Debralynne
10-10-2004, 10:48 AM
I just encountered the exact same sound error that Kehra did when I set the panel to 8, 12, 4.... The music sounded like a skipping record, the game froze, and I got a similar error message. I have had other problems with the game crashing to the desktop. (See my thread)

My specs are:

AMD Athlon 900 mHz
LOTS of HD space, but min. install
512 m RAM
NVidia GE Force 2 32 mb
SoundBlaster Live

I just realized that my soundcard driver is a bit out of date... (Oops!) I'm going to update now and I'll let you know what happens. :-)

Debralynne
10-10-2004, 12:23 PM
I'm happy to report that the driver update seems to have solved the sound error problem. I was able to play with the cables for quite a while with no problems -- however, when I left the chair to go explore in the garden for a while, the game crashed to the desktop... (which is why I'm visiting the forum again.) :-)

Ze Pedro
10-11-2004, 09:03 AM
My one and only CTD was this one - at exactly the same place and same message:

Sound Display Error: Error #21
Message:

Filename: \Myst4\dev\common\src\m4\dare_ext\error.cpp
LineNo. 26

Press 'Retry' to debug.

However, after rebooting and running the game from my previous save (not the autosave which appeared) it did not happen again (thank God). http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Maz has suggested in another thread that CTDs might be related to the autosave function. Maybe the autosave combined with the number of audio handling the card has to do here (several sounds for different frequencies) is what triggers it? http://forums.ubi.com/groupee_common/emoticons/icon_rolleyes.gif

The experts will know. http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

Kehra
10-11-2004, 09:20 AM
Well as I said in the first post, I had restarted the game in my saved position, not using the auto saved game. I wish it had worked as well for me.

Afterward though, I used the autosaved game to go off and do something else, because the autosave was before I went down into that part of the age. I have played through most (I think) of the rest of the game, completed Haven and have been working on Serenia, and I have gotten no other error messages thus far.

maztec
10-11-2004, 03:17 PM
I have no idea if it's related to the system doing autosaves, it's just a wild guess. Only thing that I can think of that would appear as random but really be consistent.

CoolWind
10-12-2004, 10:14 AM
Same problem, same place.

My system:

AMD Athlon 1 Ghz
384MB RAM
MSI GeForce FX5200
SB Audigy 2 ZS

HMishkoff
10-16-2004, 07:46 PM
Just wanted to report that I just experienced the same problem that Kehra reported (in pretty much the same place). I reloaded the game, it did it again. I haven't yet tried the obvious solutions (rebooting, updating my sound board driver, etc.), but I thought I'd check here to see if a fix for the problem had been discovered. Any ideas?

Mistleben
10-18-2004, 06:53 AM
Info only, I am experiencing exactly the same as reported by Kehra and HMishkoff also at the same point in the game. The only way out is to €œControl, Alt, Delete€ and close out at €œTask Manager€

I am operating Windows XP, 768.5 Memory, DirectX 9.0, Radeon 9000 Graphics and Creative SB Live 5.1 Sound Card. I have the latest drivers for both cards.

Kehra
10-18-2004, 06:05 PM
I'm glad (well not exactly but you get my point) to know that other people are having this problem too. At least I know for sure it's not just me being stupid (hey, more of us get to be stupid yay >.> )

I was however wondering if anything has come of this yet?

BodaMae
10-19-2004, 09:20 PM
Sound error #21- Fixed It!

I had to delete the "Auto Save" game and any other saved game around the same area (the harmonic table).
I then, uninstalled and reinstalled the game. (It gives you an option to keep your other saved games- click yes)
Worked for me - hope it works for you.
BodaMae

marlan55
10-20-2004, 06:20 PM
ok.........I found a way around it that worked without reinstalling the game...

go to the game book at the beginning:
1) Options
2) Audio Option
3) turn off all the sound (remove x)
4) load the game that locks on you
5) make sure your setting are correct for the explosion
6) get in the chair and hit the blue button
7) when it locks up, hold down the Control-Esc keys and hit them until until you bounce back to windows
8) if you have the three choice overlay, hit "ignore"
9) your taskbar should have a tab for "Warnings" Click on it to bring it up
10) It will say "Do you want to see recurrance.......hit "No"
11) on your taskbar, go back to Myst4
12) notice all the levers are to the top,
pull them all down to the bottom
13) I hit the blue button, to open chair, then hit again to lower the table
14) put all the sliders up to "12"
15) watch the lights and then get out of chair and save the game.

I did this twice to test it, and it worked...

GOOD LUCK

BY THE WAY...You will still hear the music in your head.... http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

HMishkoff
10-20-2004, 08:43 PM
I have no idea why, but your workaround did the trick, THANKS!!

elsyw
10-21-2004, 01:46 PM
It did not work for me. I hit the control-escape keys, but nothing happend. I have a Norwegian keyboard - but I guess the keys are placed the same way for those keys. Many other keys are different from English/American. My esc-key is the left upmost key, and the control is either the left downmost key or the wright downmost key. By the way, I am also unable to use ctrl/alt/delete to escape from the game, so I have to cut the power everytime the game chrashes. I am also awaiting a response from the technical support, postet a request on the 14th of October and have forwarded some files as requested on the 19th.
Any more clues?http://forums.ubi.com/images/smilies/16x16_smiley-sad.gif

marlan55
10-21-2004, 03:11 PM
elsyw:

Only thing I can think of is to hold down on the Ctrl and Esc keys for about 30 seconds and then hit them again a few times to see if you can get the computer to recognize the command.

marlan55
10-21-2004, 03:59 PM
also..........duhh, cause I didn't think of it......

If you are just going back to get a clue, you can choose the Spire book again and go back and wander around to your heart's content.

Mistleben
10-22-2004, 07:12 AM
Sound error #21-

Fixed mine too, I uninstalled and reinstalled the game. Replayed the game to just before the failed point. Deleted "Auto Save" game and any other saved game around the same area (the harmonic table)as did BodaMae. Then I did as marlan55 did, I went to the game book at the beginning:
1) Options
2) Audio Option
3) turn off all the sound

The game did not lock up, All seems to be fine now. I am now moving way beyond the failed point and further into the game.

Mistleben

elsyw
10-22-2004, 02:37 PM
Ok, since I have finished as much of Serenia as seemes possible before finishing Spire, I have gone back to Spire to give this d.... chair a last try. Although I said I never do this tuning again, I just have to. The technical support people are obviously not able to keep up with my pace!!!

So I will try this last information and let you know if it works out. I have Windows 98SE as operation system - could this be some of my trouble?

And know I go back to the game and see if I can beat that chair once more without chrashing the game. If not, I have a cheap game for sale http://forums.ubi.com/images/smilies/59.gif

elsyw
10-22-2004, 03:42 PM
Yes, it did work this time http://forums.ubi.com/images/smilies/88.gif

And I figured out why the title Myst - because everything I had done in Serenia suddenly was forgotten. I made most of Serenia, went back to Spire, and finished the last quest based on a stright gameline. When I went back to Serenia everythings back to square!!! Makes you wonder somehow?!?

At least you lot works a lot faster then support http://forums.ubi.com/images/smilies/25.gif

wackojedi
10-24-2004, 09:02 PM
I got the same error resulted in playing with the music adjustments in the chair.

P4 HT 2.6 Ghz
256 MB Ram
ATI 9600XT

maztec
10-25-2004, 09:03 PM
See the patches thread, I suspect this will be fixed soon. When the patch comes out let us (meaning me and whoever else reads the thread) know if it does or doesn't work.

Maz