PDA

View Full Version : Lighting issue



jingato
03-23-2011, 12:25 AM
I just installed and starting playing ACB and I'm noticing a weird issue with the lighting. It seems like if there is a light behind an object or character it is getting rendered in front of it instead of behind it. And sometimes characters look like their glowing white to the point where you cant even see them.

Is anybody else experiencing this. It is really annoying. Does anybody know how to fix it?

ace3001
03-23-2011, 01:29 AM
A screenshot might help to see if others also get the same problem. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

KingDaniel0
03-23-2011, 03:36 AM
-------------------------------------------------------------------------------------

Is it some kind of GLOW, Bloom effect ? Which GPU do you have, ATI or Nvidia ?

Try to disable Multisampling/AA, at the in-game Graphic option/setting. Set it to Off. Also try to force Antialiasing (AA) to 'Application-controlled', through Nvidia's Control Panel.

Though this won't be necessary, but you can also disable the option *Antialiasing - Gamma Correction*, under Nvidia's Control PANEL. Force this setting to OFF, and then play the game.

The same can be done under ATI's CCC. Set AA/Antialiasing to the 'Use application settings' option, and make sure all the other 3D settings are set to this value.



--------------------------------------------------------------------------------------

jingato
03-23-2011, 04:13 PM
Here's a screen shot of what I mean. That circle on Desmon's body is actually a light on the post behind him

http://www.mypcmechanics.com/misc/acb1.jpg

I disables multisampling and the problem went away. Then I re-enabled it and I got a new problem. Look at the lights in the picture below.

http://www.mypcmechanics.com/misc/acb2.jpg

So I disabled multisampling again but this time the second problem remained.

I have an Nvidia GTX 480

KingDaniel0
03-23-2011, 04:21 PM
---------------------------------------------------------------------------

Oh, I'm a bit confused out here....Where are enabling/disabling the AA/multisampling Value, under Control Panel or at the in-game Video Settings ?

First try to force Antialiasing (AA) to the 'Application-controlled' option, under Nvidia's Control Panel. Don't conflict this setting with your in-game AA/Multisampling Value.



-----------------------------------------------------------------------------

mornegroth
03-23-2011, 05:15 PM
Do you have your latest drivers installed?

jingato
03-24-2011, 04:44 PM
I tried all the different multisampling options. I tried setting it up in Nvidia control panel too like you suggested but it doesn't seem to help. The people I have targeted are always glowing no matter what and it makes it unplayable, especially during combat.

http://www.mypcmechanics.com/misc/acb3.jpg

http://www.mypcmechanics.com/misc/acb4.jpg


Is this happening to anybody else? I do have the latest Nvidia drivers. Does anybody know how to fix this. I'm starting to wish I bought it for Xbox. I just thought I'd have better quality on the PC.

KingDaniel0
03-24-2011, 05:25 PM
Originally posted by jingato:
I tried all the different multisampling options. I tried setting it up in Nvidia control panel too like you suggested but it doesn't seem to help. The people I have targeted are always glowing no matter what and it makes it unplayable, especially during combat.


Try to disable this option i.e. *Antialiasing - Gamma Correction*, under Nvidia's Control PANEL. Force this setting to OFF, and then play the game. See what happens ? But, this only works on OpenGL games.

Btw, what about your in-game AA/Multisampling setting and Value ?



-------------------------------------------------------------------------

jingato
03-25-2011, 01:03 AM
Antialiasing - Gamma Correction

That did the trick

Thanks http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

KingDaniel0
03-25-2011, 04:54 AM
Originally posted by jingato:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Antialiasing - Gamma Correction

That did the trick

Thanks http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif </div></BLOCKQUOTE>

Thanks for the Update.... Actually 'Gamma Correction' shouldn't have conflicted with AC:B's code though. But that Glow was indeed too bright...

Anyway, I'm glad this Lighting/Glow issue is now solved.



--------------------------------------------------------------------------------