PDA

View Full Version : Lightning - Cave



BurningGeneral
10-29-2009, 05:57 AM
Hello,
there's another problem with the light.
It's nearly the same like in my other topic.
I createt a "juarez" cave which should be completely dark inside. But there are still lights in the cave...

http://www.bilder-hochladen.net/files/cvnl-9-jpg.html

seir
10-29-2009, 09:13 AM
Yes, it's because model is made with one sided planes. Only texture side plane can stop light trace.

BurningGeneral
10-29-2009, 09:44 AM
So how did the do it in the game?

seir
10-29-2009, 10:59 AM
you need to place something near the cave that will cast shadows.

vodka-kyo
11-09-2009, 08:02 AM
I need also to create a black part on my map.
I use cast shadow and time set to reduce the light, but I can't have "no sun"

No time create night, or reduce radicaly the light.

I can't change a "dynamic light" in negative
And don't find a way with a vis box to stop
all the light.

So how can we have realy BLACK zone and a black/night sky ?

cr1m3
11-09-2009, 10:18 AM
Hi,
Try to create a DynamicLight=(in chromed go to all->Type=Dynamiclight->Class=LightObject;dont choose DynamicLight in Class it's not working.
Add this new object where u want darkness,open object atributes.
Open the Dyn Lights tab and in "type" choose omnidark then click on color to change it,set intensity to 1.000.
Ok now if you want more darkness you can scale this light with the scale tool.
Choose scale tool and hold leftclick on lightobject and push your mouse up ,u will see the darkness growing.

vodka-kyo
11-09-2009, 04:55 PM
Thanks, I test it but that don't work.
Also I can't scale a dynamic light.

seir
11-10-2009, 12:16 AM
That's really bad idea. Don't get users wrong. It will also darken the player and it's really not well optimized!

I already told you how to do that so where's the problem?

cr1m3
11-10-2009, 04:27 AM
Ok, sorry i didn't know that it was also darken the player.
To scale a light you have to be near the light object.

vodka-kyo
11-10-2009, 06:15 AM
Ok I found, what you tell to me, the black is realy realy small and just in the orange round.
I miss it the first time... So shure It's not a good way, but if it the only one, I will use it.
thanks cr1m3

To seir
I have with cast shadow (shadowcaster.msh) and time set (day_time 0.981), the first picture, but I try to have an atmophere like in the second one
http://i38.tinypic.com/34j21pt.jpg

seir
11-10-2009, 06:25 AM
Place "amb_box.msh", double click on it and from "Skins" choose "Darken". Chceck also other skins and "amb_" shapes and look which one you'll like.

Amb boxes works in shadows and you need scale them up.

vodka-kyo
11-10-2009, 07:01 AM
OK I will test this tips.
I founded for the sky... blackboxsky.msh appear and disapear. http://forums.ubi.com/groupee_common/emoticons/icon_rolleyes.gif

seir
11-10-2009, 07:57 AM
Nice http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

vodka-kyo
11-10-2009, 11:20 AM
Finaly "amb_box" don't give me what I want, and I test With a "dynamic light" in "omnidark" scale.
Rendering is absolutly perfect.
FPS aren't reduce, and I fastly disabled it because it's a short scene.

if "it's really not well optimized!" It's seem to work good with no consequence.. so I keep it.

http://i35.tinypic.com/ifxusk.jpg

seir
11-10-2009, 12:00 PM
I'd prefer to put turn of the sun light (with ChangeParams > ParamVarlist) and use shadowbox instead of OmniDark lights. Now your FPS might be fine but later with AI it may be very low...

vodka-kyo
11-10-2009, 02:25 PM
In fact, no AI on this scene (just 2).And dynamic light are only active at this time. I already test with, and no problem. This scene is about 2 minutes long, it's a sort of alucination by the player in an indian graveyard.

I test my game completly at the end about 4 or 5 times to check and fix bugs, and in 3 differents graphics card (8800GTX GTX285 and ATI 4870).
the best rendering is unquestionably this one

But If any problem appear, I use your solution.
I want that all player can play without problem.