View Full Version : Request for ColinCJ

08-29-2007, 08:11 PM
Hi Colin - After exhausting all attempts to get my router to allow me connect to a MP server in GRAW2 and not being successful, I had a thought and perhaps you may be able to help me with it.

At this point I'm getting the feeling that there may be some missing port/s posted in the readme. For most those listed ports would be enough, however, I know for a fact that my router has a very tight firewall and cannot be completely disabled without opening certain ports to make certain games function correctly (even if you're not hosting a server).

I have a feeling there are other ports being used for this game that arent listed. Whether they are for the game itself, or gamespy or ubi i dunno bu there must be something missing that the devs thought wouldnt be necessary to list.

Is there some way you could look into finding out a complete list of EVERY and ANY ports this game utilizes above and beyond whats included in the readme?...short of a game bug thats only effecting MY router theres no other explanation for not being able to connect to any type of MP server in GRAW2.

I would do it myself but i know the tech support clerks at ubi would have no clue about such things if i called in. I thought maybe you had deeper contacts for someone there who might truly be qualified and know the answer to this.

Any help would be greatly appreciated of course!

08-29-2007, 10:02 PM
Sorry to butt in, but, what router are you using? Most broadband routers have what is called a DMZ, which opens all ports to the Internet. This feature can be turned off and on. I use a Linksys router. You should be able to join an MP server even if the DMZ is closed, however. The DMZ must be open in order to host a game, however. Do you have a software firewall. i.e. Windows Firewall, ZoneAlarm, etc.?

08-29-2007, 11:39 PM
its all been taken into consideration already, plus alot more...see the cross referenced problem thread here:


08-30-2007, 02:06 AM
I will ask today.

08-30-2007, 02:08 AM
If you are joining a game u dont need to open port, it uses UDP btw. The what would be blocking it would be a Software Application such as Anti Virus, Firewall etc etc. Even a virus like a P2Pworm could be using the port and lagging you out when connecting. The only Router problem you should have is Creating a server. Since you have attempted to use another way of connecting and it has worked so the problems that would lie is that when the router is connect windows might of enable Windows Firewall or Other Software, Or Settings on the Router.
Also have you tried bridging?
What Games have you played online with this Router? I want to know because then i can see if anyone else has had these problems or if the game uses UDP.

08-30-2007, 02:12 AM
One question what exactly happens when you click on join server.

And what have you got your bandwidth setting at in game.

08-30-2007, 06:39 AM
thanks so much Colin for trying to find out for me...as for what happens after clicking the join button, the connecting box pops up as it should and you can see it trying to connect (search for connection) for about a minute or so before it gives up and times out with that cant connect message. Oh, and uh...what "in-game bandwidth settings" are you referring to???...i dont see any settings like that in graw2, where is it?

@Maverick - well...ive tried everything (im an ex-tech so im very familiar with the OS) you brought up already...with the exception of bridging the router. I didnt try it because the router docs say its used for times when you have more than one router in the network (which i dont). I know nothing about bridging, could you explain why it might help where i have only 1 router and 1 hard wired pc in the network?...oh and you're not 100% correct to assume that ports wont need to be opened to join a server...I know thats true in 90% of cases but with this router its a different story at times with certain games/applications.

Heres a list of some other games ive played online over the last 2 years with this router:

Half Life2
Joint Operations series from Novalogic
Operation Flashpoint
BF2 and BF2142
Medal of Honor series
Call of Duty series
Brother in Arms

there are others but cant recall off top of head right now so quickly

Thanks guys!

08-30-2007, 10:45 AM
Have you allowed the game through your software firewall as asked before? Not allowing the game access through one of them will not alow you to connect to any server.

08-30-2007, 12:04 PM
I can understand not wanting to read through entire threads before posting a question...and I always appreciate any help and suggestions, however, every setting/adjustment that would be obvious to the masses has already been tried, and then some.

Thanks anyway though.

08-30-2007, 12:15 PM
funny I got the exact same error as you bigshort1.
Which router are you using? I got one of Netgear and I also think my problem is the connection with the servers.

08-30-2007, 12:35 PM
Has anyone mentioned NAT? I mean the different ways different routers handle NAT by default?

There are 3 types of EndPoint Filtering (NAT).
Endpoint Independent (OPEN NAT)
Address Restricted (MODERATE NAT)
Address & Port Restricted (STRICT NAT)

To play MOST online games the router must be able to be set to at the very least MODERATE NAT. Strict NAT breaks MOST online games.

I am director of ops for a tech consulting company, and I do know a thing or two about NAT! Misconfigured-NAT configurations on SOHO routers has caused me more headaches than I care to remember! lol

08-30-2007, 01:51 PM
@Macwohl - DLink DGL-4300

@Monk - NAT filtering is part of the firewall options with my firmware and yep, i already tried it on endpoint independant for both TCP&UDP.

Im assuming its some weird game bug that only effects a very small percentage because my router is fine with all my other games...theres something screwed up/different about the way GRAW2 communicates i can tell ya that.

Funny thing is that before the 1.04 patch i wasnt even able to get the server info box to show any info...but since the patch it fixed that so i can now get the server info on all servers...but when i try to join something is either being dropped or blocked...which one i dont really know.

08-30-2007, 02:35 PM
Originally posted by BigShot1:
@Macwohl - DLink DGL-4300

@Monk - NAT filtering is part of the firewall options with my firmware and yep, i already tried it on endpoint independant for both TCP&UDP.

Im assuming its some weird game bug that only effects a very small percentage because my router is fine with all my other games...theres something screwed up/different about the way GRAW2 communicates i can tell ya that.

Funny thing is that before the 1.04 patch i wasnt even able to get the server info box to show any info...but since the patch it fixed that so i can now get the server info on all servers...but when i try to join something is either being dropped or blocked...which one i dont really know.

The DGL-4300? That's the D-Link Gamerlounge router isn't it? (Sorry I deal with "big" firewalls/routers mostly http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif )

My son's have EXACTLY that router (DGL-4300) and GRAW2 works beautifully through it. Have you asked your ISP which ports incoming AND outgoing they "filter" (BLOCK)? Not that you'll get an honest answer from an ISP most of the time....

Oh, and disable SPI in your firewall settings! It stands for "stateful packet inspection" and is little more than a "marketing-ploy" on those small SOHO routers. You need a REAL firewall to do proper ALG's etc...

08-30-2007, 02:38 PM
Ports, as the maunual states feed back today.

Options for feed back.

Please try the following.

1. Press Start Use the msconfig.
Disable all start up programmes.

2. Disable in services all programmes that are not Microsoft.

3. in IE7 tools internet options, select Delete, selct Delete all.

4. Control Panel,internet options,Advanced,Press Reset option.

5. Start Control Panel, right click My Computer, open properties, Device Manager, Open Network adaptors, select adapter that is connected to modem, right click and delete.
On restsrt Drivers will be asked for make sure you have downloaded driver prior.

Internet connection.
1. Reset modem to default settings. unplug all cables and reconnect after a min or so.

Obviously reset pass words etc if a network is being used but dont change any thing else like ports and such.

In your game folder under profiles, delete any profiles created, you will have to resign in after this.

After this is completed do a normal system clean of hard drive and defrag.
Restart system.

Please give any feed back from the above.

Sorry one last thing.

Also depending on your os do a resink with the internet.

This routine will eliminate many ares to look at.

08-30-2007, 02:44 PM
yea, actually i did ask...i called them last week and went over all the listed gameports from the graw2 readme but they told me none of those ports are being blocked at all...except for port 80 which i have the ability to unblock (and HAVE done that for testing but didnt help).

We already know its not the ISP though, because Multiplayer works fine for me once i remove the router and plug the cable modem directly into the pc. My router does not like this game.

Since yourself and other with this same router have reported no problems i can only assume that it must be due to which version, or WHEN you bought it. Perhaps I have an older one (it came with 1.4 but ive updated 1.8).

Ive also updated my NIC Ethernet drivers just incase it was a bad reaction between the NIC and router with this game but that didnt help either.

Cant understnad why some 4300's work but mine doesnt :-(...its the only router on my system and my game pc is hard wired into it.

I even tried disabling the wireless feature since my wifes laptop is the only thing around here that uses it and thats only once a week maybe, but that didnt help either...ive disabled gamefuel, ive reserved DHCP addresses (even though i dont need to with my ISP) ive turned down every firewall feature available to me including putting the pc into DMZ.

Just as a side note (incase anyone uses my ISP here), my Cable Connection ISP is Optimum Online on Long Island, NY. Fastest cable connection in the industry...i can achieve dload speeds of over 3,500kb/s. In fact when i bought this game it was a digital download version and i downloaded it in a matter of minutes, VERY fast but of course that depends on the server youre connected to as well.

08-30-2007, 02:52 PM
lol we must be here at the same time really sorry I missed that last post.

Try the above and get back to me Im here for another hour, also the game settings for internet are in the main section for MP conncetion, I think the norm or in game is 3000 but this will need changing, example my upload is 500 but it does not work too well on that setting mine is 300, it seems to be stable enough.
Just to add I tested this router out today and it was fine but I did not use the latest firmaware I used the original that cam with the cd. version 1.5.
Current version I think is 1.8

08-30-2007, 03:00 PM
Colin...yea we are here at same time, lol

I have NO options anywhere in-game to adjust the 3,000 internet setting you mentioned. I see it in the game files (forgot which one) in the install directory if i edit it, but theres no way of getting to it in-game...so now im confused...is the digital download version different? (i have the DD version, not DVD)

08-30-2007, 03:16 PM
Ok roger that.
Well do the other stuff see what gives, I would like to get rid of your profile folder though.

I would like to get to the bottom of this as its annoying me now, 4 of you at the moment have same issue but different router, for 2 of you.

Any way do the above please, some one here may be able to point you to remove the profile, this would be good.

I will check back in the morning let me know how you get on with this.
Any one here have the Direct Download version if yes please help with the folder for the profile, the gamers profile needs to be reset by deleting the profile only, not the profile folder.

The MP section for upload etc is create MP game and this option is in a drop down list under conncetion as far as I can remeber.

I am not at my machine at moment, so cant look. to be more precise.

CU in the morning.

08-30-2007, 04:25 PM
wow, well...apparently we're using 2 very different versions of this game, hehe. Maybe the trouble is with the DD version because there is no connection drop down box from the MP server screen. IN fact theres no adjustable connection settings anywhere within my game at all. Theres 2 screens, the browser screen where you join servers, and the server screen where you can start your own server and theres nothing like what youve described that would allow one to change connection speeds. Perhaps the boxed version is different? I also noticed that I have no network.xml anywhere in my directories...should I? ( i noticed mention of it in the context.xml in the root folder).

I have a file called gameinfo.xml and game_info_coop.xml in the settings folder which i see has the 3000 speed setting so i changed it to 300 and saved it but that didnt help at all.

As for the profile, the only way you can delete it is to delete the folder because the game wont let you use the delete icon in-game when you only have 1 profile listed. I deleted the folder and made a new profile but that didnt help either.


08-30-2007, 10:46 PM
UPDATE: I finally got it working folks, hurray! I can now join servers and host as well.

It was mostly by accident how it happened. While I was playing around with some settings on my router I ended up temporarily turning off DHCP for about 10 minutes or so...long enough so that when i turned it back on it assigned me a new WAN IP address for DHCP and whatya know...i was immediately able to connect to MP games.

Dont ask me why only GRAW2 gave me this trouble because i have no idea...BUT for the few of you who have the same issue...try releasing or turning off the DHCP for about 15 minutes and see if itll assign you a new IP after renewing it. Then see if that helps you connect.

Whew, done! hehe

08-31-2007, 02:59 AM
Im glad you got this sorted out.