PDA

View Full Version : Assassins Creed Performance Problems



marvinrulezz
03-18-2011, 08:29 PM
My System:

i7 950:4.5 GHZ
GPU:GTX 295 712/1512/1215
RAM:Kingston Hyper X 12GB:1950 MHz at 7-7-7-19-1
Motherboard:GA EX58 UD5
All on water.


Can someone explain to me why I am having terrible lags and FPS drops?

I am playing the game at 1920x1280 everything maxed out with Vsynch on.

I experienced that EVGA Precision shows that
GPU1 is mostly at 11-12%
GPU2 is mostly at 67-80%

That indiciates the game does not support SLI properly.

I will soon upgrade to Quad SLI and I would like to know when there will be any patches or drivers out to fix the SLI problem or maybe just a GTX 295 problem.


Has anyone else experienced FPS drops and lagging?
With my system I should not have any problems.

gabotron
03-18-2011, 09:00 PM
It could also be that your CPU's Hyper Threading is enabled while the game might not be supporting it.

marvinrulezz
03-18-2011, 09:31 PM
1.)What does my GPUīs being used unevenly have to do with Hyperthreading?
My GPU1 only has 12% usage and GPU2 70% this must be a SLI problem or at least an issue with the GTX 295 in particular.Hope someone knows when there will be patches or drivers for this prob.

ace3001
03-18-2011, 09:51 PM
Why don't you just try the game with a single GPU and test for yourself whether it's an SLI issue? If it is, just play the game that way. One GTX295 should be definitely more than enough for this.

marvinrulezz
03-18-2011, 10:02 PM
The Problem is that I am currently playing with just one GTX 295.

And GPU1 only shows 12%
GPU2 with 80%

It is definitely a SLI problem.
I am wondering if anyone else with a GTX 295 is struggling with that problem.

Can someone from Ubisoft please post when a patch or driver is released to fix the SLI incompatibility?


Also a little side note...I canīt seem to get past the villa attack sequence...the saved villagers stop at 45 and donīt move until the time is up-.-

ace3001
03-18-2011, 10:37 PM
Originally posted by marvinrulezz:
The Problem is that I am currently playing with just one GTX 295.

And GPU1 only shows 12%
GPU2 with 80% Isn't that... contradictory??


Originally posted by marvinrulezz:

Also a little side note...I canīt seem to get past the villa attack sequence...the saved villagers stop at 45 and donīt move until the time is up-.- Ah, I think it doesn't go below 45. Around that time, soldiers pour all around, and the cannon handling mercenaries tell Ezio to abandon the cannon and go fight the soldiers. Not sure what action triggers that scene, though. http://forums.ubi.com/groupee_common/emoticons/icon_confused.gif Sorry.

gabotron
03-18-2011, 11:00 PM
You can at least try the things suggested to you before concluding that it's an SLI problem.

It isn't just about the GPU. The CPU, RAM, etc. also have something to do with it. Take a look at this person's issue:

http://forums.ubi.com/eve/foru...519/m/8771047519/p/3 (http://forums.ubi.com/eve/forums/a/tpc/f/5031067519/m/8771047519/p/3)

You have a similar processor, but his GPU is way lower than yours. He solved his problem by not enabling HT for this particular game. You can try setting an affinity for a process or you can disable HT entirely from the BIOS so you can test.

I think you can also set GTX295 to use only one GPU. It could be in you NVIDIA Control Panel as indicated here (http://img5.imageshack.us/img5/5166/31413497.png).

marvinrulezz
03-18-2011, 11:05 PM
1.)The GTX 295 is a Dual GPU it has 2 cards.
And mine shows that GPU1 only has 12% usage
GPU2 with 80% usage.

That means the GPU1 is not used properly because of the poor SLI support.
Omg can someone from Ubisoft please advise here?oO

Or does somebody else have an SLI setup and is currently playing AC Brotherhood PC?


2.)I watched the console version on youtube and with them the time is always as fast as the last villager is saved.
With me it always stops at 45 and drops at the last second when it is too late.
Ezio automatically changes cannons because one is destroyed.

Please help to both questions!

marvinrulezz
03-19-2011, 05:45 AM
1.)So please can anybody advise why my GTX 295 isnīt fully used?
Does the game even have SLI Support?



2.)And please tell me how I can pass the villa attack level.
I always stop at 45 Villagers and then I get desynched-.-

The time is insufficient.
Could this be a PC bug?

shop27C171CB8
03-19-2011, 06:26 AM
Originally posted by marvinrulezz:2.)And please tell me how I can pass the villa attack level.
I always stop at 45 Villagers and then I get desynched-.-

The time is insufficient.
Could this be a PC bug? It's quite easy to finish that. Hit enough of the canons and you should be fine. I finished it the first time.

marvinrulezz
03-19-2011, 07:10 AM
Ok I got the village attack mission.


But now the most important problems:

1.)I want to know when there will be driver or patches released to provide a SLI profile or at least better support for SLI.
My GTX 295 is not being fully used and it sucks.


2.)The Multiplayer keeps telling me "Ubisoft Server is not available try again later".
Also Uplay and Multiplayer are both static grey unlike the other options.

Advise please?

KingDaniel0
03-19-2011, 07:38 AM
---------------------------------------------------------------------------------

@marvinrulezz,

Not fully sure, but you can Try using this tool i.e. nHancer for better SLI performance.....But I'm not able to find a 64 bit OS version right now.

http://www.softpedia.com/get/T...-Tweak/nHancer.shtml (http://www.softpedia.com/get/Tweak/Video-Tweak/nHancer.shtml)

http://majorgeeks.com/nHancer_d5579.html

Try to create a new custom profile for 'brotherhood' using the icon above the application box, and then add the executable to the profile from the Game's install folder.

Click on the SLI mode tab and tick the SLI mode box, select Alternate Frame rendering in the drop down below that, and then enable compatibility boxes 20, 22 and 25. I'm not fully sure about these values now.

Btw, what mode have you selected under Nvidia's CP ?



--------------------------------------------------------------------------------------