PDA

View Full Version : Dedicated Server



Swordfish350
10-08-2006, 05:55 PM
I have a server setup for Pacific Fighters and it works fine on the local LAN. However, it doesn't allow users from the Internet to join. I have turned on port forwarding for the server for port 21000. The other user gets "Please wait" Is it even possible to have direct PC to PC gaming like this or do you have to go through UBI or Hyperlobby? I noticed that the server is listening on port 21000 using UDP. Shouldn't this show a TCP port listening as well? Both server and client are patched to 4.04 Any ideas or help would be appreciated!

Here is my Confs.ini file contents:

[NET]
speed=8000
routechannels=0
serverChannels=6
localPort=21000
remoteport=21000
SkinDownload=0
difficulty=16941152
serverName=Rubbers Revenge
serverDescription=
checkServerTimeSpeed=1
checkClientTimeSpeed=1
socksHost=

[chat]
autoLogDetail=3

[MaxLag]
farMaxLagTime=2.0
nearMaxLagTime=1.0
cheaterWarningDelay=2
cheaterWarningNum=2

[Console]
;IP=20000
;IPS=127.0.0.1
LOG=1
LOGTIME=1
LOGFILE=logs.lst
HISTORY=128
HISTORYCMD=128
LOGKEEP=1

Swordfish350
10-08-2006, 05:55 PM
I have a server setup for Pacific Fighters and it works fine on the local LAN. However, it doesn't allow users from the Internet to join. I have turned on port forwarding for the server for port 21000. The other user gets "Please wait" Is it even possible to have direct PC to PC gaming like this or do you have to go through UBI or Hyperlobby? I noticed that the server is listening on port 21000 using UDP. Shouldn't this show a TCP port listening as well? Both server and client are patched to 4.04 Any ideas or help would be appreciated!

Here is my Confs.ini file contents:

[NET]
speed=8000
routechannels=0
serverChannels=6
localPort=21000
remoteport=21000
SkinDownload=0
difficulty=16941152
serverName=Rubbers Revenge
serverDescription=
checkServerTimeSpeed=1
checkClientTimeSpeed=1
socksHost=

[chat]
autoLogDetail=3

[MaxLag]
farMaxLagTime=2.0
nearMaxLagTime=1.0
cheaterWarningDelay=2
cheaterWarningNum=2

[Console]
;IP=20000
;IPS=127.0.0.1
LOG=1
LOGTIME=1
LOGFILE=logs.lst
HISTORY=128
HISTORYCMD=128
LOGKEEP=1

dusta01
10-08-2006, 07:54 PM
your net section is missing a local host . IE a valid Ip on the internet

like this

[NET]
speed=15000
serverChannels=60
localPort=21000
localHost=203.82.213.130 <--------
SkinDownload=1
difficulty=29358079
serverName=|450| Squadron Australian server
serverDescription=450sqdn.dusta.net for more info
checkServerTimeSpeed=1
checkClientTimeSpeed=1
checkTimeSpeedDifferense=0.05
checkTimeSpeedInterval=5
socksHost=
remotePort=21000
difficulty=29358079

Swordfish350
10-08-2006, 08:52 PM
Thanks a ton! I'll try that.