PDA

View Full Version : rts.dll gold pack instalation help(resolved)



slo_1_2_3
03-28-2006, 02:39 PM
Ok I finally have it I installed it first disk one then two now when I try to play it says

The application or DLL C:/program files/ubi soft/il-2 sturmovik forgotten battles/ rts.dll is not a valid windows image. Please check this against your installation diskette.

So what the heck does that mean?
Swift reply would be very very much appreciated thanx.

slipBall
03-28-2006, 02:57 PM
Slo, congrat's to you, I love your attitude. Did you uninstall PF, then installed Gold pack?? and then install PF as a merge??

Taylortony
03-28-2006, 02:58 PM
you need to download the replacement RTS.DLL and replace the one in the game folder, it is a known problem with some installs........... go here to get it then install it to replce the existing one in the game folder... the game folder should be on C drive.. program files ubisoft folder.. forgotten battles folder, drop it in there ( Unzipped and it will replace the one in there ) that is if that is where you installed the game http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

http://ubisoft.custhelp.com/cgi-bin/ubisoft.cfg/php/end...dp.php?p_faqid=10061 (http://ubisoft.custhelp.com/cgi-bin/ubisoft.cfg/php/enduser/std_adp.php?p_faqid=10061)

slo_1_2_3
03-28-2006, 02:59 PM
OOOO thank you so much http://forums.ubi.com/images/smilies/25.gif http://forums.ubi.com/images/smilies/heart.gif

Taylortony
03-28-2006, 03:02 PM
wait the link was for the Pacific fighters version go here for the FB one http://forums.ubi.com/images/smilies/disagree.gif

http://ubisoft.custhelp.com/cgi-bin/ubisoft.cfg/php/end...9y&p_li=&p_topview=1 (http://ubisoft.custhelp.com/cgi-bin/ubisoft.cfg/php/enduser/std_adp.php?p_faqid=1109&p_created=1046901133&p_sid=Ag5lOD3i&p_lva=10061&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PWRmbHQmcF9ncmlkc29yd D0mcF9yb3dfY250PTImcF9wcm9kcz0wJnBfY2F0cz0wJnBfcHY 9JnBfY3Y9JnBfc2VhcmNoX3R5cGU9YW5zd2Vycy5zZWFyY2hfb mwmcF9wYWdlPTEmcF9zZWFyY2hfdGV4dD1SVFMuZGxsIGVycm9 y&p_li=&p_topview=1)

slo_1_2_3
03-28-2006, 03:07 PM
Wait what? ?? If I install fb+ace+pf do I need both?

slipBall
03-28-2006, 03:09 PM
I did it with just the PF 104kb file

Taylortony
03-28-2006, 03:10 PM
good so its working ok now?
http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif
welcome aboard to a whole load of new planes http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif
check out the gladiator http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

iwould normally install FB run it (the game) then aep run it then pf and run it, and fix any problems along the way, u can always overwrite it again with the fb one if needed http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Skycat_2
03-28-2006, 03:21 PM
Disc one and disc two of what? Gold Pack should have three discs.

If you install FB and AEP and PF all on top of each other, the rts.dll at the Ubi Soft solutions center will work for you.

Skycat_2
03-28-2006, 03:26 PM
Don't forget the information in this earlier thread:
http://forums.ubi.com/eve/forums/a/tpc/f/23110283/m/9061078624

PF 'merged' has a different root folder than PF standalone. You need to install all five CD-ROMs (FB 1, FB 2, AEP, PF 1, PF 2) to have the merged PF game.

Finish up with the official upgrade patches.

slo_1_2_3
03-28-2006, 03:49 PM
Ok so what should I do cause I go into fb + ace to check out and make sure it works but I can't stop the movie and the mouse won't move and I can't minimize it what now?

slipBall
03-28-2006, 03:53 PM
It's most likely your settings for the game, look in threads for a simular problem, and cure It's usally the video, or sound set up choice's
How strong is your machine, what's the CPU, how much ram do you have

slo_1_2_3
03-28-2006, 04:00 PM
well I can stop the movie and hit ecscape and enter but nothing else the mouse won't move in the game and I can here the music I'm becoming very agitated with this junk

slipBall
03-28-2006, 04:06 PM
Slo, try moving over to Community help with this, you will get more help there

steve_v
03-28-2006, 04:09 PM
Originally posted by slo_1_2_3:
I'm becoming very agitated with this junk http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif go look in the mirror. theres your problem. if you follow the installation steps given here, you'll be okay. http://forums.ubi.com/eve/forums/a/tpc/f/26310365/m/5581083643

slo_1_2_3
03-28-2006, 04:12 PM
WHat the heck I pur fb disk one in so I can unistall and I hit uninstall and then it installs it without even using disk two... something screwed up

JG52Uther
03-28-2006, 04:19 PM
Calm down and take it slow.I know you are desperate to install and fly,but take a step back and read the link that Steve posted.

slo_1_2_3
03-28-2006, 04:22 PM
Its about the patches right? I'm not there yet I can't even get fb to work right.

slo_1_2_3
03-28-2006, 04:25 PM
And also I'm sorry I'm spazing but do you know how long I've been waiting? If it doesn't work I think I'm mailing the place I bought from a dead cat.And possibly a broken computer.

slipBall
03-28-2006, 04:41 PM
Just go slow, and take steve_ v. and JG52Uther's advice

steve_v
03-28-2006, 04:44 PM
Now that you've got a grip back on your sanity, lets explore the basics.

Software installation.
Are you familiar with it, or are you a novice? Have you considered asking someone who may know, and is willing to help? I am talking about your parents.

Knowing what you're capable of, and the resources available to you, makes providing a workable solution easier.

slo_1_2_3
03-28-2006, 04:46 PM
Ok I may have forgotten battles working lets see................................

slo_1_2_3
03-28-2006, 05:09 PM
............. ok forgotten battles works now, it seems that the demo I downloaded and since deleted left some junk behind and got me all screwed up but now I'm on to ace expansion then pf then patches and then the rest of the world muahahahahahaaaa..

steve_v
03-28-2006, 05:11 PM
http://home.earthlink.net/~viner45/sitebuildercontent/sitebuilderpictures/1210.gif

slo_1_2_3
03-28-2006, 05:18 PM
Dang after ace expansion it says
:::::::::::::::::::::::::::::::::::::::::::::::::: ::::::::::::::::::::::::::::::::::::::::1628 Failed to complete instalation.:::::::::::::::::::::::::::::::::::::: ::::::::::::::
What's this mean?

slo_1_2_3
03-28-2006, 05:27 PM
WHen I try to play it now it says :
The application failed to initialize properly(0xc00000005). Click ok to terminate the application.
Why is this so freaking hard?!?

Taylortony
03-28-2006, 05:40 PM
Ok now try the FB rts.dll it might get rid of that message........

Also to get rid of the movie at the start in windows go

start

all programs

ubisoft folder to last window in it

click on set up

then on any of the windows

and untick the intro box at the very bottom of the window.that gets rid of the movie..... hang in there it is worth it all and take it step by step, listen to the people helping you, dont start uninstalling etc till people tell you if its the way to go http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gifhttp://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gifhttp://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

slo_1_2_3
03-28-2006, 07:17 PM
Now the pacific fighters standaloe says this when I put the second disk in:
:The application failed to initialize properly(0xc00000005). Click ok to terminate the application.
I think I have that figured out now too but I'm just waiting for something else to mess up.
Man I think I know the troubles I was always hearing about but I always thought man they must just be big morons if they can't put disks in at the right time but o well

slo_1_2_3
03-28-2006, 07:27 PM
Dangit now its telling me t insert disk 2 (pf) and i did and its not freaking reading it.
@%$^!(@&*(!@#&^@*#({)#
wouldn't that just make my day to finally get the stuff to go online with every body then the thing I've had all along breaks . OMFG #$@%*

(edit) O sorry just me spazzing again it was dirty and I wiped it off now it works.
I also would like to know hich disk am I gonna play the merged verson on? is it pf disk 2?

slo_1_2_3
03-28-2006, 09:36 PM
Originally posted by Taylortony:
wait the link was for the Pacific fighters version go here for the FB one http://forums.ubi.com/images/smilies/disagree.gif

http://ubisoft.custhelp.com/cgi-bin/ubisoft.cfg/php/end...9y&p_li=&p_topview=1 (http://ubisoft.custhelp.com/cgi-bin/ubisoft.cfg/php/enduser/std_adp.php?p_faqid=1109&p_created=1046901133&p_sid=Ag5lOD3i&p_lva=10061&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PWRmbHQmcF9ncmlkc29yd D0mcF9yb3dfY250PTImcF9wcm9kcz0wJnBfY2F0cz0wJnBfcHY 9JnBfY3Y9JnBfc2VhcmNoX3R5cGU9YW5zd2Vycy5zZWFyY2hfb mwmcF9wYWdlPTEmcF9zZWFyY2hfdGV4dD1SVFMuZGxsIGVycm9 y&p_li=&p_topview=1)
WHich ne am I supposed to download? the top one or the bottom one?

slo_1_2_3
03-28-2006, 09:55 PM
and why does it read forgotten battles ace expansion and all the dsks until i get fb+ace+pf installed?

eskimo-again
03-29-2006, 02:41 AM
this thread delivers http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

i hope it is all working for you now http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

may i make a suggestion ?
once you have it all running patched and working just make a backup copy of the il2 folder to a dvd.

so incase you need to reinstall you can just move the folder back and get going. no install hassles.

nicolas10
03-29-2006, 08:15 AM
Have you tried testing your memory sticks with memtest86?

Nic

blackpulpit1970
03-29-2006, 10:52 AM
This is the funniest thing ive read all day, sorry bro but i have never seen anybody have this much trouble before. The process is quite simple really. Uninstall everything and then delete any UBISoft things you may have from before, then install forgotten battles,ace expansion,pacific fighters merged(red disk first),pacific fighters(blue disk) then patches from herehttp://www.airwarfare.com/guides/patching.htm Go to the merged seection. Hope this helps and do as your name says SLOW down mate.

Copperhead310th
03-29-2006, 08:04 PM
Originally posted by blackpulpit1970:
This is the funniest thing ive read all day, sorry bro but i have never seen anybody have this much trouble before. The process is quite simple really. Uninstall everything and then delete any UBISoft things you may have from before, then install forgotten battles,ace expansion,pacific fighters merged(red disk first),pacific fighters(blue disk) then patches from herehttp://www.airwarfare.com/guides/patching.htm Go to the merged seection. Hope this helps and do as your name says SLOW down mate.


1 thing to remember,
Intaslling this sim is the same as PLAYING this sim.

Both require:
Skill
Pateince
Determination
A stiff alcoholic beverage
and a mild sedative

Enjoy.

Xiolablu3
03-29-2006, 08:47 PM
I think his CD drive is not reading the discs properly by the sound of it.

I get those errors when trying to use cds on older computers which I have burned on a cd writer.

I could be wrong, but that is what I think without seeing the error.

What are your computer specs? Computers are harder to use than consoles but the games are deeper and much more reqarding, plus you dont get free stuff from patches or game updates for consoles.

Take it slow and learn, also tell us your system specs.

slo_1_2_3
03-29-2006, 09:27 PM
Nope I got it going now no more problems at the moment.

slo_1_2_3
04-04-2006, 10:44 AM
Ok I juus had to ask I mean realy, Have you ever seen some one so pathetic that it took them two days to install the gol pack and well that took them almost a year to get it?

slipBall
04-04-2006, 11:09 AM
Originally posted by slo_1_2_3:
Ok I juus had to ask I mean realy, Have you ever seen some one so pathetic that it took them two days to install the gol pack and well that took them almost a year to get it?


You do now hold several record's http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif

slo_1_2_3
04-04-2006, 11:24 AM
Just wondering.

slipBall
04-04-2006, 12:40 PM
I was just kidding, It take's us all along time to reinstall everything. That's why I'm looking forward to my DVD copy http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

steve_v
04-04-2006, 01:34 PM
Originally posted by slo_1_2_3:
Have you ever seen some one so pathetic that it took them two days to install the gol pack and well that took them almost a year to get it? Some of the best times I've had with friends doing new builds/ocing falls in the category of "software stupidity". Alcohol only insured a quicker arrival. At least you didn't have to reformat a corrupted hd. We all have our own stories, and you now have yours. http://home.earthlink.net/~viner45/sitebuildercontent/sitebuilderpictures/bricks.gif http://home.earthlink.net/~viner45/sitebuildercontent/sitebuilderpictures/icon_axe.gif http://home.earthlink.net/~viner45/sitebuildercontent/sitebuilderpictures/082.gif

slo_1_2_3
04-04-2006, 01:54 PM
http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif How true how true, Man you don't know how p-oed I was getting those 2 days I was thining all kinds of stuff,like my pf cd finaly got one to many scratches or my comp finally poooped ou all of which would have costed cash to fix which I don't have.
But it was probably cause I wasn't taking the advice that was being givin to me and I rushed and wasen't using the right rts.dll file.
I would just liuke to say thank you to all that helped me through my struggle and I hope to see some of you in the virtual skies of hyperlobby. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif http://forums.ubi.com/images/smilies/25.gif