View Full Version : d3dx9_42.dll

11-03-2010, 03:56 PM
I can't play SH5 because the game ned this file: d3dx9_42.dll
What can I do?

I'm spanish and mi english is very basic.

11-03-2010, 04:07 PM

For this problem, you need to first Update/install the DirectX 9 files. Update them from here:

http://www.microsoft.com/downl...C3-AE91-50CEB6D8FA8D (http://www.microsoft.com/downloads/en/details.aspx?FamilyID=3B170B25-ABAB-4BC3-AE91-50CEB6D8FA8D)

Btw, if you have Windows XP, then you can try launching the game, and see what happens. I always Dual-Boot my PC, so that I can troubleshoot things at my end. I presume your OS is Windows 7/Vista ?


11-03-2010, 04:25 PM
Sorry, I install this files and the problem continues.

I can see the file d3dx9_42.dll in a carpet of the DVD and I copy/past in the C:ubisoft/silent hunter 5

Now I can see a loading bar (Updating launcher) but the game isn't run.

11-03-2010, 04:42 PM

Oh, actually I couldn't understand the SECOND line of your post. Are you placing the file inside the SH5 folder ? This file should also be under the 'C:\WINDOWS\system32' path. Are you still getting the SAME DirectX error as before ?

Which Operating System/OS are you using ? And what are your FULL PC specs ? Do you meet the Game's minimum requirements ?


11-03-2010, 04:58 PM
Sorry but I don't speak english and it's very dificult for me.

My OS is WINDOWS 7 64 bits, Intel Core 2 Quad 2.50 Ghz, 6 GB RAM and yes, I placing the file inside the SH5 folder... but I delete this files.

I updating DirectX whith an aplication of the folder support/directx in the DVD.

11-07-2010, 06:50 AM
Originally posted by Frayle5js:
Now I can see a loading bar (Updating launcher) but the game isn't run.

SORRY for the delay in getting back......

Well, this could be a UBI Game Launcher issue, IMO. Which Internet Connection are you using ? Are you behind any Router firewall, and/or Proxy ? Please also disable any Windows firewall. And make sure you run the Game/Game Launcher, with full ADMIN rights.

OK, <STRIKE>as your PC specs are fine</STRIKE>, have you also tried reinstalling the FULL game again, on some other Hard drive location/folder, if this problem persists ? (Don't use the same Windows path/folder. Give the installer a different/new path). Do a FRESH install of the game, and after installing first try using the DEFAULT in-game Video settings. Also try this method which I'm giving below:

First Close unnecessary programs that automatically load on start-up, and background tasks:

To do this click Start, then Run, then type MSCONFIG and click OK. Windows 7 will launch Microsoft's System Configuration Utility. Click on the Startup tab. This takes you to a page with a list of 'startup items'. Some startup programs are absolutely necessary, others are simply a waste of RAM. Disable only those programs that you recognize, and don't need to have running all the time. When in doubt, leave it on. Click on the OK button. A message will pop up telling you that you must restart your computer before these changes will take effect. Click on "Restart" and your computer will automatically reboot.

Delete all Temporary files from your system:

From the Start menu, select RUN and type %TEMP% and click OK, this will bring up your Temp folder, Delete all the files in this folder. You may need to turn on the ability to view hidden files and folders to do this. To do so, double click My Computer, then click Tools and Options. Then click View, and select the option to view all hidden files.

Now, which version of game do you have, Retail DVD or STEAM ?

First you must Manually delete the entire 'Ubisoft Game Launcher' folder, e.g. from C:\Program Files\Ubisoft\Ubisoft Game Launcher. Also remove it from Control Panel----> Programs & Features. Make sure the UbisoftGameLauncher is fully removed from these locations, BEFORE installing it again.

After that again reinstall the Game Launcher from the disk/DVD. Browse the DVD, and go to 'Support-----> Game Launcher', and run the UbisoftGameLauncherInstaller.exe file. STEAM's path should be something similar like this e.g.: C:\Program Files (x86)\Steam\SteamApps\Common\Silent Hunter 5\Redist\GameLauncher\UbisoftGameLauncherInstaller .exe.

OR, reinstall the 'Game Launcher' software from here:

http://static3.cdn.ubi.com/orb...auncherInstaller.exe (http://static3.cdn.ubi.com/orbit/launcher_installer/UbisoftGameLauncherInstaller.exe)

If the above methods still don't work, then you can try deleting the 'Registry' entries of the Launcher. (i.e. from HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Ubisoft\Ub isoft Game Launcher, or HKEY_LOCAL_MACHINE\SOFTWARE\Ubisoft\Ubisoft Game Launcher.)

On a side note, If you face any kind of connection problem, or get an error while connecting, then try clearing the Windows HOSTS.txt file. Though this won't be always necessary. Anyway, locate the HOSTS.txt file found under this path, C:\Windows\System32\drivers\etc. Open it with notepad, and then 'Delete' everything below these two lines of text: localhost
::1 localhost

Now save the file, and try launching the game. First make a backup, and change the *properties* of this file, if needed.


11-09-2010, 06:09 AM


Actually, which Graphics Processor are you using ? Do you have a proper dedicated GPU, or you are playing the game on your System's onboard Chipset/processor ?

Kindly ignore the above suggestion of mine, for the time being, if you don't have a proper Graphics Card. Sorry I overlooked your System specs......