View Full Version : @Support : The dedicated linux server does not work!

06-06-2009, 04:20 AM
It seems, that the provided files are not really working in online mode.

Another german customer reported the same problem at the german ubi board.

Error Message:
278 - MESSAGE BOX: Logging in…
280 - CAccountService::OnLogin(): Client=11111111111111 Result=E_SESSION_ERROR_CORE_GAME_CONNECT_UNREACHAB LE
281 - MESSAGE BOX: Could not reach Far Cry® 2 servers.
282 - MESSAGE BOX: The Far Cry® 2 server is not available at this time. Please try again later.
283 - Dedicated server exit: Info not set.

Tested on Debian Linux 32 bit and 64 bit (Lenny) and on openSUSE 11.1 64 bit.

Tested on 3 different locations (behind a privat router and two professional webserver at two different housings).

Please look at the provided files or if there are some parameters we have to use for the linux version, then provide a small documentation for it. The --help parameter only provides parameters for the log and cfg file.

At this state, the dedicated linux server is unusable. If you want to have more servers online, then the dedicated linux server has to work. I guess that you also know, that most professional webservers are running under linux!


06-06-2009, 09:25 AM
Hi! Just tried it again and something is a bit different. The message "logging in..." lasts a bit longer before the errormessage comes up. It looks like, that it get a connection, but was rejected and results now in a timeout. Also the ...server is not available... message comes now twice:

278 - MESSAGE BOX: Logging in…
279 - Login failed with error : E_SESSION_ERROR_CORE_TASK_TIMEOUT
280 - CAccountService::OnLogin(): Client=46291157516287 Result=E_SESSION_ERROR_CORE_TASK_TIMEOUT
281 - MESSAGE BOX: The Far Cry® 2 server is not available at this time. Please try again later.
282 - MESSAGE BOX: The Far Cry® 2 server is not available at this time. Please try again later.
283 - Dedicated server exit: Info not set.


06-06-2009, 09:31 AM
!!!! Got a connect! There seames another port beeing blockt here, but I guess I'll find out which one.

06-06-2009, 09:33 AM
Good luck Linux users, great OS but crappy at the same time http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif.

06-06-2009, 09:46 AM
I'll give it a whirl as well on Debian Lenny.

06-06-2009, 10:59 AM
Okay, got the ports for running iptables on a webserver. For login' there is an additional port used for a short time.

Here we go:

IN_ALLOWED_TCP="9000 9001 9002 9003 9004"
OUT_ALLOWED_TCP="3074 3078 3100 9000 9001 9002 9003 9004"
IN_ALLOWED_UDP="3074 3075 9000 9001 9002 9003 9004"
OUT_ALLOWED_UDP="3074 3078 3100 9000 9001 9002 9003 9004"

I ran my firewall so the login process lasts a bit longer. Enough time to look via netstat -a and I noticed the port 3078 http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

The server works now. Now time to find out how to get a connect from within the same network http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif


06-06-2009, 05:18 PM
That's awesome hrgargi!!

06-07-2009, 07:06 AM
I've written a little tutorial howto setup a FC2 linux server. For now only in german, but I'll try to translate into English later.



09-15-2009, 09:46 AM
what if we want to put custom maps running on a linux dedicated server ? what would be the :

SetSetting map_cycle value for example map called demo.fc2map.

I tried putting it in /root/MyGames/....
even any other custom folder but it gave me error message :

304 - Dedicated server exit: ERROR: Try to create a session without a valid map

09-15-2009, 01:59 PM
You may be getting the message because of this http://forums.ubi.com/images/smilies/16x16_smiley-wink.gif
Server maintenance and downtime (http://forums.ubi.com/eve/forums/a/tpc/f/5071014757/m/4041019887)

09-15-2009, 04:02 PM
no thats not it...i can run the default maps, but i cant add any custom maps because the linux dedicated launcher wont accept the path where the maps are.
Its not a server downtime thing...its a launcher thing.

09-15-2009, 04:42 PM
Ive seen some of your maps Sandbirds....

Shame you cant get the server running customs. http://forums.ubi.com/images/smilies/16x16_smiley-indifferent.gif

09-16-2009, 04:27 AM
Hi agent http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif
My maps suck compared to yours lol.

My upload speed sucks at home, but the server at work has a linux and a good upload speed.

I've tried everything...5 hours yesterday tried to do this...

If anyone has managed to do so and doesnt want to share the howto...just reply that you have done it, i just want to know that it can be done http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif


09-16-2009, 06:36 AM
im not 100% sure, but I am pretty sure I have seen this issue before. Have you tried searching the forums (with the Find functin of course) for another similar thread? I remember a guy trying to run a Linux srv, but I dont remember the outcome.

09-16-2009, 07:13 AM
yup, i've searched this whole forum, google, even opened the server files with a hexeditor try to see there if there are any clues. No one has posted anywhere about running custom maps. Only how to run the server with default values.