PDA

View Full Version : Getting heavy flickering and blocky textures with anti-aliasing and OpenGL - ATI 5870



RedRiver83
12-26-2011, 05:23 PM
Why do i get these flickers and blocky textures when im running opengl and anti aliasing on my ATI card? It appears in some angels and when zooming out.

See video. http://youtu.be/P42cdTAcY_4

IL2 sturmovik 1946 4.10.1m + UP 3.0 RC4 (steam version)
ATI 5870 @ 1920x1080
Catalyst Version 11.12

conf.ini


[window]
width=1920
height=1080
ColourBits=32
DepthBits=24
StencilBits=8
ChangeScreenRes=1
FullScreen=1
DrawIfNotFocused=0
EnableResize=0
EnableClose=1
SaveAspect=0
Use3Renders=0


[Render_OpenGL]
TexQual=3
TexMipFilter=3
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=0
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=0
TexFlags.UseVertexArrays=0
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1 (now works with ATI)
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=0

TexFlags.TexEnvCombine4NV=0 (1 for Nvidia)
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=0 (1 for Nvidia)
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=0 (1 for Nvidia)

HardwareShaders=1

Shadows=2
Specular=3
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=3
LandShading=3
LandDetails=2

LandGeom=3
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
Water=1
Effects=1
ForceShaders1x=0

PolygonOffsetFactor=-0.0625
PolygonOffsetUnits=-3.0

dglasal
12-26-2011, 07:54 PM
Change the following line in your config.ini:

Water=1 change to Water=2

Number ratings available:
0 is the simplest rendering
1 is simple hardware-rendered water-surface
2 optimized for AMD/ATI-cards
3 & 4 optimized for nVidia graphics cards

Hope this helps

wayno7777
12-26-2011, 08:40 PM
If that doesn't work, see this post....Been having that problem since Cat 11.5's....
http://forum.1cpublishing.eu/s...d.php?t=22765&page=5 (http://forum.1cpublishing.eu/showthread.php?t=22765&page=5)

Woke_Up_Dead
12-26-2011, 09:52 PM
Originally posted by dglasal:
Change the following line in your config.ini:

Water=1 change to Water=2

Number ratings available:
0 is the simplest rendering
1 is simple hardware-rendered water-surface
2 optimized for AMD/ATI-cards
3 & 4 optimized for nVidia graphics cards

Hope this helps

That's interesting, where did you get this information? Do you know any other tips for ATI cards?

dglasal
12-27-2011, 04:26 AM
Just reviewed my Catalyst Control Center 3D Application Settings, did some playing around with it and discovered or shall I say re-discovered that when "SMOOTHVISION HD: Anti-Aliasing" was not set to "Use application settings" I had flickers. When I clicked the box for "Use application settings" the flickers went away. Remember, Il-2 been around for a while, our newer cards (5000 series and up) came well after. With all the improvements and capability these cards bring, the code for Il-2 was not written for them. But I'm far from being an expert.

WP: Mission4Today.com website. Go to Setup Guides -> Conf.ini Guide. For ATI cards see [Render_OpenGL]. The information may be dated but I do not think that settings like these change that much. Please note, this is a guide; modify to your liking and particular computer set-up.

RedRiver83
12-27-2011, 05:46 AM
Originally posted by wayno7777:
If that doesn't work, see this post....Been having that problem since Cat 11.5's....
http://forum.1cpublishing.eu/s...d.php?t=22765&page=5 (http://forum.1cpublishing.eu/showthread.php?t=22765&page=5)

Thanks all for helping me out. The fix for me was the atioglxx.dll file. Gonna put it in a safe place for future use.

The file should be in the installation as default.

wayno7777
12-27-2011, 08:02 PM
JOriginally posted by dglasal:
when "SMOOTHVISION HD: Anti-Aliasing" was not set to "Use application settings" I had flickers. When I clicked the box for "Use application settings" the flickers went away.

And the reason for that is the game does not use AA.
By putting the atioglxx.dll file in your game folder you can use AA again. It was culled from the 11.4 CAT.

megalopsuche
12-31-2011, 08:46 AM
Thank you for this thread! Now my Il-2 install looks as good as ever!