View Full Version : Game Won't Log In - Can't Play Online

02-24-2006, 06:28 AM
When I enter the in-game browser and try to log in to ubi.com nothing happens. The login window just stays there. My account works perfectly on ubi forums and sites, so WTH?

I also disabled my firewall and that didn't help.

02-24-2006, 04:41 PM
Yeah im ahving a similar problem... my profile signs in fine, but b/;c i just got a new pc, i had to re install, and put in the cd key... the thing pops up w/ "CD KEY SERVER NOT RESPONDING, TRY AGAIN LATER" any ideas?

02-25-2006, 02:50 AM
is there any news on when the cd key server will be back up? been waiting 2 days now to play, cuz i just re-installed it after a format.

02-26-2006, 09:54 AM
When i type in my cdkey in the mpgame it says its invalid... tried many times now.. bought ravenshield and athena sword and it came today =/ anyone nows why its laike that? need to do something special to type in the cdkey?

02-27-2006, 06:58 PM
Enable UPnP on your router, Port Forward the Recommended Ports for the CD Authentication if you want to use the Game Service. Otherwise, you will continue to install your game. Wash, Rince, Repeat. The port info is in the Multiplayer FAQ.

02-27-2006, 09:51 PM

Leoncatz, could you expand a bit on your solution in simpler terms?

I have a firewall and set it for full access to Ravenshield.

02-28-2006, 05:45 PM
you need to port forward the following in order for your RvS game to passthrough your router properly. * indicates that you need to forward for both TCP/IP and UDP just because it's simpler and is a fail safe setup.

* 5777/5777
* 6777/6777
* 7777/7777
* 8777/8777

If you are connecting via LAN at a LAN party, you may need to port forward more as follows.

* 5777/5777
* 6777/6777
* 7777/7777
* 8777/8777
* 9777/9777
* 10777/10777

That's generaly enough to allow a full 8 coop or 16 adv players passthrough for authentication.

As a general rule, most of this type of BS can be done away with if you configure your UPnP service in Windows 2K, XP, 2K3 to Auto and reboot. But make certain that you have also enabled UPnP in your router's configuration screens. UPnP services automatically opens ports from your machine and router, permitting the full passthrough that you require. This is an outgoing feature ONLY. That means that anyone from outside your router CAN NOT/ SHOULD NOT be able to passthrough UNLESS you are running an application that opens the ports anyways. Effectively, this alleviates the desire to go into DMZ unprotected.

That's about as much as I can explain without turning this into a Networking 101 type of forum. Note that I will probably post this information in another thread because this was alot of typing.

Good Luck.

02-28-2006, 10:20 PM
I have turned on upnp, and forwarded ports and i have it DMZ. still no response from key server.

03-01-2006, 06:45 AM
In that case, you seem to have everything you can on your end. It must be a problem with UBI at that point. *shrug*

03-01-2006, 10:12 AM
This is a problem of Patch 1.6, but theres a fix for it. You can find it here:


This file is an installer, that modifies the "gsrouters.dat" in the "Ravenshield\System"-Folder. If you don't want to download the fix you can fix the file yourself. Open it with a text-editor and replace the [Servers]-section with the following:


03-01-2006, 01:46 PM
what is this fix and why has noone else mentioned it?
is this real or a virus

03-01-2006, 03:03 PM
is this because i'm just getting this game now as opposed to people who have had this for over 2 years? not many people have to register? i'll try this...

03-01-2006, 04:24 PM
There was a post in the Community Help forum, which is now unavailable, that talked about uninstalling McAfee Privacy software. Disabling it did not work, but uninstalling it fixed the CD key server cannot be found error for a lot of people. So if you have McAfee software installed, might want to try that.

You don't need to forward any ports on your router unless you are running a server. Port forwarding only works for INCOMING connections, so it's pointless to forward a port that will be used for an OUTGOING connection. It won't help you.

If you are running a server behind a router, the only ports that REALLY need to be forwarded are:

7777-7787 UDP
8777-8787 UDP

The rest are outgoing connections and are not needed to be forwarded.