PDA

View Full Version : Exit point



davodafone
10-25-2009, 04:43 PM
Hello,

I'm building a wildwest legend and i would like to create a "Runaway" point, as the last objective in Nogales Wild west Legend.

I just don't know what kind of object to use (Waypoint, sensors,...) and how to parameter it to run the last action_chain. I tried a lot but failed.

Sum-up : The Reds have blown everything and will runaway --> how can i launch the last action_chain and finish the game when a red player join the final locations ?

Thanks for your help.

czaq
10-26-2009, 05:31 AM
Place a sensor, set the team for it, and copy actions from onExplode on the dynamite that you want to switch for this sensor.
Also, I suggest you make it disabled by default, and only enable it when the dynamite before it explodes (act_Enable)

Vladd90
11-08-2009, 10:35 AM
Originally posted by czaq:

Also, I suggest you make it disabled by default, and only enable it when the dynamite before it explodes (act_Enable)

Please, write more in detail how to make it. http://forums.ubi.com/groupee_common/emoticons/icon_rolleyes.gif

seir
11-09-2009, 01:23 AM
Go to the "Selections" window. Click on "Historical" - you'll open the objects list for Wild West Legends mode. Now find AC (ActionChain) that contains actions for last objective. Default name of this chain is "ac_3obj001". Now you'll need to click on this object from the list and click on "Select objects" in the same window at its bottom part. Look at the screenshot:

http://img41.imageshack.us/img41/6728/61154528.jpg

Now in "Object attributes" window double click on "4 items" to add new "null" field in action list.

http://img41.imageshack.us/img41/6728/61154528.jpg

Click on "null" and choose "act_EnableDisable". Now add your sensor to "cTarget" field. in "cType" leave option "_ENABLE".

Now you enabled your sensor. Remove action "actNet_FinishRoundTeam", go to your sensor, uncheck "Enabled" field, go to "onEnter", add new line by double click on "empty" field right to the "onEnter" text. Click on "null" and choose action "actNet_FinishRoundTeam" and choose "RED" in field "TeamWinner".

That's it http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Vladd90
11-09-2009, 03:28 AM
Originally posted by seir:


Click on "null" and choose "act_EnableDisable". Now add your sensor to "cTarget" field. in "cType" leave option "_ENABLE".



For some reason when I made this actions with ac_3obj001, sensor did not apeear. So I made it with ac_2obj001. Now it works.)
Thank you, Seir!

davodafone
11-09-2009, 11:19 AM
One of my problem was finally the position of the sensor, too low in the ground. I put here upper, and then worked perfectly.