PDA

View Full Version : The patch to Myst 4



talanimal
03-07-2005, 02:47 AM
I've just loaded the patch (1.02) for Myst 4. I started the game already so I'm hasitant to install that patch. Are there any known issues about problems with the patch for the PC? I own pentium 4 with XP SP2 and Geforse FX 5200 card.

I understand there's going to be a new patch soon. Should I wait for it, or is it better to use the current version in the meantime?

Where can I post requests for patches? Is it possible to ask for improvements and not just bug corrections?

Thanks for any input
T.

GadrenURU
03-07-2005, 04:30 AM
there's already a patch 1.03...look on Mystworlds.com for the links.

talanimal
03-08-2005, 01:54 AM
Thanks, GardenURU.
Where can I find a list of the issues that the new patch is "patching"? I followed the links on the site you told me about, but the list of corrected issues is from July, 2004. Surely there are some additions in the 1.03 patch!

Also: should I install both patchs? I downloaded both and was surprised to see that patch 1.02 is 42 Mb, and patch 1.03 is just 15 Mb. Doesn't patch 1.03 contain the corrections in patch 1.02?

Any input will be apreciated
Thanks
T.

Heimdall_G
03-08-2005, 10:08 AM
Patches can sometimes introduce very strange and difficult-to-fix problems. My experience has been that installing a patch should be done only in response to problems, not simply because the patch is available. So, if you aren't having problems, I'd recommend not installing any patches.

In general, if it ain't broke, don't fix it....

LordTulla
03-10-2005, 01:49 PM
FYI, If anyone is relying on the Myst IV "No DVD Patch" to play the game, it will no longer work after you install the v1.03 patch.

You'll have to uninstall the entire game, load version 1.00, upgrade to the v1.02 patch and then apply the "No DVD Patch" - thanks UBI http://forums.ubi.com/images/smilies/16x16_smiley-mad.gif

talanimal
03-12-2005, 04:04 AM
Wow, people, this patch thing is more troublesome then I thought! http://forums.ubi.com/groupee_common/emoticons/icon_rolleyes.gif

What's "No DVD patch"? My Myst IV is on DVD, and so far I didn't install any patches. Is there a Myst IV version on CD-Rom?

LordTulla, I assume when you say Version 1.00 you mean the original game. Am I right, or is that another patch? http://forums.ubi.com/images/smilies/blink.gif

Thanks for helping
T.

LordTulla
03-12-2005, 05:05 AM
The "No DVD Fix" (patch) is something UBI Support provided on their support website (Oct 2004) that allows you to play the game without having the DVD in the drive. It worked with all MYST IV versions up to 1.02. However, it will not work with v1.03.

But the link to that "patch" was either moved, or the page removed, (without any explanation) a month or so ago. Also there seems to be some sensitivity to discussing this issue in this forum - posts disappear. http://forums.ubi.com/images/smilies/10.gif

Yes, by v1.00 I mean the original game.

Heimdall_G
03-15-2005, 09:12 AM
The v1.03 patch (15.4 MB) is available here (http://www.ubi.com/US/Downloads/Info.aspx?dlId=708).

"Fixed in version 1.03

PC & MAC

- Subtitles for English, Italian, German, French or Spanish are now available.

- Fixed some memory leaks and random crashes.

PC ONLY

- The NVidia driver 66.93 is not working properly with some combinations of AMD CPU and Geforce 4MX.
We recommand users to upgrade their driver when a new release will be available from NVidia."

talanimal
03-17-2005, 12:55 PM
No English subtitles for the PC? It can be real helpfull, and a good reason to install a patch.
Since, as I can see in previous entries, installing patches might be a bad idea, I'd like to have a patch that fixes nothing but adds subtitles in English. Do you think we can somehow convince the patch-makers to do this for us? They can through in a way to print the journal, too.

Oh, and one more question: is it ok to install a newer patch without installing the older one, or will this couse troubles?

Happy gaming
T.

Heimdall_G
03-17-2005, 01:39 PM
Well, gosh, T.

If ya reads real close, ya sees that it sez:

"PC & MAC

- Subtitles for English, Italian, German, French or Spanish are now available."

Yep, yep, the 1.03 patch does subtitles in English for the PC, you betcha!

<Ahem>. Seriously though, folks. The latest patch usually contains everything that the earlier patches contained, unless otherwise noted. So, no, you don't usually need to install an earlier patch to install the latest one. However, if the latest patch doesn't install, try installing the earlier one(s), then the latest.

talanimal
03-20-2005, 11:30 AM
Well, Heimdall, I guess PC, being just two letters, was a bit lost on me! http://forums.ubi.com/images/smilies/1072.gif oh, and 5 points for a well delivered sarcastic remark... http://forums.ubi.com/images/smilies/88.gif

I know that later patches usualy contain the older ones, I just thought it was wierd that patch 1.02 was almost 3 times larger that patch 1.03. I expacted the new patch to be larger if it has all the changes from the old patch.
That brings me to another important question: Did they fix all the bugs from the other patches? I sew lots of complains about the old patch, and I remember your "don't fix" recomandation, so I'm realy afraid to use any patch. The subtitles are very tempting, though...

Thanks
T.

Heimdall_G
03-20-2005, 12:30 PM
Hopefully, the bugs from the earlier patches were fixed, but I can't guarantee it! The difference in file size may well mean that the 1.03 patch is only an overlay on the 1.02 patch code, and doesn't contain the earlier code. But it should contain fixes....

If you really want the English subtitles, I'd say go ahead and install the 1.03 patch. The worst that can happen is that you'll need to re-install the game if there are glitches. Just back up your Revelation Program Files \sav folder before applying the patch, so that you won't lose any game progress.

Heimdall

talanimal
03-26-2005, 04:58 AM
Thanks, Heimdall, I'll do that.
They don't always speak clearly in the English version of the game, so I'd love to have subtitles.

Happy gaming
T.

talanimal
04-12-2005, 11:38 AM
Hi all
As I said, I've decided to install patch 1.03 on my system, without patch 1.02. I wanted the English subtitles.
I've been playing Spire for a while, and so far no problems at all. I guess that means patch 1.03 is ok on its own, at least on my system.
I just thought I'll let people know.

BTW: I second Heimdall's recomandation about backing up saved games before installing patches. The fact I had no problems doesn't mean it'll work well on all systems.

Thanks again for all your help
T.

avt84
03-07-2007, 03:52 PM
Is there any way to update Myst 4 that isn't completely installed on my computer? There's only needed parts installed on my disk.

Heimdall_G
03-08-2007, 12:02 PM
Welcome to the Forums!

By "... Myst 4 that isn't completely installed on my computer", do you mean that you did a minimum install of Revelation from the original DVD's? And are you having problems with the game that make you want to update it?

avt84
03-08-2007, 04:49 PM
Originally posted by Heimdall G:
Welcome to the Forums!

By "... Myst 4 that isn't completely installed on my computer", do you mean that you did a minimum install of Revelation from the original DVD's? And are you having problems with the game that make you want to update it?

Thank you!

Yes, it's a minimum install from the original DVDs (two of discs). I haven't had any problems with Myst IV - at least not yet. I'm just curious about what to do when getting any problems that could be solved with the update.

Heimdall_G
03-08-2007, 05:12 PM
The Revelation patches are available here (http://www.ubi.com/US/Downloads/Info.aspx?dlId=708). I recommend applying the 1.02 patch and then the 1.03 patch. The 1.02 patch is 41.1 MB, while the 1.03 patch is only 15.4 MB, which may mean there's "good stuff" included in 1.02 that isn't included in 1.03. Apply the patches as follows after installing or re-installing Revelation, being certain to log into Win XP with full Administrator privileges:
-- a. Close all open applications.
-- b. Click on Start > Run.
-- c. Browse to myst4_v1.00_to_v1.02_pc.exe, and double-click on it to put it in the Open: box.
-- d. Click on OK to start the install process.
-- e. Follow the Wizard's instructions, and accept the install defaults.
-- f. Reboot when installation is complete.
-- g. Close all open applications.
-- h. Click on Start > Run.
-- i. Browse to myst4_v1.0_to_v1.03_pc.exe, and double-click on it to put it in the Open: box.
-- j. Click on OK to start the install process.
-- k. Follow the Wizard's instructions, and accept the install defaults.
-- l. Reboot when installation is complete.

avt84
03-08-2007, 08:01 PM
Originally posted by Heimdall G:
The Revelation patches are available here (http://www.ubi.com/US/Downloads/Info.aspx?dlId=708). I recommend applying the 1.02 patch and then the 1.03 patch. The 1.02 patch is 41.1 MB, while the 1.03 patch is only 15.4 MB, which may mean there's "good stuff" included in 1.02 that isn't included in 1.03. Apply the patches as follows after installing or re-installing Revelation, being certain to log into Win XP with full Administrator privileges:
-- a. Close all open applications.
-- b. Click on Start > Run.
-- c. Browse to myst4_v1.00_to_v1.02_pc.exe, and double-click on it to put it in the Open: box.
-- d. Click on OK to start the install process.
-- e. Follow the Wizard's instructions, and accept the install defaults.
-- f. Reboot when installation is complete.
-- g. Close all open applications.
-- h. Click on Start > Run.
-- i. Browse to myst4_v1.0_to_v1.03_pc.exe, and double-click on it to put it in the Open: box.
-- j. Click on OK to start the install process.
-- k. Follow the Wizard's instructions, and accept the install defaults.
-- l. Reboot when installation is complete.

I forgot to tell that I have Apple. http://forums.ubi.com/images/smilies/35.gif Sorry about that. I got my issue solved, the problem was that I had moved the game directory to a different location from the installed one.

Heimdall_G
03-10-2007, 01:47 PM
For reference, the Revelation 1.01 and 1.03 patches for the Mac are available here (http://www.ubi.com/US/Downloads/Info.aspx?dlId=709).