PDA

View Full Version : Can't get the Perfect Mode working - wierd



Alcoraz
01-31-2007, 12:47 AM
System:
-3400+ 1024MB GeForce 6800GT (93.71)

Settings:
-32bit colors
-Stencil Buffer ON
-OpenGL ON

In options perfect mode is grayed out and I can't set "HardwareShaders" to "=1"

Any ideas? http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

[Render_OpenGL]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=0

Shadows=1
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=3
Water=1
Effects=1
ForceShaders1x=0

PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0

LT.INSTG8R
01-31-2007, 12:58 AM
Change the line:

HardwareShaders=0

To

HardwareShaders=1

You are now in Perfect Mode.

Alcoraz
01-31-2007, 01:09 AM
When I change it to "=1" and start the game perfect mode is still grayed out and "HardwareShaders" has changed back to "=0" in conf.ini.

dbillo
01-31-2007, 07:44 AM
Look in the [Render_DirectX] section, and make sure that the HardwareShaders line there is =0

bazzaah2
01-31-2007, 08:01 AM
are you running in Open GL?

If not make sure you are, then you should have perfect mode available.

Alcoraz
01-31-2007, 12:30 PM
As I said I'm running in OpenGL mode. It seems that conf.ini settings restore to default every time I start the game. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

JSG72
01-31-2007, 01:43 PM
Originally posted by Alcoraz:
As I said I'm running in OpenGL mode. It seems that conf.ini settings restore to default every time I start the game. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

Do You
accept the changes to config?

Did you put Open GL in IL2 setup file before or after changing config

If you do accept then do a reboot and then try "In game" setup.

FoolTrottel
01-31-2007, 02:36 PM
In options perfect mode is grayed out and I can't set "HardwareShaders" to "=1"

Some time ago (few weeks?) this same problem came up in the Community Help Forum.

A solution was a change in some setting in the Nvidia Control Panel.

Trouble is, I can't find that thread! http://forums.ubi.com/images/smilies/35.gif

Maybe try looking over there...