PDA

View Full Version : need help with Uplay!!! URGENT



Fairus60
01-09-2010, 11:42 AM
well Ive tried to log in through my PC but it just keeps sending me to the main page after logged, but it only logs me to ubi site, not to Uplay,as if I hadnt entered my data, tried to enter through AC2 but it says the server is down and returns me to the game please anyone? Ive used it perfectly before, got all rewards, dont understand why it no longer works

DLTyrus
01-09-2010, 12:45 PM
I had the same problem the first time I tried to log onto Uplay. I tried agai nthe next day and it worked, so my guess is that it just goes down every now and then, it is still a beta afterall. Try again in a day or two or something, though I'm not sure why you'd need to if you've already got all the rewards. http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

Fairus60
01-09-2010, 01:35 PM
Originally posted by DLTyrus:
I had the same problem the first time I tried to log onto Uplay. I tried agai nthe next day and it worked, so my guess is that it just goes down every now and then, it is still a beta afterall. Try again in a day or two or something, though I'm not sure why you'd need to if you've already got all the rewards. http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif just tried again and now says there is an error in loading the info. I like to have a look there sometimes, even with all rewards XD

Fairus60
01-09-2010, 09:45 PM
anyone? could a mod help?

Realjambo
01-11-2010, 07:57 AM
What browser are you using?