PDA

View Full Version : stuttering framerates.



Michaeljcox24
04-07-2011, 11:17 PM
System specs:

Q9650 @ 4ghz 12hrs prime stable
GTX 470 @ 850MHZ aftermarket cooled
4GHZ 1066 HyperX DDR2
850W Corsair PSU

I game at 1920 by 1080 btw

And STILL this game is fps choppy in certain areas. Its like the game can't keep up with itself. I have AA off, Vsync off, after effects off etc....

What has made me very angry, is when I ran afterburner, the onscreen display showed that the game was only maxing out at 50% GPU usage, when the likes of Mafia 2 and Just Cause 2 utilise up to 90% and run smooth as butter.

And I've seen a lad on another forum with a GTX570 and I7 950 complaining of the same problem.

wtf is going on here?

This is an excellent game which is quite frankly spoilt on the PC by very poor utilisation of PC Hardware.

jaketimmons992
04-08-2011, 05:26 AM
Yep i've got the same problem too and apparently so do many others. I've got a similar system (intel quadcore @ 3.6Ghz, 4gb ram, GTX460 @ 900Mhz) and the game feels choppy as hell all the time.

It seems to me that it is actually a problem cause by poor mouse controls. When you turn the camera with the direction keys it seems to be perfectly smooth unlike when you turn with the mouse. If you're playing with a controller then i'm not sure what the problem is.

Unfortunately Ubisoft has a terrible history of addressing problems like this with patches so your best chance to play the game w/ a controller or just learn to put up with it. Sucks.

KingDaniel0
04-08-2011, 05:43 AM
-------------------------------------------------------------------------

@Michaeljcox24,

After playing the game for a while, have you also checked the CPU usage at the Task manager ? Are all the CORES fully utilized ?

You can also try disabling some of the cores, and play the game on 2 CPU cores, though Brotherhood seems to run fine on QUAD-core CPUs, unlike AC2.

By any chance, do you have Asus GamerOSD, and/or SmartDoctor installed on your computer ? Try to uninstall and remove these tools, as they have known to create a conflict with some of the PC titles, including AC:B. For your Video card, try playing Brotherhood on any latest BETA version of the Nvdia drivers, if possible.

Could this also be a Mouse Lag and delay, which you are experiencing ? Which OS do you have ?



--------------------------------------------------------------------------

Michaeljcox24
04-08-2011, 12:21 PM
Yup, all 4 cores are maxing out at 100%

I run windows 7, no apps in systray or background, on a gamepad.

Urgh

KingDaniel0
04-08-2011, 12:50 PM
Originally posted by Michaeljcox24:
Yup, all 4 cores are maxing out at 100%


So if you disable 2 of the CPU cores at the task manager, does it help overcome some of the in-game Stuttering, or any Lag ?

Or is the result same/worse, if you play it on 2 Cores ? Btw, have you tried playing the game under 'Windows XP SP2 Compatibility' Mode ? Does it make any difference ?



-----------------------------------------------------------------

Michaeljcox24
04-08-2011, 01:01 PM
playing on two cores makes the problem worse, whilst setting XP compatability mode makes no difference.

FPS in Fraps remains around 57-60, but the games stutters like heck, its not really a frame drop though I suppose.

Have the other lads who've had this issue used the beta driver to any success?

madarHR
04-08-2011, 02:12 PM
Originally posted by Michaeljcox24:
playing on two cores makes the problem worse, whilst setting XP compatability mode makes no difference.

FPS in Fraps remains around 57-60, but the games stutters like heck, its not really a frame drop though I suppose.

Have the other lads who've had this issue used the beta driver to any success?

exactly same problem

Michaeljcox24
04-08-2011, 02:29 PM
Thank you. I await to see what the admins say about this, it's **** poor performance for a 35 quid game when I can run JC2 maxed out with absolutely no stutter whatsoever.

They can do it right sometimes, because POP forgotten sands runs absolutely fine.

madarHR
04-08-2011, 02:32 PM
Originally posted by Michaeljcox24:
Thank you. I await to see what the admins say about this, it's **** poor performance for a 35 quid game when I can run JC2 maxed out with absolutely no stutter whatsoever.

They can do it right sometimes, because POP forgotten sands runs absolutely fine.

totaly agreed
and yes as i have said new beta drivers dont help at all

Ramdoode2011
04-10-2011, 09:24 AM
I have the same problem too.everytime I play the game for about 6 to 8 minutes, the game chrashes and breaks and freezes my pc,and i need to restart my computer. pls help , i dont know know why it keeps happenning,i tried everything lowering the graphics,updating the game,reinstalling it, disabling antivirus ,firewall, disabling startup programs even services in msconfig, my specs are fine ,even better than the recommended for playing Assassin's creed brotherhood according to system rating.my graphic card is a GTS 250 gigabyte lgb,my processor is an intel core2duo 2.80GHZ running on windows 7 32-bit.pls help ,i would really appreciate it.

KingDaniel0
04-10-2011, 09:29 AM
Originally posted by Michaeljcox24:
playing on two cores makes the problem worse, whilst setting XP compatability mode makes no difference.

FPS in Fraps remains around 57-60, but the games stutters like heck, its not really a frame drop though I suppose.

Did this stuttering start Only after applying the latest Patch 1.02 ?

As a side note, what happens if you enable and Force VSYNC to ON, both under GPU's Control Panel and in-game options ? Does it reduce any kind of micro-stutter ? But try to use this along with 'Triple Buffering', via any tool like RivaTuner.

Are you guys conflicting any in-game settings with your Video Card's Control panel ?

There is one old program/tool i.e. 3D-Analyze. Download it, and select the game's exe i.e ACBSP.exe, and tick the bottom option i.e. Remove Stuttering. You can also create a BATCH file and run it....

There are 2 modes here, Quality and Performance. Try the second one. But, I doubt this is going to work on Brotherhood, as the game is very new and the ENGINE is different, and this option works best on OLD Video cards and games. But you can give it a try.

http://www.3dfxzone.it/dir/tools/3d_analyze/download/


----------------------------------------------------------------------------

Mr_Shade
04-10-2011, 09:58 AM
Can I remind everyone to report the issue to support as well..

Appears a few new cases of this have appears since the recent patch, which even though it wasn't to do with things that could have affected performance, it may have something to do with it.

Please make sure you let them know all of the specs and drivers you're using.


You can contact support via the 'contact us' link, or the direct link in my signature.

Michaeljcox24
04-10-2011, 10:42 AM
I've contacted support thanks.

For me, it's happened ever since I bought the game. Should it run smoothly? Or is what people are saying, that it barely uses any of the GPU in the PC and relies massively on CPU be true?

if the latter is true, a patch should be released by ubi that makes the game fully utilise the GPU in these peoples machines (including mine). It's not fair otherwise.

RasGhi
04-11-2011, 05:38 AM
Yea, it happened the first day I bought the game too.

KingDaniel0
04-11-2011, 05:46 AM
Originally posted by RasGhi:
Yea, it happened the first day I bought the game too.

Did you try that 3d-Analyse option which I gave ? Does it work for Brotherhood, or it makes no difference in the game's performance ?



-------------------------------------------------------------------------------

RasGhi
04-11-2011, 08:35 PM
Nothing changed. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

Michaeljcox24
04-12-2011, 12:33 PM
I dont think there is a known fix for this. I've been in touch with Ubi support, who gave me the usual generic solutions (update drivers, run in admin mode) but other than that, they were clueless (like me)

I wouldn't mind as much if they actually said they were working on a patch to fix it, but there is nothing, anywhere, to suggest anything is being done about it.

Like I said, POP Forgotten sands runs perfectly, so they can do it right when they want to. I have no idea why this stutters though, and I wish Ubi support would stop talking to me like I only just learned to switch on a PC at school last week.

Mr_Shade
04-12-2011, 01:17 PM
Have you tried disabling Aero - if your using Windows 7 [or vista]?

I noticed on another game, it has improved frame rates.

[the above is not an official fix, just something to try]


You can either do it via the themes option in windows - or by right clicking the .exe choosing compatability - and putting a tick in "Disable desktop composition".

When you start the game, you should see Aero change into a solid theme.

If it does not help - remember to undo the changes http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

Michaeljcox24
04-12-2011, 01:34 PM
Thanks for the ideas but I tried it and it doesn't work.

The ONLY thing that works, and I mean the ONLY thing, is lowering the resolution the game runs at. At 1650 x 1080, stuttering is non exisitent, however this is a useless fix for me because my monitor is 27", and thus the native resolution is 1920 x 1080.

And I can only attribute this to the fact the game doesn't pool enough gpu power at high resolutions, which needs patching.

Lignjoslav
04-12-2011, 05:31 PM
Originally posted by Michaeljcox24:
I've contacted support thanks.

For me, it's happened ever since I bought the game. Should it run smoothly? Or is what people are saying, that it barely uses any of the GPU in the PC and relies massively on CPU be true?

if the latter is true, a patch should be released by ubi that makes the game fully utilise the GPU in these peoples machines (including mine). It's not fair otherwise. It should run smoothly and it's not so CPU intensive. My main specs are:
Radeon 6950 2GB
Athlon II x2 240 (2.8GHz)
4GB DDR2 800MHz
Win 7 Pro x64
I play the game at 1920x1080, max details, 4xAA (with Enhanced Quality AA, so Nvidia would actually call it 8x, as well as Adaptive AA and 16xAF enabled in the Catalyst Control Center). I was even able to record a multiplayer session with MSI Afterburner on top of that. So you're definitely being very unlucky and something in your system doesn't get along with the game in its current version.

Bertnn26
05-06-2011, 04:36 PM
It dosn't for me...

3D prog keeps crashing

KingDaniel0
05-07-2011, 04:18 PM
Originally posted by Bertnn26:
It dosn't for me...

3D prog keeps crashing

You mean the 3D-analyse tool doesn't work ? Do you get any ERROR message when it crashes ?

Can you give the below method a Try, if possible, and if the Game does not Crash ?

Try to rename ACBSP.exe to AssassinsCreedIIGame.exe, and then try to Play Brotherhood with this EXE, if possible. But before making those changes, do make a BACKUP of any file........

Or, try to select AC2's Profile under Nvidia or ATI's Control Panel. Select AC2's profile, or create a profile of AC2 by selecting 'AssassinsCreedIIGame.exe', and then try to play Brotherhood with this Profile.

Also, try to play the Game under 'Windows XP SP2 Compatibility Mode', by making a shortcut of the Game's EXE. But when you do this, also look here under the Compatibility TAB, and check and tick these 2 options 'Disable Desktop Composition', and 'Disable Visual themes'. Now click on this .exe and run the Game.

Just see if doing all this, gives any in-game performance gain, or removes any in-game Stutter ?



---------------------------------------------------------------------------

Bertnn26
05-08-2011, 03:50 AM
i think it's the update ...

I've played the first evening and it went fine.
next day it did an update and than the stuttering started

in the movie parts the sound always came late, in ac 1 and ac2 also

KingDaniel0
05-08-2011, 05:00 AM
Originally posted by Bertnn26:
i think it's the update ...

I've played the first evening and it went fine.
next day it did an update and than the stuttering started

Alright, then I think the Update is causing a problem with your problem. Many others have also complained about this issue, after the PATCH....

Avoid Patching the Game, if it creates a problem, and update the Game only if it's necessary. But now as the game has already been updated, then you can't do anything, except doing a fresh re-install. What are your PC specs ? Which Video Card do you have ?

Force VSYNC under your Video Card's Control Panel, as well as also at the in-game option. This has helped one guy overcome some in-game stutter.

http://forums.ubi.com/eve/foru...1067519/m/5821096329 (http://forums.ubi.com/eve/forums/a/tpc/f/5031067519/m/5821096329)


As a side Note, you can also try the above method which I gave, i.e. XP Comp Mode along with those 2 options, just for testing purpose.....



--------------------------------------------------------------------

Bertnn26
05-08-2011, 05:25 AM
I know my spec's are low and don't expect any uber game play.

intel cre 2 duo T9500 @2.6
4gig ram
ati mob radeon hd 3650

and i tried the xp classic mode, turning my av off and internet conection and it helped a bit but not quite.

it still stutters but not that long any more than before.

I think i'll try the clean instal

dzhyre
05-09-2011, 12:39 AM
i have the same problem..few lags movie scene in killing ,stunning ,even the lowest settings..but lowering the settings helps..
because of this lag,i get first killed even if i stun him first..http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

RasGhi
05-12-2011, 02:14 AM
I already contacted support. Didn't help my problem. I even run the game on 800x600 and all settings set to 1. Stii stuttering, I run Crysis at high with 40fps. THE GAMES HAS A PROBLEM! Please fix it, it's been a month and I want to play my game ALREADY! I'm really really trying to control my temper here but with this BS support, I don't think I could. I loved the AC series, I want to play brotherhood so bad but alas I can't. Pleaassee help.

Bertnn26
05-12-2011, 01:30 PM
Originally posted by RasGhi:
I already contacted support. Didn't help my problem. I even run the game on 800x600 and all settings set to 1. Stii stuttering, I run Crysis at high with 40fps. THE GAMES HAS A PROBLEM! Please fix it, it's been a month and I want to play my game ALREADY! I'm really really trying to control my temper here but with this BS support, I don't think I could. I loved the AC series, I want to play brotherhood so bad but alas I can't. Pleaassee help.

LoL feel your pain...

I've even didt a format ( has been a while)
it "Helped" a bit, didn't run it in xp mode i hope for the best.

I've seen some guy's who had this 2 and the solved it with a gamepad instaid of a mouse ...

RasGhi
05-13-2011, 08:27 AM
I don't have a gamepad. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif I've bought this on my graduation. Great gift Ubisoft. Really great.