PDA

View Full Version : Why does the water look so poor?



red99
11-22-2004, 09:15 PM
Can someone help me make the water for IL2 look like it does on the box. Right now, for me, it looks like a flat blue surface. I have everything set to maximum and have run the game in Open GL and also Directx and both options give me a flat blue water surface without the swells and overall nice looking water as seen on the box.

My computer is running a ATI Radeon x800 XT video card with 2 gigs of memory. My version of Directx is 9.0c

actionhank1786
11-22-2004, 09:17 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by red99:
Can someone help me make the water for IL2 look like it does on the box. Right now, for me, it looks like a flat blue surface. I have everything set to maximum and have run the game in Open GL and also Directx and both options give me a flat blue water surface without the swells and overall nice looking water as seen on the box.

My computer is running a ATI Radeon x800 XT video card with 2 gigs of memory. My version of Directx is 9.0c <HR></BLOCKQUOTE>

You have to go into the games Config. file and change it yourself.
Someone can give you the exact instructions as to how you go about it.

Maple_Tiger
11-22-2004, 09:21 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by red99:
Can someone help me make the water for IL2 look like it does on the box. Right now, for me, it looks like a flat blue surface. I have everything set to maximum and have run the game in Open GL and also Directx and both options give me a flat blue water surface without the swells and overall nice looking water as seen on the box.

My computer is running a ATI Radeon x800 XT video card with 2 gigs of memory. My version of Directx is 9.0c <HR></BLOCKQUOTE>


I don't think you'r running Perfect Landscape. Make sure that the Stencil buffer is enabled. Or, you can go into the Conf file, under the Open GL heading, and change Water = 0 to water = 1 or 2.

CapBackassward
11-22-2004, 09:29 PM
Go find your IL 2 setup screen. There's one in your start/Programs menu or in your IL 2 folder at C: Program Files\Ubi soft\IL 2 Stumovick. At the Video tab pick your video card. Start up the game and pick Hardware setup. Then pick video options and max out everything. You've got enough system to run IL 2 Maxed out. Make sure that you have everything on High, Excellent and Perfect depending on whichever is the max. And lastly, Detailed clouds. This should have you on your way.

hope this helps,
Rick

RocketDog
11-23-2004, 01:49 AM
If you are in "excellent" landscape detail mode mode, pop into the Quick Mission Builder, set the time of day to 10:00, your height to 300 m and enjoy the nice new waves provided in the 3.01 patch.

Regards,

RocketDog.

Bearcat99
11-23-2004, 06:16 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by red99:

My computer is running a ATI Radeon x800 XT video card with 2 gigs of memory. My version of Directx is 9.0c <HR></BLOCKQUOTE>

I am assuming you have a 2.2G or better processor?

roybaty
11-23-2004, 06:20 AM
I thought you needed pixel shader 3.0 to see the waves, thought the ATI cards still only supported 2.0?

Warlordimi
11-23-2004, 07:09 AM
You mean poor like this??? http://forums.ubi.com/images/smilies/59.gif

http://t.proville.free.fr/eau2.jpg

http://t.proville.free.fr/eau1.jpg

http://t.proville.free.fr/eau3.jpg

RocketDog
11-23-2004, 07:24 AM
Nice waves. How's the frame rate?

Regards,

RocketDog.

sapre
11-23-2004, 07:34 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Warlordimi:
You mean poor like this??? http://forums.ubi.com/images/smilies/59.gif

http://t.proville.free.fr/eau2.jpg

http://t.proville.free.fr/eau1.jpg

http://t.proville.free.fr/eau3.jpg <HR></BLOCKQUOTE>

HOLY ****!!!

Bucketrider
11-23-2004, 07:58 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Warlordimi:
You mean poor like this??? http://forums.ubi.com/images/smilies/59.gif

http://t.proville.free.fr/eau2.jpg

http://t.proville.free.fr/eau1.jpg

http://t.proville.free.fr/eau3.jpg <HR></BLOCKQUOTE>
Yeah...gorgeous renders of the water. Would love to see your frame rates! I chug to about 10 fps with that kind of water w/ ships firing their guns on the Kamikaze track. In cockpit I get 20-25...but w/ stutters as the game loads the textures. That's on a Athlon64 3000+, 1 gig RAM and a Geforce 6800GT 256, 2X AA, AF off, 12x9.
As for the orginal post...in your config.ini, check to see if the line for "HardwareShaders" is set at 1, not 0.

Warlordimi
11-23-2004, 08:06 AM
To be honest, guys, thoses screens aren't mine. Here's the owner configuration!

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR> Athlon 64 3500+ / 1GODDR PC 3200 Dual channel / Abit AV8 Pro / DD Maxtor 160 go SATA /Leadtek 6800 Ultra / drivers 67.02 / FSAA 4X
Aniso 4X
1024x768x32 <HR></BLOCKQUOTE>

Here's a screen with the FPS!

http://t.proville.free.fr/fps2.jpg

33 Avg, 49 Max, 112 Min...

I think I'll won't wait long to buy a new pc!!! http://forums.ubi.com/images/smilies/cry.gif

On the kamikaze track, he runs 45fps Avg, and drop to 11 when they are kamikazing themselves. Could be worse...

Fornixx
11-23-2004, 08:30 AM
I have the same problem! Just a blue/purple flat surface. I thought I had al the settings right. Im on a 3.4GHz 2GB 9800XT rig. Should be enough shouldn't it.

That water in your post is just insane Warlordimi !!!!! http://forums.ubi.com/images/smilies/16x16_smiley-surprised.gif


Fornixx

Warlordimi
11-23-2004, 08:47 AM
AFAIC, I got much more problems with palm trees than with the water.

With more or less the same water quality, I run on average 35fps on all situations, except heavy AA, i.e. But, as I approach the shores, I instantly drop to 5 fps Avg!!! http://forums.ubi.com/groupee_common/emoticons/icon_mad.gif

I had to lower the details of the trees to forest=1

dwieser
11-23-2004, 09:39 AM
go int sturmovic folder double click il2 setup then turn off anistropic extension then go to your video card properties control panel and turn on anistropic filter there or visa versa but the thing is you cant have them both turned on

RocketDog
11-23-2004, 10:00 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Fornixx:
I have the same problem! Just a blue/purple flat surface. I thought I had al the settings right. Im on a 3.4GHz 2GB 9800XT rig. Should be enough shouldn't it.
<HR></BLOCKQUOTE>

The water in the pictures is the water = 3 setting only available on graphics cards that support Pixel Shader 3.0. This means the Nvidia 6800 series only. The current generation of ATi cards only support PS 2.0 and so can't show the very detailed water in the shots above. However - key point - even an absolutely top-end PC with a 6800ultra can only produce marginal frame rates using water = 3. In the screenshots above, we're looking at an external view with no effects and running a very basic 1024 x 768. In an in-cockpit view during a dogfight with smoke effects etc I suspect it would struggle to get over 30 FPS, so the trade in performance for graphics is very, very steep. From what I've seen here, even those with monster PCs use water = 3 just for screenshots and actually play at water = 0, 1 or 2.

On my own PC (3.0 GHz P4, 1GB DDR400, X800Pro, 3Dmark03 ~ 10,2000) I generally run in excellent mode at 1600 x 1200 with 4 x FSAA and get frame rates of 35 - 45 FPS, or in perfect at 1280 x 960 with 2 x FSAA, water = 2 and get maybe 5 FPS lower frame rates. Running in excellent certainly feels a lot smoother and the extra image sharpness from operating in 1600 x 1200 is very good.

If you are seeing just a flat blue surface, you are probably running in excellent mode in missions near mid day. The "excellent" water was dramatically upgraded in the patch, so just go to the QMB, set the mission time to be before 10:00 or after 14:00 and you should see the lovely new wave animations. The new effect is meant to represent shadows, and so is tuned out around mid-day.

Although you have a very good PC, the 9800XT is no longer a leading-edge card and is only marginally capable of running perfect mode. Even with a good CPU you may need to knock it down to 1024 x 768 to get playable frame rates.

Change between excellent/perfect under the main menu hardware set up sub menu. Go to video options, custom and set landscape detail to excellent or perfect as you choose.

See here for some screenshots of the different effects:
http://www.simhq.com/simhq3/sims/boards/bbs/ultimatebb.php?ubb=get_topic;f=114;t=001616

Hope this helps.

Regards,

RocketDog.

codeseven7
11-23-2004, 10:56 AM
Worlordimi, those pic's are insane! I thought the caption would say something about 'Photoshop enhanced' or something. Thats gotta be the best water I've seen in any game (can't wait till Silent Hunter 3 comes out), I gotta have it!

I'm about to finaly ditch my 4y/o P3 933. Soon the the Athlon 64 Socket 939/ PCI Express/ n-Force 4 SLI ect, ect, boards and chips will be available to advance gameplay to the next step. 'Maybe' then Water=3 will be 'playable'.

codeseven

Fornixx
11-23-2004, 12:48 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by RocketDog:
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Fornixx:
I have the same problem! Just a blue/purple flat surface. I thought I had al the settings right. Im on a 3.4GHz 2GB 9800XT rig. Should be enough shouldn't it.
<HR></BLOCKQUOTE>

The water in the pictures is the water = 3 setting only available on graphics cards that support Pixel Shader 3.0. This means the Nvidia 6800 series only. The current generation of ATi cards only support PS 2.0 and so can't show the very detailed water in the shots above. However - key point - even an absolutely top-end PC with a 6800ultra can only produce marginal frame rates using water = 3. In the screenshots above, we're looking at an external view with no effects and running a very basic 1024 x 768. In an in-cockpit view during a dogfight with smoke effects etc I suspect it would struggle to get over 30 FPS, so the trade in performance for graphics is very, very steep. From what I've seen here, even those with monster PCs use water = 3 just for screenshots and actually play at water = 0, 1 or 2.

On my own PC (3.0 GHz P4, 1GB DDR400, X800Pro, 3Dmark03 ~ 10,2000) I generally run in excellent mode at 1600 x 1200 with 4 x FSAA and get frame rates of 35 - 45 FPS, or in perfect at 1280 x 960 with 2 x FSAA, water = 2 and get maybe 5 FPS lower frame rates. Running in excellent certainly feels a lot smoother and the extra image sharpness from operating in 1600 x 1200 is very good.

If you are seeing just a flat blue surface, you are probably running in excellent mode in missions near mid day. The "excellent" water was dramatically upgraded in the patch, so just go to the QMB, set the mission time to be before 10:00 or after 14:00 and you should see the lovely new wave animations. The new effect is meant to represent shadows, and so is tuned out around mid-day.

Although you have a very good PC, the 9800XT is no longer a leading-edge card and is only marginally capable of running perfect mode. Even with a good CPU you may need to knock it down to 1024 x 768 to get playable frame rates.

Change between excellent/perfect under the main menu hardware set up sub menu. Go to video options, custom and set landscape detail to excellent or perfect as you choose.

See here for some screenshots of the different effects:
http://www.simhq.com/simhq3/sims/boards/bbs/ultimatebb.php?ubb=get_topic;f=114;t=001616

Hope this helps.

Regards,

RocketDog. <HR></BLOCKQUOTE>

Thx a lot!!! I'll try tweaking as you suggested and change the time of day. Suppose I should start looking for a new vid card too.

Really appreciate the help! http://forums.ubi.com/images/smilies/11.gif

dwieser
11-23-2004, 02:13 PM
i have a 9800xt and i get water just like the pictures above so quit saying you have to have a 6800 will ya

NoBunny
11-23-2004, 02:51 PM
my 9800XT with the 4.11's and my watter looks great too.