View Full Version : Severe stuttering when voices or subtitles occur in single player mode

11-15-2004, 01:02 PM
Generally speaking, Pacific Fighters runs well for me in perfect mode, with AA and Anisotropic Filtering turned off, while using water=1.

However, when radio messages are heard during single player gameplay, they invariably cause a brief period of severe stuttering, and sometimes outright pauses in action, even when frame rates are in the 50s immediately before and immediately after the period of stuttering.

I thought the solution would be to deactivate the voices and just read the subtitles. Strangely, the stutters still occur to the same extent with the voices shut off.

Does anyone have any suggestions how to alleviate this problem ? Incidentally, I had the same problem with Forgotten Battles, even with version 1.22.

Thanks in advance.

11-15-2004, 01:07 PM
I'm seeing the same thing here. The only thing that I've found to help is to drastically lower the sound settings but there should be a better way to handle it.

11-15-2004, 01:15 PM
Thanks for the reply.

All of my sound settings are already at the lowest levels possible.

In any event, why are the "subtitles" for the radio messages causing the stuttering ? I've already deactivated the chatter and voices.

11-15-2004, 02:00 PM
have you tried nosubtitles=1 in your config?

11-15-2004, 02:43 PM
Thanks, but if I understand that command line correctly, it will deactivate the subtitles.

When coupled with the fact that I have already deactivated the voices, how would I know what's going on around me, particularly in single player campaign mode ? Without voices or subtitles, it would be the equivalent of flying 100% of the time adhering to strict radio silence. For example, how would I know if someone in my squadron, out of visual range, was in need of assistance ?

Thus, even if this was to work, it would sacrifice other significant aspects of game play.

11-15-2004, 02:56 PM

Please post your DxDiag in Community Help
Click here for DxDiag_Instructions (http://www.airwarfare.com/tech/system.htm)

see this thread for PF ingame settings

This isn't suspose to be happening. There have been very few reported problems with sound in PF, which leads to believe its a hardware/ driver/ settings issue.

11-15-2004, 03:21 PM
Thanks, Steve_V. I will post my dxdiag in the community help section as you suggested.

Would this be classified as a sound problem ? Once again, it occurs when the subtitles are displayed, even when the voices have been deactivated. I find it really strange and frustrating that the mere display of a few lines of subtitles causes the game to stutter for a few moments, whereas my system maintains solid frame rates even under the most pressing of circumstances.

Claude (my name, not the Japanese plane !)

11-15-2004, 03:26 PM
i was just wondering if when you disabled the subtitles, the problem went away. That may confirm it was directly related to the subtitles. But by all means, do as Steve suggested and post your dx dump in the help forum. That way, the guys that can actually make sense out of that stuff can see if you have any issues. Good Luck

11-15-2004, 03:38 PM
Thanks Supr

Good idea. In addition to posting my dx, I will deactivate the subtitles temporarily in order to confirm whether they are the culprits.

It's like clockwork. I'll be flying a mission enjoying the overall performance and suddenly things freeze up for a few moments. In every such case, when I glance up at the top of the screen, I see a few lines of subtitles.

11-15-2004, 06:09 PM
Yes dropping sub titles AND sunspots helped me.Titles and sunspots helping fps.As I do not fly with anything but realism(even tho I suck mad donkey bizzzawls) I feel that "no cockpit" view is ga..err..aay umm I mean ...New age partnership...so I dont use sunspots cuz outside camera view why have them?? So that in and of itself freed up 6-7 fps.Not much but you could always try it fer yerself!!


11-16-2004, 12:57 PM
I was experiencing the exact same thing. I tried just about everything until I read one of Hunter's posts. It said to raise sound to 32 channels, and/or Lower the Hz from 44, to 22. I did both and that solved my problem. I still get them a little, but they're very, very, very slight.