PDA

View Full Version : Water = 3 & Nvidia Shader



10-23-2004, 02:07 PM
Has anyone tried increasing the Water quality? I was expecting Lock-on type water at least, and the manual says that setting water=3 in the conf file will enable shader model 3 on my 6800 gt. No such luck. The water looks exactly the same if I set it to 1,2 or 3!!! No reflections at all. Am I missing something?

One thing I did notice is that 'hardware shaders' is set to '0' a few lines up. Do I have to set this to '1' or something? No info on this in the manual. I have set everything to maximum, and while the planes look great, and the sky is good, the water is a big dissapointment so far. Any help would be much appreciated. I'm using the recommended driver - 61.11. Had been using the latest from nvidia.

Lifetaker999
10-23-2004, 02:14 PM
Check page 4 on the pdf manual in your IL2 directory. It amazes me how much people cry about stuff that is completely documented. Reading and comprehension have become casualties in the FPS era. http://forums.ubi.com/images/smilies/cry.gif

VW-IceFire
10-23-2004, 02:22 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by phoenixeyes:
Has anyone tried increasing the Water quality? I was expecting Lock-on type water at least, and the manual says that setting water=3 in the conf file will enable shader model 3 on my 6800 gt. No such luck. The water looks exactly the same if I set it to 1,2 or 3!!! No reflections at all. Am I missing something?

One thing I did notice is that 'hardware shaders' is set to '0' a few lines up. Do I have to set this to '1' or something? No info on this in the manual. I have set everything to maximum, and while the planes look great, and the sky is good, the water is a big dissapointment so far. Any help would be much appreciated. I'm using the recommended driver - 61.11. Had been using the latest from nvidia. <HR></BLOCKQUOTE>
Yeah you kinda need to have shaders on to use shaded water.

This means that you need to be in Perfect mode. Enable perfect mode, go back and enable Water=3. The water won't just reflect (we've had that for ages with Water=1 and Water=2) but it will use new pixel shader routines to actually give the water 3 defintion. It MAY not be playable...as many are finding out.

9th_Spitin
10-23-2004, 02:37 PM
Water 3 is nice for screen shots but thats about it. When down near the water the FPS is good but when the flak starts it goes to the single fps's.

Sys:
AMD 3000 64 bit
BFG 6800GT
1 gig ram
120 gig HD
28 gig HD
CD/DVD ect ect.

No601_prangster
10-23-2004, 02:57 PM
I was running 61.72 drivers with Aces but they didn't work with Water=3 so I switched to 61.11 as recommended in the manual. These were OK but my frame rate was around the 16fps mark. Not good!

I saw a post recommending the 66.81 drivers and they are great. Now getting over 25fps and the water looks great.

AMD 3400 and 6800GT@370mhz AAx4 AFx2 if your interested. http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

10-23-2004, 03:07 PM
I'm ignoring the sarcastic comments. I've read both my manual and the pdf manual and tried everything. One thing that I have noticed is that the 'perfect' setting for landscape detail is greyed out????????? I can't see any reason for this at all. I have a 6800gt, 265mb set for it in the bios, default settings in windows and the recomended drivers. I'm just about to try the drivers recommended above to see if this enables the option. I'm guessing this is the reason why the graphics are average!

Marek_Steele
10-23-2004, 03:13 PM
You'll need to be running opengl, select fx/6800 in il2setup, stencil buffer on, landscape detail in "perfect" ("excelent" won't add this) and then in the conf.ini file you'll need to change to water=3.
I'm not a 6800 user, but most feedback around seems to currently prefer 65.73's (and also the readme) being more stable than both 61's and 66.81s. Also the readme states that you can't get 3d water with 61.77's.

10-23-2004, 03:26 PM
Couldn't find any reason for the greyed out perfect setting so reinstalled. Suprise suprise its now available??? Ah well at least its fixed. Working ok with 61.11 but I see what you mean about the frame rates! Will try those other drivers. Thanks for the help guys. Looks great.

Alexi_Alx_Anova
10-23-2004, 03:39 PM
See this thread for my experience.

http://www.simhq.com/simhq3/sims/boards/bbs/ultimatebb.php?ubb=get_topic;f=114;t=000416

Yes, the water=3 is disappointing wrt FPS.

Alexi

9th_Spitin
10-23-2004, 03:41 PM
I am running the 66.81 drivers and they seen to be running very well.

Nubarus
10-23-2004, 04:17 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by phoenixeyes:
Couldn't find any reason for the greyed out perfect setting so reinstalled. Suprise suprise its now available??? <HR></BLOCKQUOTE>

Next time you notice Perfect mode is grayed out again instead of re-installing the entire game you might be better off if you enable Stencil Buffer in your IL2Setup instead.

Putting a check mark in a box is a lot faster and easier then installing FB+EAP+2 patches+PF.

BSS_Vidar
10-23-2004, 04:26 PM
I had this same problem as well.
Go to your video card advanced settings under the 3D tab. Make sure that you're not in directX mode, but Open GL. If the black dot is in DirectX, your card won't process the changes you made in the Open GL section in the Config.ini file.

Hope this helps.

S!

DarthBane_
10-23-2004, 04:28 PM
If only developers gave us some crapier PS3.0, i mean with less effect but more playable, now that would be nice. With sugar on top. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif.
For 6800 users:
Curently playing with water=1, 1152x864 on 6800u, with all card optimisations on (quality mode) 4aa 8as. It is on edge of playable. water=2 looks strange so i dont use it. Dig Vib on 1 also improves a bit gray element of ocean saturation. Developers grant us some more color please. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Barred
10-23-2004, 04:40 PM
It also depends on yoour processor and other settings like FSAA and AF. Granted water=3 does take more processing so I used the first hints and tips on page 8 of the manual even though I am sitting with a p4 3.2 and 4gig of RAM, I never drop below 25fps even with a small flotilla on screen and I am at low level.

I know 25fps is considered slow and in a fps yes it is totally unacceptable, but I remember when IL2 came out and was getting slower FPS with out the eye candy. Personally in flight sims I can accept lower FPS to a degree when they come out, and know that if it is going to live on my drive for a long time it will get better as the hardware catches it up.

DarthBane_
10-23-2004, 04:46 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Barred:
It also depends on yoour processor and other settings like FSAA and AF. Granted water=3 does take more processing so I used the first hints and tips on page 8 of the manual even though I am sitting with a p4 3.2 and 4gig of RAM, I never drop below 25fps even with a small flotilla on screen and I am at low level.

I know 25fps is considered slow and in a fps yes it is totally unacceptable, but I remember when IL2 came out and was getting slower FPS with out the eye candy. Personally in flight sims I can accept lower FPS to a degree when they come out, and know that if it is going to live on my drive for a long time it will get better as the hardware catches it up. <HR></BLOCKQUOTE>

Argh i cannot. I optimise to get that fluid feel of FLYING.

Barred
10-23-2004, 04:56 PM
Darth I spent too many years watching games come to life on systems that are way below the targeted specs.

That is painful all you can do is hope that you get above 25 fps with every thing running when you start a project that is pushing the envolope http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif