PDA

View Full Version : Splinter Cell Conviction HUGE problem!



TheBabeLover
04-28-2010, 10:17 AM
Got Conviction today. Tried to play it, but there's something wrong. First when I started it; no title-screen. There is a title screen, but you can't see it. No text, but sound. In the end I did start the game. Tried some settings. The clouds are gone, but there is little texture. After a few seconds, there's this


http://i39.tinypic.com/zahac.jpg

What the hell is going on. I got a good computer too. This is the only game this has happened with.

Riprie1
04-28-2010, 10:19 AM
Looks like your video card is fried. Starts off with videogames, later it is when you turn on your computer. Could also be overheating issue.

nazarethx
04-28-2010, 01:15 PM
This is only relevant if you use an ATI graphics card:

I had the same problem after playing the game for a while. I was convinced that it was NOT a video card overheating issue. After looking around for a while, I found out that ATI had released a 10.4a driver to fix some problems with SC:C. After uninstalling the old ATI drivers, booting into safe mode and running a quick Driver Cleaner Pro scan to ensure all the old drivers were removed, I installed the 10.4a driver and tried to play again.

This time, the game was playable, but I continued having another issue that had been occurring all along: crashing to desktop during particular parts of the game (such as outside after the theater in DC). After tinkering around, I decided to enable Catalyst AI and set it to Advanced just for the heck of it since Catalyst AI is ATI's driver optimization. And guess what; it worked!

So long story short?

1. Download the 10.4a ATI driver @ http://support.amd.com/us/kbar...t-10-4-a-Hotfix.aspx (http://support.amd.com/us/kbarticles/Pages/ATI-Catalyst-10-4-a-Hotfix.aspx)
2. Run a Driver Cleaner Pro scan during a Safe Mode boot @ http://www.afterdawn.com/softw...iver_cleaner_pro.cfm (http://www.afterdawn.com/software/security/system_cleanup/driver_cleaner_pro.cfm) (optional)
3. Reboot into Windows and install the 10.4a driver
4. Open Catalyst Control Center, click Graphics > 3D > AI tab > Uncheck Disable Catalyst A.I. and slide the bar to Advanced.
5. Profit!

http://img52.imageshack.us/img52/5277/atij.jpg

Hope this helps anybody that might be having this issue (even if it seems like a specific solution for maybe only a handful of people).

edit: thought I'd include a screenshot of ATI's CCC

simplesim
04-28-2010, 06:45 PM
@TheBabeLover,

I don't have any problem with the GPU and I'm using the ATI HD4850 512mb, catalyst A.I. is st at standard for now, so should I also set it to advance and will that help solve the stuttering in gameplay?
I didn't install the 10.4 driver as it didn't perform good in GTAIV, so I sticked to 9.4 instead.

zurv
04-28-2010, 09:28 PM
10.4a is out JUST for this game and battlefield

install it if you want to play the game. You can always put the old driver back in if you wanna play gta4

Blument
04-28-2010, 09:36 PM
Originally posted by zurv:
10.4a is out JUST for this game and battlefield

install it if you want to play the game. You can always put the old driver back in if you wanna play gta4

Just to clarify, 10.4 are the latest, 10.4"a" are the preview/beta ones. (It's the same, both drivers works fine, but if he's going to update them, better have the full ones with all the fixes/hotfixes http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif)

nazarethx
04-29-2010, 12:13 AM
Yep, when I posted the little tutorial above, I don't believe ATI had posted the official 10.4 driver on their site. I'd definitely recommend using the official 10.4 over 10.4a (that's what I'm doing now http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif)

Cole987
05-05-2010, 04:13 PM
Originally posted by nazarethx:
This is only relevant if you use an ATI graphics card:

I had the same problem after playing the game for a while. I was convinced that it was NOT a video card overheating issue. After looking around for a while, I found out that ATI had released a 10.4a driver to fix some problems with SC:C. After uninstalling the old ATI drivers, booting into safe mode and running a quick Driver Cleaner Pro scan to ensure all the old drivers were removed, I installed the 10.4a driver and tried to play again.

This time, the game was playable, but I continued having another issue that had been occurring all along: crashing to desktop during particular parts of the game (such as outside after the theater in DC). After tinkering around, I decided to enable Catalyst AI and set it to Advanced just for the heck of it since Catalyst AI is ATI's driver optimization. And guess what; it worked!

So long story short?

1. Download the 10.4a ATI driver @ http://support.amd.com/us/kbar...t-10-4-a-Hotfix.aspx (http://support.amd.com/us/kbarticles/Pages/ATI-Catalyst-10-4-a-Hotfix.aspx)
2. Run a Driver Cleaner Pro scan during a Safe Mode boot @ http://www.afterdawn.com/softw...iver_cleaner_pro.cfm (http://www.afterdawn.com/software/security/system_cleanup/driver_cleaner_pro.cfm) (optional)
3. Reboot into Windows and install the 10.4a driver
4. Open Catalyst Control Center, click Graphics > 3D > AI tab > Uncheck Disable Catalyst A.I. and slide the bar to Advanced.
5. Profit!

http://img52.imageshack.us/img52/5277/atij.jpg

Hope this helps anybody that might be having this issue (even if it seems like a specific solution for maybe only a handful of people).

edit: thought I'd include a screenshot of ATI's CCC

Just one more thing set mipmap to performance anything alse as you wish then game will work perfectly.... I tried all of these and this is the only thing that worked.. My game crashed randomly untill i set mipmap to performance.
Sorry for my bad english.