PDA

View Full Version : Can't save config file



casualty26ac
05-09-2007, 10:21 PM
Hi, I'm a newbie to 1946 and IL2. Got a new PC, Vista installed and I can't save my config settings. I get this message when I try to save changes, "Cannot create the C:\Program Files\Ubi Soft\1946\config.ini file."

I checked the properties and it's not "read-only." Any fixes? Thanks

Bearcat99
05-09-2007, 10:51 PM
You shouldn't have any problems. The file already exists.. if you modify it just save it. Backup and rename the original.

Feathered_IV
05-09-2007, 10:54 PM
Sounds like it is 'read only' right click on it and select Properties. Un-check the read only box and then click apply. Good luck!

casualty26ac
05-10-2007, 01:08 AM
The entire Ubisoft folder is set to read-only. I change it, and it checks itself as read-only again.

-HH-Quazi
05-10-2007, 01:08 AM
After you make the changes you want, try just clicking the "X" up in the right hand corner like you are going to close it and see if it offers you and opportunity to save the changes.

-HH-Quazi
05-10-2007, 01:09 AM
Originally posted by casualty26ac:
The entire Ubisoft folder is set to read-only. I change it, and it checks itself as read-only again.

Strange indeed. Go to your Ubisoft folder and see if it is set to read only and uncheck it. If it switches back to read only by itself, then go to your Program Files folder and see if it is checked for read only. If so uncheck it and see if it stays unchecked.

I am running XP and my game folder is checked for read only but my conf file is not. This may be something dealing with Vista. My suggestion above is comprised mainly of logic than of experience.

Capt.LoneRanger
05-10-2007, 02:02 AM
1. The name of the file is conf.ini, not config.ini IIRC.
2. Files on C are usually marked as write-protected. One reason to NOT install games on the C-drive.
3. The write-protection marker on C: is not rigid. You can change, delete or overwrite the files, anyway. BUT you have to be logged in with admin-rights to do so!
4. 3= another reason to install games to other drives.

willyvic
05-10-2007, 02:13 AM
Sounds like a Vista denial problem. I do not use Vista but have reports from others that it is very picky on what you can and can't change.

This is from a Vista thread:

To gain control again of valuable .INI files in game directories or bookmarks in your account folders you need to grant yourself access. Any time you see the 'Denied' message for a directory:
Right click on the directory > Properties > Security > Advanced > Permissions > Edit > highlight 'Everyone' and select 'Remove' and then apply and OK.

Hope this helps. Anyone else with Vista please chime in.

WV

casualty26ac
05-10-2007, 02:20 AM
Under permissions I don't see "Everyone" as an option. Could it be "Users (Home-PC\Users)?"

willyvic
05-10-2007, 02:41 AM
Do not know. I am not a Vista user. But I would try that and see if it were my issue. If it doesn't work you can always reverse any changes you make, no?

WV

MaxMhz
05-10-2007, 02:47 AM
Originally posted by casualty26ac:
Hi, I'm a newbie to 1946 and IL2. Got a new PC, Vista installed and I can't save my config settings. I get this message when I try to save changes, "Cannot create the C:\Program Files\Ubi Soft\1946\config.ini file."

I checked the properties and it's not "read-only." Any fixes? Thanks
browse with explorer to the file conf.ini (not config.ini) - open with notepad, edit if needed, use Save and not Save As... to save after the edit. (Save As... will add a .txt extension, you do not want that to happen).

casualty26ac
05-10-2007, 02:44 PM
I can't seem to resolve this. Ubisoft folder is "read-only," so I uncheck it, it "applies" changes to all files in the directory, then when I hit properties again, it's checked as "read-only." I still can't make changes to confi.ini.

I called Velocity support and they couldn't help---said they were more there for Hardware support---love my PC BTW, but I can't enjoy IL2 yet http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

Should I post this in Community Help?

mbfRoy
05-10-2007, 02:54 PM
http://forums.ubi.com/eve/forums/a/tpc/f/23110283/m/384...181041855#5181041855 (http://forums.ubi.com/eve/forums/a/tpc/f/23110283/m/3841031855?r=5181041855#5181041855)

Have you tried that?

casualty26ac
05-10-2007, 03:31 PM
It's not listed like that, but I did try what most resembled that in Vista. I tried to change select "all users," rather than everyone. I still can't remove--it's there as an option, but not highlighted or selectable.

casualty26ac
05-10-2007, 11:22 PM
User Acount Control was the trouble. I set to "off" That was why it wouldn't save. Thanks for the help though. I appreciate it.

Jettexas
05-11-2007, 04:54 PM
Ran into this myself, when editing conf. file
to specify widescreen and Vista kept not doing it..

You dont need to, and should not
disable Vista's UAC,though it does cry wolf constantly-

Make sure you can "view system files and folders" in Vista.

Click Computer,
In the user folder with your user name
look for a folder named AppData

your path will look something like this

yourusername/AppData/Local/VirtualStore/Program Files/(Various Program Folders here)

In that folder youll find your confi.ini
The Virtual Store folder is invisible by default.

Heres whats going on,
Vista "virtualizes" certain files in legacy apps-
This is a feature of the User Account Control system, and prevents applications from writing to certain system locations, Program Files, Windows, etc..instead Vista gives them a hidden home in the Virtual Store folder, and the application goes along never noticing the difference.(in theory....)The file is still "there" and writeable as far as the app is concerned.


The Vista documentation does a poor job of explaining this..but
you can see your virtual store files when browsing your folders via explorer the normal way
(instead of going to find them in Virtual Store everytime)

when you're browsing folders in explorer and you open a folder which contains such virtualized files youll notice an additional icon at the top of the explorer window with the tag "Compatability Files" click this and theres all the files Vista has placed in Virtual Store
Shown within Explorer, edit and save from here and you should be fine.

If it just wont "take", edit the one actually in the virtual store folder.

Its kinda a hamfisted approach to Vista security in my opinion and creates problems with all softwares that write back to their
parent folders after the initial install, Il2 does this frequently-
writes all kinds of things
all over the IL2 folder..

so if your missing tracks, control settings, monitor settings etc.,scripts in the RCU file.,eventlog.lst..anything that writes to a parent text file somewhere.check your Virtual Store.

UAC's a pain,(down arrow,enter, every 3 minutes..lol) but I'd leave it on anyway, without it your running a prettier, more expensive version of XP, and if something nasty ever gets in, you'll be glad you have it on.

Hope this helps others as Vista starts creeping in.

S!
RFXO