PDA

View Full Version : Which version of Il-2 to be installed?



WildeSau
12-21-2004, 12:19 PM
I have the feeling - as many others here seem to have to - that the flight models of FB/AEP/PF have been simplified comparing to the ones used in Il-2.

This makes me wanna install Il-2 as a separat installation.

Can someone tell me which version (mean which patch) is the best to go with?

Thanks.

WildeSau

Gato__Loco
12-21-2004, 02:24 PM
The last one, of course!

horseback
12-21-2004, 03:01 PM
Are you talking about the original Il-2 Sturmovik? That one patched up to 1.2, I believe. I agree that the flight models are somewhat harder in the original, but aircraft performances were not always in line with published figures. On the plus side, it was a lot easier to trim for level flight.

When FB first came out, I remember that the AI were ungodly accurate, and that a QMB against anything but a Rookie was almost impossible. As a primarily offline player, it was extremely frustrating, and I considered it unplayable as it was. It wasn't until the 1.21 patch came out that I was able to enjoy the new aircraft and feel as though the campaigns were worth my while, and so for nearly six or eight months, I played the original game even though FB was on my HD.

I now find that when I occasionally return to play the original Il-2 instead of FB, that I'm getting significantly better results than I did when I was playing it all the time. I assume that this means that either my skills have improved or I've gotten a lot luckier.

In short, FB/AEP/PF may not be as watered down as you've been led to believe. The memories of those of us who have been with this series from almost the beginning don't always factor in our learning curve or the investments many of us have made in better HOTAS/joysticks/TrackIR, etc. 'Harder' does not necessarily translate into more accurate.

cheers

horseback