PDA

View Full Version : disc unreadable AC2



rossonerixx
12-28-2009, 06:28 PM
I got a disc unreadable error right after I started the delivery missions for his father, the one after the feathers. I tried restarting, cleaning the disc, there's no scratches or dust or anything on it. Now I get a disc unreadable error as soon as I try to load my game file. Very frustrating. I'm currently trying to install AC2 to my harddrive to see if that fixes the problem.

ToKillInPeace
12-28-2009, 06:33 PM
Try exchanging it, if his problem only happens with AC2, the disk is probably defective.

When I got mine I paid like 3 bucks for a one year warranty.

rossonerixx
12-28-2009, 09:52 PM
Well i got it at gamestop so i should be able to just go back and give them it and they'll give me a new one. The thing is, it happened with AC1, though only after I beat it, I couldn't reload my save.

No other games, just AC1 and now AC2, I have a feeling it's my xbox because both discs were fine.


Luckily, installing it worked. So I figure I'll play it, beat it, buy a new xbox.