View Full Version : Assassins Creed Brotherhood Multiplayer

03-19-2011, 10:34 AM
Why doesnīt the Multiplayer work?
When I try to open Multiplayer or Uplay it responds with "The Ubisoft Server is currently not available".

Also they are written in static grey as if they were not meant to be clicked on.

I live in Germany...does anybody else experience this?

03-19-2011, 11:02 AM
Hi! I have the same problem!

I just bought the Codex edition version yesterday.
The install went fine, without any problem, i logged into the launcher with my user name, and i was able to activate the game with my serial.
But after i launched the game, and im in the main menu, the game cannot use my internet connection. The multiplayer icon is grey, the uplay too, and i cant redeem my extra content either. If i try to log in, its says: servers are not avaible, please try later. My friends can log in at the same time.
I tried to "reset" the host file, and i plugged out my router, and just plug in the net with the cabel modem, so its not a router issue.

i can play with any other multiplayer game, like mmos or fps like Bad Company 2.

So please, if anyone know about this, please response

03-19-2011, 11:17 AM
I am not sure but I think the special Editions have other Serials.

The server must not be ready to accept those serials yet.

That is the only explaination I have.
I have the Auditore Edition.
Same thing with mine...Multiyplayer and Uplay are grey.

Clean install and activation though.
I really hope ubisoft will resolve that problem soon or at least someone will help us.

Maybe it has something to do with the area code because people from Australia seem to be able to play the game.

But some others from Europe and myslef from Germany which is in Europe arenīt .

03-20-2011, 03:31 AM
Hi! Got the same problem!!!

Getting really frustrated, Bought the Codex Edition, contacted the support system. They only say make sure all anti-virus software, and firewalls are disabled, and open port 1000.

I am a network engineer, and I can see what port and ips, Assassins Creed Brother is trying to access, and it doesn't even use port 1000. And now the support system haven't replied to my questions as of yet.

If anybody have any suggestion please let me know. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

03-20-2011, 07:46 AM
You guys had log in with ur account, but everytime when I tried to log in with my account, it says I have to connect to the internet, but Ive already connected. I got confused. And during the install period, theres no request to let me insert the CD key. I live in Australia and AC is codex edition.

03-24-2011, 11:01 AM
I have the regular edition, and got the same problem. so that serial code thing isn't the problem.

03-24-2011, 12:56 PM
Those of you gyes who can connect to ubisoft server in game, do you have Allocated external IP? http://forums.ubi.com/images/smilies/shady.gif

03-25-2011, 07:14 AM
wat do you mean Allocated external IP?

03-25-2011, 01:08 PM
Please check here-
Assassin's Creed Brotherhood [PC] Connection issues. [updated: March 23rd] (http://forums.ubi.com/eve/forums/a/tpc/f/5031067519/m/9691085619)

05-10-2011, 03:54 AM
hey plz give me assassins.creed.brotherhood cd key thanx

05-10-2011, 04:50 AM
Originally posted by same57:
hey plz give me assassins.creed.brotherhood cd key thanx

Nobody else can give you their CD-KEY....

Because each key is Linked and tied to one particular UBISoft account, and if we use it on some other account, then we might get this message saying 'This product Key has already been used before'.

From where did you purchase this Game ? Is it a RETAIL disk copy, or you downloaded it from any digital web-store like STEAM, Ubishop etc. ?

Usually the CD-KEY will be printed on a Slip of paper, at the Back/front of the Game's Manual. Or there is silver box in the bottom-left with INSTALL KEYCODE written at the top. You have to scratch the silver away with a coin to reveal the code, underneath like a scratchcard.......

Or, check your EMAIL account, and all the folders like Spam/junk, if you bought it from any Digital store.

Some Digital stores also have an option on their Website, where you can view all your Purchase and full Account Details. Sometimes the Product Key is also listed here.


07-02-2011, 05:09 AM
I have downloaded the game and my multiplayer wont work and uplay so do you have to buy the game and get the multiplayer

07-02-2011, 05:32 AM
Originally posted by Hesham1991:
I have downloaded the game and my multiplayer wont work and uplay so do you have to buy the game and get the multiplayer

If you not bought this game yet, then obviously you need a Legit Cd-key to play MP, so you must buy this game in order to play Online.

If you have already purchased the Game, then you need to enter your Product key when you are trying to play the MP part.