PDA

View Full Version : Graphical glitches in 3.0.4?



Matz0r
02-06-2005, 10:00 AM
Since I've upgraded to 3.0.4 I've been seeing lots of wierd stuff in game. (RADEON 9800 PRO)

Take a look at these:

http://www.pfy.nu/tmp/gfxbug1.jpg
http://www.pfy.nu/tmp/gfxbug2.jpg
http://www.pfy.nu/tmp/gfxbug3.jpg
http://www.pfy.nu/tmp/gfxbug4.jpg
http://www.pfy.nu/tmp/gfxbug5.jpg
http://www.pfy.nu/tmp/gfxbug6.jpg

Anyone else?

Matz0r
02-06-2005, 10:00 AM
Since I've upgraded to 3.0.4 I've been seeing lots of wierd stuff in game. (RADEON 9800 PRO)

Take a look at these:

http://www.pfy.nu/tmp/gfxbug1.jpg
http://www.pfy.nu/tmp/gfxbug2.jpg
http://www.pfy.nu/tmp/gfxbug3.jpg
http://www.pfy.nu/tmp/gfxbug4.jpg
http://www.pfy.nu/tmp/gfxbug5.jpg
http://www.pfy.nu/tmp/gfxbug6.jpg

Anyone else?

VW-IceFire
02-06-2005, 10:46 AM
Yep...an ATI difficulty. I just got it while playing in UK-Dedicated.

We're supposed to keep these shots and send them somewhere. Uhhh I was just going to find out but I can't remember.

3.JG51_BigBear
02-06-2005, 10:57 AM
What version CAT do you have?

LeadSpitter_
02-06-2005, 11:05 AM
with the stock ati driver 4.10 4.11 and 4.12 i got similiar glitches along with others like clouds prop and sunglare refracting on the canopy glass wth AF and AA on.

I downloaded the tool Drive Cleaner 3 and after unintalling the drivers I ran the drive cleaner tool and removed my old nvidia drivers that were left after uninstall and the ati drivers left after the uninstall.

I then downloaded the omega 4.12 ati drivers and the glitches went away almost completely. I still get some oddities now and then but not like your getting.

In il2fbsetup.exe im using ati radeon x800/9800/9700/9600/9500
Im also not using any aa and af, I hope that helps you out.

I seen ubi & 1c blame ati for this problem but there was never any prob before with aa and af post patchs and no other games seem to have any problems whatso ever. I could be wrong but it seems to be somthing that changed in this game but we really dont know since we dont get detailed information on all changes in each patch readme.

I think the techhelp mods are doing a very good job on trying to resolve this problem.

Im also running a ati 9600 xt 256m 8x agp card so maybe the 9800 is experiencing different problem.

When i get the anomolies its usually with aax1f on and after playing the game for a long time like somethings running out of memory in the ati card or game itself. Alot of people using trackir seem to suffer from memory loss also and blame is immediatly thrown on TIR.

I also notice by your screenshots you have TexQual=2maybe that effects the problem more?

Heres my opengl settings


[Render_OpenGL]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=1
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1
TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=0

HardwareShaders=0

Shadows=1
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=1
Forest=2
LandShading=2
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=2
TexLandLarge=1

Water=0

HardwareShaders=0
ForceShaders1x=0
Effects=0

PolygonOffsetFactor=-0.0625
PolygonOffsetUnits=-1.0

Matz0r
02-06-2005, 12:38 PM
I'm using CAT 4.11. I've heard of alot of troubles with the ATI drivers, not only in FB but I had none of these problems pre 3.0.4, so it would be strange if it's all ATI problem. I didn't do anything to my drivers after upgrade.

Looked in my config and found TexQual=3, what does it do?

BerkshireHunt
02-07-2005, 02:06 PM
The best piece of advice I ever read was to stay away from ATI. This was from 'The Tech Report' site which had just tested the first 'super' Radeon (Nividia's greatest then was the Geforce3Ti500).
Even then (approx. three years ago) their tests revealed that ATI's drivers had a major problem handling mipmap levels (ie they were bugged in a big way, as screenshots confirmed). The advice given was that although Nvidia sometimes lags ATI in technology, they far surpass them in driver support. ATI's Quality Assurance testing team and driver writers are frankly inferior to Nvidia's- it's been the case for the last 10 years.
Since that time I've watched sympathetically from the sidelines as ATI users howl about their latest driver deficiencies- while Nvidia's drivers remain rock solid. So do yourself a favour next time- say no to ATI.

VW-IceFire
02-07-2005, 06:00 PM
I've had enough problems with nVidia drivers and heard enough complaints to know that they are just as bad as ATI drivers. Just less driver sets to screw up on per year. Opinion of mine anyways.

Sorry, I did forget to mention, Catalyst 5.1.

The problem is not at all present (or I have never seen it in thousands of hours) running 4.7 OGL from the FB directory (which is easy to do as well).

pourshot
02-07-2005, 08:36 PM
It would be great if you posted again in this thread and also if you could submit a bug report over at ATI feed back. The more poeple report them the faster it will get fixed

technical support (http://forums.ubi.com/eve/forums?a=tpc&s=400102&f=49310655&m=1101097862)

BaldieJr
02-07-2005, 09:46 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by BerkshireHunt:
The best piece of advice I ever read was to stay away from ATI. This was from 'The Tech Report' site which had just tested the first 'super' Radeon (Nividia's greatest then was the Geforce3Ti500).
Even then (approx. three years ago) their tests revealed that ATI's drivers had a major problem handling mipmap levels (ie they were bugged in a big way, as screenshots confirmed). The advice given was that although Nvidia sometimes lags ATI in technology, they far surpass them in driver support. ATI's Quality Assurance testing team and driver writers are frankly inferior to Nvidia's- it's been the case for the last 10 years.
Since that time I've watched sympathetically from the sidelines as ATI users howl about their latest driver deficiencies- while Nvidia's drivers remain rock solid. So do yourself a favour next time- say no to ATI. <HR></BLOCKQUOTE>

Fellow old-timer? Woah!

"RAGE3D" really was the perfect name eh?

Winter-Storm
02-07-2005, 10:21 PM
No point in slamming ATI when their drivers work perfectly in every other game I play.

I€d only go back to Nvidia because THIS game basically requires it and at the moment they have the faster cards€¦ I don€t think the graphical programmers who work on IL-2 like ATI very much, I don€t see how such huge problems can occur for ATI and not Nvidia every few patches.


btw, I also get these problems.

Turk_man
02-08-2005, 01:27 PM
Berkshirehunt are you for real? Are you a major shareholder in Nvidia? Man these graphics problems have just started after 3.04 so I think it`s likely that ATI has very little to do with it. Ati`s drivers may not be as solid as Nvidia but don`t forget we still have Omega drives aswell. Both companies make great products and to discount ATI because of something that happened 10 years ago http://forums.ubi.com/images/smilies/35.gif is crazy.

BM357_Faust
02-08-2005, 01:42 PM
I get the same graphics problems with my x800 Pro if I use Cat 4.11 or Cat 4.12. I'm using 4.10 for now and I do not see any graphics glitches.

BerkshireHunt
02-09-2005, 06:31 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Turk_man:
Berkshirehunt are you for real? Are you a major shareholder in Nvidia? Man these graphics problems have just started after 3.04 so I think it`s likely that ATI has very little to do with it. Ati`s drivers may not be as solid as Nvidia but don`t forget we still have Omega drives aswell. Both companies make great products and to discount ATI because of something that happened 10 years ago http://forums.ubi.com/images/smilies/35.gif is crazy. <HR></BLOCKQUOTE>

Absolutely. Believe me, I have no brand loyalty whatsoever- I just like an easy life.
Oleg has stated repeatedly (over the last 18 months) that graphics glitches experienced with ATI cards are not his company's fault. There are errors in ATI's drivers- there's even a thread where he asks people to write to ATI on the subject- they've ignored his plea for them to do something about it.
And I'm not making it up about ATI's crummy driver support- read some of the technical review sites for more information.