PDA

View Full Version : Wee bit confused



hartsox
09-23-2007, 03:39 PM
IS IL2 Forgotten Battles a stand alone product? Or is it an upgrade for IL2 1946 or the original IL 2? I have PF and it has an install option of installing FB+AEP+PF, is the FB forgotten battles? Thanks for reading.

hartsox
09-23-2007, 03:39 PM
IS IL2 Forgotten Battles a stand alone product? Or is it an upgrade for IL2 1946 or the original IL 2? I have PF and it has an install option of installing FB+AEP+PF, is the FB forgotten battles? Thanks for reading.

Platypus_1.JaVA
09-23-2007, 03:47 PM
You only need the Il-2 1946 package. All other versions are obsolete. IL-2 1946 does contain all the newest goodies, it is also the most common version to be found in online gamerooms.

hartsox
09-23-2007, 04:06 PM
Thanks http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

VW-IceFire
09-23-2007, 06:25 PM
Should just point out in case your still at all questioning...IL-2 1946 contains EVERYTHING from the whole series. So Platypus is completely correct in saying that all other versions are obsolete.

Happy gaming! http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

hartsox
09-23-2007, 08:12 PM
All of them? Wow.