PDA

View Full Version : Perfect Mode - Can Anyone Run with good fps?



Ace_Eloff
04-22-2005, 01:20 AM
I have a 3.06 hyperthreaded Pentium 4, 2 gigabytes of ddr 400 ram, and a 9800 pro with 128 mb, and perfect mode in PF runs terribly... it looks awesome, but my framerate averages in the teens going to a high of 25 (up to 40 when looking at nothing but sky) and a low of 7 or 8.

Is this normal? Anyone have better results with a better video card or cpu?

Ace_Eloff
04-22-2005, 01:20 AM
I have a 3.06 hyperthreaded Pentium 4, 2 gigabytes of ddr 400 ram, and a 9800 pro with 128 mb, and perfect mode in PF runs terribly... it looks awesome, but my framerate averages in the teens going to a high of 25 (up to 40 when looking at nothing but sky) and a low of 7 or 8.

Is this normal? Anyone have better results with a better video card or cpu?

TRdneck33
04-22-2005, 01:23 AM
My old system was similar to yours with less RAM and I got better than that. Post in the community help forum and the great bunch of people will help you figure out what is dragging you down.

WOLFMondo
04-22-2005, 01:26 AM
I can get roughly 70+ FPS on the blackdeath track running perfect mode, no texture compression, 6XFSAA and 16XAF 1152X864. Got a 64bit 3500 939 pin 90nm+1.5GB DDR 400 running in 2 dual channel layouts+X800XT PCIe.

Before that I had a PC not to disimilar to yours and could get good FPS. But I was running it in OGL, I followed PF coasties ATI guide and had all the latest drivers.

Ace_Eloff
04-22-2005, 01:43 AM
"My old system was similar to yours with less RAM and I got better than that. Post in the community help forum and the great bunch of people will help you figure out what is dragging you down."


How much better would you say? 10%? 50%? 100%? I think i might post in community help... I know I get like 3 or 4 times the framerate with excellent mode as oppose to perfect... so not sure if that's normal.

Vacillator
04-22-2005, 04:08 AM
My XP2600 and 9800Pro/XT bios does a heck of a lot better than that, like 30s most of the time, 75 (screen refresh rate) in the sky. I'm running vsync on for TIR.

But are we talking the same settings? What aa / af? Compression? etc etc

LEXX_Luthor
04-22-2005, 04:46 AM
I just got 9800Pro and I am running Perfect 1280x960 far better ... about 45fps using 2x AA/AF on fairly complex maps (in cockpit, looking forward). Looking at sky, I get ~130fps.

You may run the il2setup program (in game folder) and see if you have correct card selected for the game, czech out your il2setup video options, make sure you are running good video driver (new Cat 5.4 is great here). Also, see if your video card 3D settings are all set to Max Quality instead of Max Performance.

LEBillfish
04-22-2005, 08:03 AM
What is this "Black Death Track" I always hear everyone using to test their systems?

VW-IceFire
04-22-2005, 08:20 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Ace_Eloff:
I have a 3.06 hyperthreaded Pentium 4, 2 gigabytes of ddr 400 ram, and a 9800 pro with 128 mb, and perfect mode in PF runs terribly... it looks awesome, but my framerate averages in the teens going to a high of 25 (up to 40 when looking at nothing but sky) and a low of 7 or 8.

Is this normal? Anyone have better results with a better video card or cpu? <HR></BLOCKQUOTE>
Yep your doing something wrong.

I've got an AMD 2700+, 1GB of PC2700 (333) ram, a Radeon 9700Pro, and when I run Perfect mode I getan average of about 41fps in the usual situations.

So I have a slower system but I'm getting much better performance.

We'll need many more details as to driver versions and that sort of thing. Take it to the community test forum, read the stickied post on howto run a DXDIAG and go from there.

The Blackdeath track (which you can run from the track playback selectors) I get about 33fps. Its a difficult track for the computer to play...that one and the Kamikazi track. Good benchmarks.

Supr
04-22-2005, 08:41 AM
yea, i have a 9800 pro, 1 gig of ram and a barton core chip running at 2.4 ghz. Mine are better too. Not great, and there are slowdowns at times, but its very playable. I dont think i could ever go back to not playing perfect.
I haven't been playing much lately ( thank SHIII and nascar, so i cant really give you any percise fps, but i think i was around 30 last time i ran the BD. I also use 4XAA and 4AF, thats something else i would find hard to do without, however using the AF seems to give a real big hit in fps. I drop it for online play.

Also, what is your sound device, that can have a pretty big affect on fps too.

Good Luck

Atomic_Marten
04-22-2005, 08:49 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by LEBillfish:
What is this "Black Death Track" I always hear everyone using to test their systems? <HR></BLOCKQUOTE>

search the track list (.trk), once when you enter main fb screen

3.JG51_BigBear
04-22-2005, 08:53 AM
Are you running directx or opengl?

Atomic_Marten
04-22-2005, 08:59 AM
personally i get no more than 10fps on 'perfect' opengl.(yeah the sea waves are awesome but..).

I have AMD3.2athlon, 1GiG RAM but FX5600 VGA(256mb). Now, is *that* normal?http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

R_Target
04-22-2005, 09:01 AM
My 9800 Pro couldn't handle perfect unless I used no AA/AF. Then the water looks great, but everything else looks terrible.

gprr
04-22-2005, 09:52 AM
Hi Ace

What you should realy do is go to Community Help forum ,post your dxdiag & conf.ini and ask for steve_v and other hardware experts to analyz your PC and game setup.This forum modrator is also topgun hw specialyst.
You can also go to www.airwarfare.com (http://www.airwarfare.com) and look for the tech guides to start work on your rig and game settings.

Cheers
gprr

Qbeesh800
04-22-2005, 10:22 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Ace_Eloff:
I have a 3.06 hyperthreaded Pentium 4, 2 gigabytes of ddr 400 ram, and a 9800 pro with 128 mb, and perfect mode in PF runs terribly... it looks awesome, but my framerate averages in the teens going to a high of 25 (up to 40 when looking at nothing but sky) and a low of 7 or 8.

Is this normal? Anyone have better results with a better video card or cpu? <HR></BLOCKQUOTE>

Got athlon 1700 xp+, 768 ram, o/cd gf 4 ti4200 128. Runs very good.

BigA21
04-22-2005, 10:59 AM
I wonder Ace_Eloff is running water=1, water=2, or water=3 compared to some of the simmers in these replies.
I have not seen this parameter mentioned yet and it just might be a case of apples vs. oranges?

Supr
04-22-2005, 11:07 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by BigA21:
I wonder Ace_Eloff is running water=1, water=2, or water=3 compared to some of the simmers in these replies.
I have not seen this parameter mentioned yet and it just might be a case of apples vs. oranges? <HR></BLOCKQUOTE>

good point. that water setting can make a big difference.

Atomic_Marten
04-22-2005, 11:19 AM
That is the biggest blow on fps -- perfect water (water3). I also imagine that we all talkin about that here http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif.

Ace_Eloff
04-22-2005, 12:26 PM
Perfect mode and Water=1

I recently tweaked my settings, setting texture compression to S3TC, blilinear filtering (and also set Anisotrophric on the video level from 8x to 4x and to application preference)

All this considered... my frame rate improved by around 70%

But I wish i could still use Anisotrophic Filtering... it was so pretty, but in the pacific there isn't much land anyway.

Equilizer
04-22-2005, 01:04 PM
I have a 9800 Pro, Athlon XP 2600+ (overclocked to 2.09Ghz), 1GB PC2700, and etc.

Running anisotropic, even on application setting, yields very poor framerates when looking at the water with Perfect landscape and water=0. I also had 4xFSAA on at the time, but the anisotropic knocked my frames down 45 to 60%.

I'd recommend just leaving the il2setup as trilinear, the difference is negligible in flight anyway.

Frenchminem
04-22-2005, 01:30 PM
I have a:
AMD 3500+ 64bits
1gb Dual DDR 400 cas 2.5 (corsair)
GeFOrce 6800GT 256MB

and , in 1024*768... with water=3,tree=max, and ground gunners enable... I can only turn AA 4*, to keep the game running at around 40fps, best times... with sometimes momments under the 25 fps...(in OpenGL)
regarding to the other answer... I guess I have a problem somewhere too...
but I spent many time to configure the game... trying all combinations, with compression 32bits, open GL, or D3D

Bearcat99
04-23-2005, 07:18 PM
ASUS A7N8XD
AMD XP3200
1.5M DDR 400RAM
BFG 6800GT OCd 256M
Antec True Power 430W PS
NVidia Soundstorm


I get 37 fps on Pacific map in a QM in the cockpit of a P-40 with 16 planes in the air and perfect water=1. water=3 is nice... but i find it is too much of a hit so I set it to 1 which IMO looks a heckuva lot better than 2.

Hunter82
04-23-2005, 10:16 PM
Asus A8V
FX 53
1 GB 3200 OCZ Plat Rev 2
2 X 74 gb Raptors in raid 0
X800 XT PE

running in perfect at 1600 X 1200 and getting more frames than I need http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

Ace_Eloff
04-23-2005, 11:05 PM
heh

well I put water to = 0 and I'm up to 40 fps for the pacific map, and 30 fps for the pacific map with 16 planes in the air. Not half bad.

GoToAway
04-24-2005, 02:02 AM
Supermicro X5DAE
2x 2.66GHz Xeons
1024MB PC2100
GF 6600GT

I get 40 - 50 FPS in normal flight, 20 - 30 in normal action, and single digits when flying over areas with many objects when a lot of aircraft are airborne (the second Pearl Harbor mission, for example. As soon as I get near the town, I'm getting 5 - 9 FPS.)

I average about 25 FPS in black death with highs peaking at just shy of 40. The lowest point is during the collision, where I routinely get about 9FPS.

I run 2xQ AA because it really does not make much difference performance-wise.

Dumbo_AK32nd
04-24-2005, 08:45 PM
What is this "Black Death Track" I always hear everyone using to test their systems?

Salute, Billfish!

They're refering to one of the "movies" that comes pre-loaded with the game.

At the bottom of your main menu, click on "Play Tracks." You'll find a listing of all the pre-loaded movies (in addition to your own, if you've made any).

All the movies are listed in alphabetical order. "Black Death" is actually listed as "TheBlackDeath," so it's towards the bottom of the list. This track was used as the FPS benchmark for FB:AEP because it has a lot of aircraft and close-to-the-ground action.

For the PF add-on, folks seem to be using the "Kamikaze" track as the new benchmark. Again, lots of aircraft with lots of AAA from a fleet. Plus all that sparkly water! It's actually listed as "Kamikaze02."

Hope this helps!

And, yes, I am running in PERFECT mode and have run several tests with various AA and AF settings. See this thread (http://www.simhq.com/simhq3/sims/boards/bbs/ultimatebb.php?ubb=get_topic;f=127;t=002190) over at SimHQ...my contribution is about 3/4 of the way down.