PDA

View Full Version : Mah conf.ini files ain't workin'.



ImMoreBetter
10-06-2007, 01:49 PM
I decided to play around with my conf.ini files.

Nothing I change is making an effect. http://forums.ubi.com/images/smilies/51.gif

I opened the conf.ini in notepad and changed "arcade=0" to 1. Then saved. No imediate changes or changes when I reboot Il2.

Halp?

Waldo.Pepper
10-06-2007, 01:51 PM
Et tu Vista?

Divine-Wind
10-06-2007, 01:57 PM
Check that it's not "Read Only." (Under properties)

ImMoreBetter
10-06-2007, 02:21 PM
It is not read only.

Waldo.Pepper
10-06-2007, 02:26 PM
Is your OS Vista, and is the ini file contained within the program files directory? ===

This was originally posted in these forums by Jefftexas.

You dont need to, and should not
disable Vista's UAC,though it does cry wolf constantly-

Make sure you can "view system files and folders" in Vista.

Click Computer,
In the user folder with your user name
look for a folder named AppData

your path will look something like this

yourusername/AppData/Local/VirtualStore/Program Files/(Various Program Folders here)

In that folder youll find your confi.ini
The Virtual Store folder is invisible by default.

Heres whats going on,
Vista "virtualizes" certain files in legacy apps-
This is a feature of the User Account Control system, and prevents applications from writing to certain system locations, Program Files, Windows, etc..instead Vista gives them a hidden home in the Virtual Store folder, and the application goes along never noticing the difference.(in theory....)The file is still "there" and writeable as far as the app is concerned.


The Vista documentation does a poor job of explaining this..but
you can see your virtual store files when browsing your folders via explorer the normal way
(instead of going to find them in Virtual Store everytime)

when you're browsing folders in explorer and you open a folder which contains such virtualized files youll notice an additional icon at the top of the explorer window with the tag "Compatability Files" click this and theres all the files Vista has placed in Virtual Store
Shown within Explorer, edit and save from here and you should be fine.

If it just wont "take", edit the one actually in the virtual store folder.

Its kinda a hamfisted approach to Vista security in my opinion and creates problems with all softwares that write back to their
parent folders after the initial install, Il2 does this frequently-
writes all kinds of things
all over the IL2 folder..

so if your missing tracks, control settings, monitor settings etc.,scripts in the RCU file.,eventlog.lst..anything that writes to a parent text file somewhere.check your Virtual Store.

UAC's a pain,(down arrow,enter, every 3 minutes..lol) but I'd leave it on anyway, without it your running a prettier, more expensive version of XP, and if something nasty ever gets in, you'll be glad you have it on.

Hope this helps others as Vista starts creeping in.

ImMoreBetter
10-06-2007, 02:32 PM
I don't have Vista.

Thanks for typing all that up anyway. I'm sure it'll help someone.


Anyway, I just figured it out. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

I had to adjust and save the file before opening Il2.

When I tried earlier I closed Il2 before opening it back up, reseting the changes.

MrMojok
10-07-2007, 01:15 PM
If you're going to install this game on a Vista computer, would your best bet be to just install it into the root of c: instead of in c:\program files?