PDA

View Full Version : Saitek X52 Problem - Stick has no input in IL-2



Klussdog
01-31-2010, 09:08 PM
Guys, this is weird. Last night I was playing IL-2 and all of a sudden I had the dreaded blue screen with a memory dump.

System seemed to restore OK but today my Saitek X52 is no longer working with IL-2. Only the Magic mouse and a few programmed keys are functioning. Throttle and stick arre dead!

Any suggestions to fix this problem?

Chivas
01-31-2010, 09:18 PM
Click on Game Controllers in your Control Panel and see if Windows sees the X52. You may have unplug and replug the usb cable or reload the X52 software.

Klussdog
01-31-2010, 09:35 PM
Yes, the X-52 is showing up under Game Controllers. What's strange is that the sticks inputs are working fine in the Saitek Control Panel but when I check in IL-2 all inputs are dead.

I can't imagine what would have caused this to happen other than some sort of driver conflict or a recent windows update.

Sooocool
01-31-2010, 09:54 PM
See if your in game controls inadvertently were reset to default.
If so, remap your HOTAS.

Klussdog
01-31-2010, 10:08 PM
All is OK, nothing was changed at all...... http://forums.ubi.com/images/smilies/compsmash.gif

Chivas
02-01-2010, 12:47 AM
Go into IL-2 game controls, Hotas section, click opposite your Ailerons and move your stick back and forth instead of left and right and see if the input changes.

Klussdog
02-01-2010, 06:47 AM
Guys, thanks for all the suggestions but I found out that I had a driver conflict http://forums.ubi.com/images/smilies/25.gif.

I use a Logitech G19 Keyboard and a G13 Game Pad. Their new driver 3.03 has a serious conflict with the Saitek X52 units drivers.

Do not upload the new 3.03 driver unless you want problems. If it happens just remove the driver and install a previous version.