PDA

View Full Version : il2 FB pack and patch



flyingbolt
12-28-2007, 11:26 PM
is there a specific way to install the il2 FB expansion pack and 4.08 patch? after installing both of them in the same folder as i installed the game, i couldnt open the game. could the patch/AEP have overwritten something? maybe its because i installed them in the same folder. anyone have a solution?

Skycat_2
12-28-2007, 11:53 PM
The 4.08 patch can only go over the 4.07m version of the game.

Forgotten Battles is version 1.0.
Aces Expansion Pack is version 2.0.
Adding Pacific Fighters plus its patches as an expansion can only get you up to version 4.04m.
Adding the Pe-2 Peshka add-on brings you up to 4.05m...

As you can see, if you don't have "1946" installed (either as the full version or as the expansion to FB+AEP+PF version) you can't use the 4.08m patch.

Skycat_2
12-29-2007, 12:06 AM
Fortunately you don't have to uninstall/reinstall the whole game. If you installed FB and then Aces Expansion Pack (and then the 4.08 patch which made FB+AEP unplayable) you can get back to where you need to be by applying the proper patches for Aces Expansion Pack.

See Patching Guide (http://forums.ubi.com/eve/forums/a/tpc/f/23110283/m/4721047273) and only install the two patches for Aces Expansion Pack (v2.01 and then 2.04).

If I've misunderstood what you did, the guide should help sort things out for you. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

flyingbolt
12-29-2007, 12:06 AM
ok thanks. but that still doesnt explain why the game wont start if the patch didnt even work (i didnt get any error messages or any message at all). as for the 4.07 patch, can someone post a link to download it? thanks

Skycat_2
12-29-2007, 12:22 AM
The technical explanation is that each expansion and upgrade patch installs--as a minimum--a new files.sfs archive into your game folder. This file tells the game what version is being used and where all the components are. Simplified: your 4.08m version of files.sfs is pointing to stuff that isn't in your game folder. (Edit: also, the launch executable was changed after v4.05 so your FB+AEP launch icon is completely incompatible with the 4.08 update.)

There is no 4.07m patch. It was a commercial expansion that, as a paid download, required FB+AEP+PF installed as a minimum. You don't appear to have Pacific Fighters so this is a moot point; you'd have to either purchase PF to use the 1946 expansion or spend the same money to get the full version of 1946, which includes the entire series as a single install.

Let me repeat that: 1946 is the entire series as a single install. Yes, it installs from DVD as version 4.07m so it includes all the expansions and updates released prior. You get all the planes, maps, objects and missions of Forgotten Battles, Aces Expansion Pack, Pacific Fighters, Pe-2 Peshka and all the new content that was originally going to be two separate expansions following Pe-2.

Available on DVD for about $20 US or as a full version digital download from Ubi.com (which I think even comes as 4.08m).

M_Gunz
12-29-2007, 08:56 AM
Originally posted by flyingbolt:
is there a specific way to install the il2 FB expansion pack and 4.08 patch? after installing both of them in the same folder as i installed the game, i couldnt open the game. could the patch/AEP have overwritten something? maybe its because i installed them in the same folder. anyone have a solution?

If you really only have to the Forgotten Battles level then you can only use Forgotten Battles
patches.

But if you have beyond FB itself; Aces, Pacific Fighters, PE2 or 1946 then each may be patched
to its own maximum. 1946 has the total set and is the only that goes beyond 4.05, it runs $20
at many stores.

Bearcat99
12-29-2007, 08:57 AM
You need to tell us what you have... do you have just FB.. do you have the GOLD pack which is FB + AEP.... do you have the FB complete .. which is FB+AEP+PF.... or do you have !L2 1946.. which is everything and the one you should have... at various times in the sims life different versions were released.. and some of them are still on the market.. however IL2 1946 (http://forums.ubi.com/eve/forums/a/tpc/f/26310365/m/4591089933/r/4591089933#4591089933) is what you want.

flyingbolt
12-29-2007, 09:42 AM
thanks for the info guys. by the way bear, i just have il2: forgotten battles and the ace expansion pack

Bearcat99
12-30-2007, 03:00 PM
Get 46..... see that link I posted and you will see why it is best.. even if you dont care for the Pacific.. the planeset and maps alone not to mention the improvements and bug fixes are more than worth it.