PDA

View Full Version : Jaggies



donpellegrino
12-21-2007, 10:18 AM
I am a bit disappointed in the quality of the board and pieces in Chessmaster 11. I have a decent piece of hardware with a dedicated 3D graphics card. Unfortunately the edges of the board and the roundness of the pieces are littered with jaggies. Can I adjust anything to get these smoothed out?

willy_297
12-21-2007, 11:17 AM
yes you can.U need to config the antialiasing of youre card.

donpellegrino
12-21-2007, 01:07 PM
Thanks. I used the ATI Catalyst Control Center's 3D section to disable the use of application settings and to bump everything over to highest quality. This improved the look of the board and pieces dramatically.

Pr0metheus 1962
12-22-2007, 08:05 AM
I agree. Anti-aliasing is used for the background wallpaper so I can't understand why it's not available for the board itself. I'll have to see if I can mess with my graphics card to force the game to use it. [edit] Nope. I tried it but it just won't work for the board.

It would, of course, be nicer if the developers would add an optional setting so that we can choose anti-aliasing while in the game's UI.

Pr0metheus 1962
12-22-2007, 09:19 AM
I managed to get it working. When I had everything bumped up to maximum I was getting a weird prism effect - almost as if I was looking through a thick plate of glass - this only happened in the main menu unless I added glare to the board settings. I'm using a Radeon X1600 graphics card.

So I messed around with the settings and basically the game doesn't seem to like anything except full anti-aliasing, full adaptive anti-aliasing, full anisotropic filtering and forcing 24-bit buffer depth. If I use triple buffering, medium-to-full mipmap detail level, full vertical refresh or if I enable catalyst AI either the jaggies appear or I get that weird prism effect.

Anyway, after a half hour of tweaking I got a good result. Maybe my experience can help others to get the right mix.

Here's my game with jaggies:

http://img.photobucket.com/albums/v207/Beery/Chess3-1.jpg

And here it is without:

http://img.photobucket.com/albums/v207/Beery/Nojaggies.jpg

Maybe that's a subtle difference, but it sure seems to make a big difference to me.

donpellegrino
12-22-2007, 10:59 AM
Thanks for the post Beeryus. I agree that application specific settings would be much better. I hate modifying gloabl configurations like this for just one application. Enabling full 3D support at the application level would be a nice enhancement for the next patch.

I was able get the shot shown here on an "ATI Mobility Radeon HD 2400 XT" with the following settings under 3D. I didn't detect any kind of Prism effect.

3D -> All Settings

SMOOTHVISION: Anti-Aliasing
Use appliation settings: Unchecked
Temporal anti-aliasing: Unchecked
Level: 4X
Filter Box

SMOOTHVISION: Anisotropic Filtering
Use application settings: Unchecked
Per-pixel samples: 16X

Catalyst A.I.
Disable Catalyst A.I.: Unchecked
Slider: Advanced (full to the right)

Mipmap Detail Level
Slider: High Quality (full to the right)

Wait for vertical refresh
Slider: Off, unless application specifies

Adaptive Anti-Aliasing
Enable Adaptive Anti-Aliasing: Checked
Slider: Quality (full to the right)

3D -> More Settings

Direct3D Settings
Enable geometry instancing: Checked (dimmed)
Support DXT texture formats: Checked

OpenGL Settings
Triple buffering: Unchecked
Force 24-bit Z-buffer depth: Unchecked

http://byfiles.storage.live.com/y1p0MRkTeOBbGb_ztol_xGXe1OUKw60DN00YEB8jZgZSYXX-YndskITaDcAWpzlObpQrl8MGwrjEkc

I also agree that this is a very big deal. I spend a lot of time staring at the board. It should look pretty. I enjoy selecting different sets based on my mood and I think the quality of the rendering is a significant part of the experience.