PDA

View Full Version : [Unofficial & Unsupported] Enabling Windowed Mode (for you LCD users)



maztec
10-04-2004, 03:49 PM
For those of you not technically inclined but still willing to do this despite the risks of the game crashing or doing something wrong, here is a player made patch created by launton over at the Guild of Greeters:

http://forums.guildofgreeters.com/index.php?showtopic=5662

Use at your own risk, this is unsupported by Ubi and well most anyone else http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif
--------


Big thanks to Almlys on this one. Here's your answer -- it's possible it might cause problems/bugs. If you encounter problems because of this discuss them here...

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>If you have the demo, do this, it's simple.

Copy and paste the game.dsc file from the "path_to_the_demo/bin/" to "path_to_the_full_game/bin/"

And now edit that file, and change the "full_screen ( true )" line to "full_screen ( false )"

Also, remove "demo" from the window title.

Seems that is working, but not officially supported.

This file is not present in my full installation, but seems that the game is still reading it.

If you don't have the demo, the game will succesfully start in windowed mode only creating a file called game.dsc in the bin folder where the game is installed with these contents.

"path_to_full_game/bin/game.dsc"

{graphic
full_screen ( false )
}
<HR></BLOCKQUOTE>

Maz

maztec
10-04-2004, 03:49 PM
For those of you not technically inclined but still willing to do this despite the risks of the game crashing or doing something wrong, here is a player made patch created by launton over at the Guild of Greeters:

http://forums.guildofgreeters.com/index.php?showtopic=5662

Use at your own risk, this is unsupported by Ubi and well most anyone else http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif
--------


Big thanks to Almlys on this one. Here's your answer -- it's possible it might cause problems/bugs. If you encounter problems because of this discuss them here...

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>If you have the demo, do this, it's simple.

Copy and paste the game.dsc file from the "path_to_the_demo/bin/" to "path_to_the_full_game/bin/"

And now edit that file, and change the "full_screen ( true )" line to "full_screen ( false )"

Also, remove "demo" from the window title.

Seems that is working, but not officially supported.

This file is not present in my full installation, but seems that the game is still reading it.

If you don't have the demo, the game will succesfully start in windowed mode only creating a file called game.dsc in the bin folder where the game is installed with these contents.

"path_to_full_game/bin/game.dsc"

{graphic
full_screen ( false )
}
<HR></BLOCKQUOTE>

Maz

Noir31
10-05-2004, 12:49 AM
How is this done on the Mac retail version? Help. :-)

maztec
10-05-2004, 01:08 AM
I would assume it's probably exactly the same.

Noir31
10-05-2004, 05:47 AM
No, we don't have a bin folder.

maztec
10-05-2004, 12:12 PM
Give me a directory listing for the mac version and we'll see what I can think up. My bet is if you create the game.dsc in the folder the game executable is installed into it probably will work.

kinghoser
10-05-2004, 03:36 PM
I've tried this to no avail on the mac version. I put the absolute path to the directory where the executable is located but to no avail. It still starts up in full-screen mode. I wouldn't mind so much if there were just a way I could command-tab out in OSX. Once I'm in the game, I seem to be locked inside the application until I quit, which is just plain annoying. Can anyone else figure anything out?

maztec
10-05-2004, 08:00 PM
ok mac users speak up and try things out http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

lajaro
10-06-2004, 02:24 PM
W00t http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif - got it to work under Mac OS X.3.5. Maztec was right - sorta (thanks, bud)

- Open up a terminal window
- Change to the REAL Myst 4 directory (by default /Applications/Ubisoft/MystIV/myst.app
- create game.dsc in there with the following:

{graphic
full_screen ( false )
}

(you don't need to include the full path)

I was hoping that it would improve the sound sync issue (it doesn't). And now I have two mouse pointers to contend with (any ideas anyone)???

Perhaps someone can post the game.dsc file that was included in the demo?

maztec
10-06-2004, 03:34 PM
absolutely awesome that it is working for you lajaro and thanks for posting the instructions.

the dual mouse pointers is a known issue and apparently not easily fixable. Perhaps some variable of alt/command + tab can fix it? Least that was what I was told.. heh.


As for sound sync, make sure you've installed hte full game... and other than that, not sure you'll have to start a new thread with info specific to it or continue an existing thread.

lajaro
10-06-2004, 04:01 PM
Can you post a copy of the demo's game.dsc file? would like to see what other options are available.

Apple-Tab does allow toggling between windows (i.e. leave hand pointer stationary in Myst window). But returning to Myst window still provides dual hand and system pointers).

Will install on PC - that is if my DVD-RW allow me to http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif - and try to compare results.

gr0ss
10-08-2004, 01:10 PM
Well, after having an issue with the resolution limitations of the game for the last week, I just went and bought Revelation trusting in this thread.

The 'Game' file modified and copied across from the demo works flawlessly and once opened in a window, it can be maximised to full screen on my 1280x1024 TFT with no loss or degradation, the only sign that it's windowed is the grey border and bar which really don't intrude anyway.

Thanks guys for coming up with a solution so fast, and thanks also to maztec for listening to various rants about this problem and considering it priority enough to sticky this thread.

maztec
10-08-2004, 08:31 PM
Not a problem grOss, glad it worked for you. Again a big thanks to Almlys for suggesting this fix http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

johnwil2004
10-11-2004, 09:34 PM
I bought the Myst Revelation set for my Mac.
I saw a screen shot someone put in the forums here. The shot was gorgeous. My LCD screen images are nowhere near that quality. I read about the full-screen issue on LCDs in this forum. I tried the suggested fix by lajaro:

&gt;&gt;&gt;W00t - got it to work under Mac OS X.3.5. Maztec was right - sorta (thanks, bud)
- Open up a terminal window
- Change to the REAL Myst 4 directory (by default /Applications/Ubisoft/MystIV/myst.app
- create game.dsc in there with the following:
{graphic
full_screen ( false )
}
(you don't need to include the full path)
&lt;&lt;&lt;
but I could not find out how to do this. I also downloaded the entire 185Mb demo (!) just so I could get the game.dsc file
I modified it but then I could not find any place to put it that made any difference.
Can someone please help me?

johnwil2004
10-11-2004, 09:37 PM
I bought the Myst 4 set. It doesn't look so good on my LCD. I tried your instructions, but I do not know enough UNIX to fill in the missing commands, etc. Can you help?

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by lajaro:
Can you post a copy of the demo's game.dsc file? would like to see what other options are available.

Apple-Tab does allow toggling between windows (i.e. leave hand pointer stationary in Myst window). But returning to Myst window still provides dual hand and system pointers).

Will install on PC - that is if my DVD-RW allow me to http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif - and try to compare results. <HR></BLOCKQUOTE>

maztec
10-11-2004, 09:44 PM
terminal

cd /Applications/Ubisoft/MystIV/myst.app

cp /Desktop/*.dsc .

exit

johnwil2004
10-12-2004, 07:15 PM
I want to thank Maztec for his prompt, but unfortunately, not-working, reply. I still get slightly fuzzy full-screen on my LCD display (native 1680x1050 20"), even after doing the modification posted Oct 11 (thanks for the Unix help).
I tried this on my "ancient" P3 800 box with my newly acquired ATI 9600 Pro card. I'm not sure what to think as it was less attractive on the windows box than the apple box. Is it the result of the cpus being so different? Or video cards? Or main boards? And so on. Unfortunately, I also have a smaller LCD screen on it, too, so comparisons do not come easy.
Anyway, if anyone with a Mac has more ideas, I'm listening....

maztec
10-12-2004, 09:07 PM
Someone here with a mac managed to do it, you did manage to make the change? did you put it in the right spot? Hrm

johnwil2004
10-14-2004, 09:46 AM
Hi - I tried what you suggested and even with maztec's help, could not make it window. Any more ideas? Thanks

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by lajaro:
W00t http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif - got it to work under Mac OS X.3.5. Maztec was right - sorta (thanks, bud)

- Open up a terminal window
- Change to the REAL Myst 4 directory (by default /Applications/Ubisoft/MystIV/myst.app
- create game.dsc in there with the following:

{graphic
full_screen ( false )
}

(you don't need to include the full path)

I was hoping that it would improve the sound sync issue (it doesn't). And now I have two mouse pointers to contend with (any ideas anyone)???

Perhaps someone can post the game.dsc file that was included in the demo? <HR></BLOCKQUOTE>

maztec
10-14-2004, 07:26 PM
Detail to us what you did and where you put it?

terminal window:
cat &lt;&lt; "EOF" &gt;&gt; /Applications/Ubisoft/MystIV/myst.app/game.dsc
{ graphic
full_screen ( false )
}
EOF


That should create the file in the necessary location if you used a default install. -- on a Mac.

lajaro
10-19-2004, 10:51 AM
I need to amend Maztec's post.

You should open the file for writing using this command:

cat &lt;&lt; "EOF" &gt;&gt; /Applications/Ubisoft/MystIV/myst.app/game.dsc

Otherwise, you're trying to edit the wrong file.

Sure it was just an in-haste omission http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

JohnWill2004 ....

Some LCDs will interpolate (make fuzzy pixels) when run in non-optimal resolutions. Others will just shrink the viewable area to section off the required matrix. Your LCD sounds to be interpolating....check with the manual or manufacturer if there are any options they can provide you. Then change the resolution to 1024x768 before you run the game.

-lajaro

maztec
10-19-2004, 11:53 AM
Boggart. Sorry about that, thanks for pointing it out lajaro.

I'll fix that in my post &lt;g&gt;.

brulo2004
12-26-2004, 05:41 AM
aaargh it gives me an unexpectedly quit ****it:

Date/Time: 2004-12-26 23:09:31 +1030
OS Version: 10.3.7 (Build 7S215)
Report Version: 2

Command: Myst4
Path: /Applications/Ubisoft/MystIV/Myst4.app/Myst4
Version: 1.0 (1.0)
PID: 661
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

that sux http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

arne_328i
02-16-2005, 10:23 PM
For you Mac users, I got it to work in windowed mode, and can help. You don't have to use Terminal, you can make the game.dsc file with any plain text editor (such as TextWrangler or BBEdit). Or you can get the one I made here. (http://home.comcast.net/~e21graymarket/transfer/game.dsc) (Right or Control-click the link and save the file, don't open it in your browser.) Then navigate to the application itself and right or Control-click on the app (named myst4 on mine) and select "Show package contents." Paste a copy of the file you downloaded in there, close the window and you should be good to go.

Now I just wish that I could get my poor old dual processor G4 to use 1024x768, the most it will do is 800x600. But it still looks WAY better than it did at full screen.