PDA

View Full Version : last lair of romulus bug help



zuasdebusos
03-30-2011, 01:58 PM
so i have came to end at the final lair of romulus in vatican and chased and killed that cardinal and performed leap of faith but after leap of faith it does some kind of loading and i can hear sound, see minimap, hp move around but i don't see picture only see white screen in "!" in the middle i've tried to replay memory and waiting but it remains like that

jag272
03-31-2011, 01:28 AM
i got through it without a problem. it might be the game is running slow or having trouble to access the files. mine loaded straight off like it should.

lomig1983
04-04-2011, 08:28 AM
Hello everybody,

Same problem here, after the leap of faith, the game won't load. I have a white screen and an exclamation point and so it goes forever...

A little help would be appreciated (i tried to run the game with everything set as low as possible...and my machine isn't a dinosaur...)

Thanks in advance!

ElleCore
04-04-2011, 08:56 AM
Try reinstalling the game or contacting Ubisoft support.

lomig1983
04-04-2011, 10:26 AM
Thank you.

Well, I ran again the program with low graphics but this time it worked!