View Full Version : GRAW2 stops responding on startup

10-05-2008, 10:24 PM
Ghost Recon Advanced Warfighter 2 stops on load.
I do not get a crash, error, or freeze.
It just loads about half way then stops.
No more loading icon, no more disc activity, nothing.
I have to CTRL+ALT+DEL to task manager and close it.
It's listed as "Not Responding".
I also have current drivers for everything.

Vista Ultimate 64 (Directx 10)
Asus Crosshair II Formula MAinboard
2.6Ghz AMD X4 Phenom 64-bit (Quad Core)
8GB DDR2 1066
nVidia 9600GT 1GB ddr3
X-Fi Extreme Audio

(just in case it's some input device issue)
Logitech G15 Gaming Keyboard
Logitech G9 Gaming Mouse
Belkin Nostromo n52te gamepad

Ghost Recon Advanced Warfighter 2 v 1.05 (XP/Vista)

Thank you in advance, if someone has a hint to a solution.

10-05-2008, 11:00 PM
Try another gig of RAM. I have 2 gigs of RAM and the game runs like a charm.

10-06-2008, 12:13 AM
I have 8gb ram (ddr2 1066).

10-06-2008, 12:59 AM
My blunder. I saw the 1 GB figure for your video card and assumed you were talking about system RAM. The only thing I can see that might be a problem is your operating system. Vista is notorious for its difficulty with programs and hardware that ran perfectly well with XP. Perhaps a topic search in this forum about Vista fixes will provide an answer. I'm still chugging along with XP. My Vista OS is sitting on the shelf. I'm just reluctant to install it because of all the problems I've heard or read about Vista.

10-06-2008, 11:32 AM
Originally posted by Luis_Wu:
I'm still chugging along with XP. My Vista OS is sitting on the shelf. I'm just reluctant to install it because of all the problems I've heard or read about Vista.

I was just like you but I found a guide on how to install Vista while already having XP on the master drive and I can tell you it was very simple to accomplish.

The Vista look and feel is a bit onortodox (sp?) for me, more so after getting to know XP better than other OS's I have used. There are still plenty of Companies that don't offer x64 support for many applications and that blows but, since I can always go back to using my trusty XP Pro, I keep harping at Vista until I can get to know it better and decide whether is worth switching altogether or just keep it as is.

Now, IIRC, GRAW 2 was never trully a friend of Vista, some of the other members said they were having no issues but I think it was with Vista x32 and not x64 so, you may want to bust open Google or try the Search feature here.

P.S.: tankgirl, is Vista x64 really capable of supporting more than 4GB's of Ram? I really want to know and since I know a lot of people that had 4GB of ram to use with XP even if XP was only capable of using 2GB (3gb with that tweak but not 100% proof), I was wondering if Vista was trully capable of it.

I have heard that that you can but with the x86 OS. With DDR2 as cheap as it is now, I could always bust open another 4GB for mine. http://forums.ubi.com/images/smilies/16x16_smiley-wink.gif

10-06-2008, 07:18 PM
XP 64 and vista 64 will both allocate ram above 3.99ish ceiling (on 32bit os)
Vista Ultimate can recognize and use up to 128gb total of ram. I believe XP 64 can handle 128gb as well.

I'm not having issues with any other games, except this one. It just refuses to load.
I did think of something to try. Running it in xp mode. I'll try it and come back with results.

10-06-2008, 07:39 PM
Compatibility mode does nothing at all to help. Same result. It just stops loading. No errors nothing. Left it for an hour before thinking maybe I'm impatient. No such luck.
It just stops half way through load, doing nothing. It doesn't crash, lockup.. it just stops.
I can CTRL+ALT+DEL to task manager with no problem lag or issue. It closes very quickly too. Starting to think it's a GRAW2 on 64bit is the issue.
I guess I'm SoL and very unimpressed.
I only wanted this game for co-op play. (since almost every other game over looks this)

10-07-2008, 08:25 AM
As much as Grin tried, I believe their Engine was not capable of much support for even Vista, that and UBI pushing them to finish the game as quick as possible is the end result.

11-11-2008, 09:04 AM

Uninstall an application called OpenAL.
It is apparently some 3rd party substitute for EAX which apparently has some issues on Vista64..not clear on the details.
Not sure if OpenAL was installed with GRAW or with creative drivers, but there you have it.
In this case I tend to blame GRIN...I mean, when have those guys ever let me down? *cough*

11-14-2008, 12:13 AM
While I can't help you with your GRAW problem, others at GhostRecon.net might be able to. There are still a few people playing the game that should be able to help if no one is able help you get it running here.

11-18-2008, 03:58 AM
I did as suggested. I found it listed as "Host OpenAL". Quick uninstall and reboot, and all it happy in the 64 bit vista world.