PDA

View Full Version : [Tutorial]Running R.U.S.E under Linux



kingnebula
07-27-2010, 10:41 PM
Hello all!
I recently had some free time, so i decided to play around with RUSE and see if I can get it to work under Ubuntu Linux. I did some searching and finally found a solution.

I have written up a fairly easy to follow tutorial here:
http://h3xlabs.com/forums/viewtopic.php?f=36&t=133

The end result looks something like this:

<span class="flash-video"><object codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0"
classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
width="960"
height="745"
><param name="allowScriptAccess"
value="never"
></param><param name="wmode"
value="transparent"
></param><param value="transparent"
/><param value="never"
/><param name="movie"
value="http://www.youtube.com/v/h6rFpypLSTI&hl=en_US&fs=1?rel=0&color1=0x3a3a3a&color2=0x999999"
/><param value="true"
/><param value="always"
/><embed allowScriptAccess="never"
type="application/x-shockwave-flash"
pluginspage="http://www.macromedia.com/go/getflashplayer"
wmode="transparent"
src="http://www.youtube.com/v/h6rFpypLSTI&hl=en_US&fs=1?rel=0&color1=0x3a3a3a&color2=0x999999"
width="960"
height="745"
/></object></span>
watch it on youtube for better quality
http://www.youtube.com/watch?v=h6rFpypLSTI
If you have any questions on the process i'll be happy answer your questions on tutorial website.

Good luck!

esiex3
07-27-2010, 11:27 PM
There's still a rendering bug it seems, but it runs fine.

BTW, where'd you get this copy from?

kingnebula
07-28-2010, 12:25 AM
There's still a rendering bug it seems, but it runs fine.

Thanks! It's fixed now. I have added the fix on the tutorial.

senortoot
07-28-2010, 08:01 AM
good work

AnderZEL
07-28-2010, 09:59 AM
BTW, where'd you get this copy from?

are you thinking off the copy off singelplayer ruse free weekend?

NW_Evolution
07-28-2010, 11:39 AM
Originally posted by AnderZEL:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">
BTW, where'd you get this copy from?

are you thinking off the copy off singelplayer ruse free weekend? </div></BLOCKQUOTE>

that doesn't seam the free we edition.. but a full edition (Turtle AI?)

kingnebula
07-28-2010, 01:59 PM
Don't think too hard about it; You might hurt your brain. http://forums.ubi.com/groupee_common/emoticons/icon_razz.gif

infke
07-28-2010, 04:01 PM
Somewhat offtopic, but what's the name of that song? It's quite relaxing actually.

kingnebula
07-28-2010, 04:14 PM
I'm glad you like it! it's one of my favorites. It's called "The four seasons - Spring" by Vivaldi

Blitzkreigmop
07-29-2010, 12:45 AM
Originally posted by kingnebula:
Don't think too hard about it; You might hurt your brain. http://forums.ubi.com/groupee_common/emoticons/icon_razz.gif

My brain isn't hurting yet, just... Confused. Good job with the Linux, but... That game had things that are not released. Either you are a Eugen insider, or... Or... OR...

kingnebula
07-30-2010, 11:07 PM
no sticky? http://forums.ubi.com/images/smilies/bigtears.gif

kingnebula
09-16-2010, 04:27 PM
Just an update:

I have tested the final version of the game with steam running under Wine and it works perfectly!

There is actually VERY little performance lose with this game running under Wine. The multilayer also works perfectly, no problems at all!

Now I have no reason to boot into windows http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gifhttp://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gifhttp://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

Enjoy!



My system specs:
Ubuntu 10.04 32bit with Wine 1.1.42
Memory registered by OS: 3GiB
Processor: Intel Core i7 920 2.67GHz
Graphics card: nVidia GeForce GTS 250

Vilkazas
09-17-2010, 12:13 PM
yeaaah pirate version can run linux as u showed in a wid but what about not pirated version?

mikepaco
02-08-2011, 09:40 PM
I just got RUSE working under Wine, however I have no sound and the fonts are a little fuzzy. Has anyone encountered the same problems?

Brahmanfire
02-08-2011, 10:51 PM
The Four Seasons was a damn good album... I luv rockin out the ole Baroque era funkaliciousness.

kingnebula
02-14-2011, 08:46 PM
mikepaco, glad that it worked for you but it broke on my system http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif and I can't fix it. reinstalled wine/steam/ruse none worked but no matter i should upgrade to 10.10 any ways http://forums.ubi.com/groupee_common/emoticons/icon_razz.gif hopefully a clean slate will fix it

As for the sound I fixed it but don't remember how. Had to do something with disabling pulseaudio or something like that.

Good luck. Please tell me what worked

pa-wa
05-31-2012, 06:23 PM
Sorry to dig up this thread, but the website linked doesn't work anymore.
Just tried RUSE via Steam and got it installed, but when it starts up it gives the error windows media 9 codecs or higher required, i have the packages wmp10, wmp9 and wmpcodecs installed.
When I try to continue the game freezes while loading and doesn't respond anymore.