PDA

View Full Version : Extremely loud sound



ArienMalfoy
09-26-2005, 10:18 PM
I loaded up a previously saved game, and ever since then there are times when I try to enter certain areas and an extremely loud feedback sound occurs. These are areas I have entered before with no problem, and this sound issue never came up until today. Can anyone explain this? I can't go any further at this point because I can't stand to enter certain areas because of the sound. I don't want to just turn the volume down because I know I might miss something I need, and I also know it just shouldn't be doing this.

ArienMalfoy
09-27-2005, 09:10 PM
Can't anyone help me? http://forums.ubi.com/groupee_common/emoticons/icon_confused.gif

hogarth...
09-28-2005, 09:28 AM
Do you have any other programs running at the same time as Myst V? I have noticed that even having Internet Explorer open at the same time as running the game will cause problems with audio.

ArienMalfoy
09-28-2005, 05:11 PM
No, I never run any other programs when I play games. And I would think that would cause a problem with the audio throughout the whole game, not just in certain areas. These areas don't have any special sounds either, so I can't pinpoint it to a particular sound file or anything, though I don't know why that would only affect a previously saved game and not all games.

Heimdall_G
09-28-2005, 10:42 PM
Try re-installing (or installing) the latest driver for your mouse.

Also, if you have lots of processes and applications running in the background, that could be the cause of the EoA sound problem. Try using Windows Task Manager to close everything except for Explorer.exe, Ctfmon.exe, and whatever your hardware needs:
-- a. Press Ctrl+Alt+Del once and then click on Task Manager.
-- b. Select the Applications tab.
-- c. Click on the desired application to highlight it.
-- d. Click on the End Task button at the bottom of the tab.
-- e. Repeat this procedure until all unnecessary applications and processes are closed. If you aren't sure which background processes or applications can be closed using Task Manager, check out the AnswersThatWork Task List Programs index (http://www.answersthatwork.com/Tasklist_pages/tasklist.htm). The most common tasks are described, and which ones are essential and which can be safely closed are noted.
-- f. Play EoA.

Note: DO NOT leave your Internet connection active after doing this, especially if you have only a software firewall. An active connection with no firewall is an open invitation to hackers, who are most assuredly not your friends!

ArienMalfoy
09-28-2005, 11:24 PM
What would my mouse have to do with it?

And I'm not sure why I'd need to close all programs but those you mentioned, when I wasn't having a problem the first several times I played the game. It's only since I loaded up one particular, earlier, saved game that I'm having a problem, and it only comes up in certain areas (ie. the control room on Todelmer and the stairway leading down from the Great Shaft). I've been in those areas with no problem before. Why would I be having this problem now when absolutely nothing has been changed on my computer? I'm beginning to think that the saved game itself is corrupt, in which case I am going to have to uninstall and reinstall the game (or possibly go back to a waaaayyy earlier saved game), as I had to go back to that earlier saved game because of that Todelmer bug that dumps you at the end of the age without doing what you need to do.

This is so wierd. I just can't think of why I would suddenly have this problem when I didn't have it before and nothing has been changed on my computer. If the game worked before and nothing has changed, why would it not work now?

By the way, under "Applications", there's only my one internet application running (this board), which I never have running when I'm playing a game, so that definitely can't be it.

myster3
09-29-2005, 12:02 AM
What would my mouse have to do with it?

computers are weird, you never know what might affect something. i any event, it can't hurt to try!


I'm beginning to think that the saved game itself is corrupt, in which case I am going to have to uninstall and reinstall the game (or possibly go back to a waaaayyy earlier saved game)

if the saved game file is corrupt, uninstalling and reinstalling Myst V will *not* help. if you have other save files work, but this one doesn't, then you should stop using it!


This is so wierd. I just can't think of why I would suddenly have this problem when I didn't have it before and nothing has been changed on my computer. If the game worked before and nothing has changed, why would it not work now?

like i said, computers are weird! and believe me, things change on your computer every time you use it. the fact is that your problem is so specific that short of hiring an expert to come to your house and look at your computer, you'll probably never know exactly why that save file isn't working.


By the way, under "Applications", there's only my one internet application running (this board), which I never have running when I'm playing a game, so that definitely can't be it.

i seriously doubt that any running background processes are causing your problem. have you done all of the computer tune-up things that are now posted in a sticky tread? updated drivers, defrag, registry clean-up, etc? do all of that stuff, and if you still have a problem, then you are probably going to have to bite the bullet and revert to an earlier saved game file.

good luck,

-myster3

hogarth...
10-02-2005, 12:13 PM
Okay, now I have the problem.

I am on Todelmer. I was on the top of the first pinnacle, and had just looked through the telescope.
I then began to descend the stairs toward the room with the controls bathed in red light. As I turned the corner towards the room, a feedback loop of sound began that grew louder and louder until it overwhelmed my system - and my ears. I quickly turned off my speakers, hoping to perevent them from burning out from the loudness of the sound.
I shut down the game.
Next I started the game again, finding myself in the same area, as the red room appears, there is a small "pop" of sound, and then the feedback loop starts up again, growing to an unbearably loud level.
I went into game settings and lowered all sound settings to their minimum. I also checked the "mute" setting. This has no effect on the sound. It continues to roar at top volume.
I shut down the game.
I started the game again. Same problem. I go to the sound settings again and find that the Mute setting has been unchecked - the game did not remember that I had checked it before.

There is nothing wrong with my drivers or my computer. The game played fine up to this point - well, at least after lowering the video settings so that my machine could handle it.
I have completed the Great Shaft, visited all the Ages, completed Tahgira, and done some work in all the other Ages. Nowhere else have I run into this audio bug.

And it IS a bug.

I will wait for further instructions, but at this point the game is no longer playable.

EDIT: Ok - I have been able to stop the howling by turning off EAX support in the game settings.
Clearly the game is giving instructions that my soundcard - a Soundblaster 5+1 - does not understand. It is odd that this has not happened anywhere else in the game though.

I am uninstalling the game from this machine and I'll start over again when my new Alienware box gets here. It's obvious this game is not meant for "common" people with normal machines.

Anyone reading this, be aware that simply being able to play Uru or Myst IV is no guarantee that this game will run properly on your machine. This game is - to put it in the kindest words possible - less than carefully designed.

ArienMalfoy
10-02-2005, 02:06 PM
THANK YOU!!!!! That is EXACTLY what I experienced, and I also experienced it in two other locations (both times when I tried to enter a room of some type, once in Taghira and once back in D'Ni at the Great Shaft; but the problem started in Todelmer). I will try turning off the EAX support as well and see if that solves my problem. Does that affect the game in any other way? I have no plans to get a new computer anytime soon, so I'm stuck playing on the one I have.

hogarth...
10-02-2005, 05:06 PM
Let us know if that solution worked for you, Arien. I am going to try one more time before uninstalling the game to turn EAX effects back on. Turning it off obviously helped, but I'm curious to see how repeatable the issue is.

I'm also curious what sound card you are running on your machine. I hope this problem hasn't caused damage to the sound card. For those who haven't experienced it - yet - the sound is very, VERY loud when it occurs. Unbearably so.

And myster3, your statement that "things change on your computer every time you use it" may be technically true, but it is not likely that "things change" to the extent that your sound card flips out because you've turned a corner in a game. I believe that there is some spurious coding in this game. I have wondered why, for example, merely opening a web browser while the game is running often causes the sound track of the game to double up on itself, such that you hear the same sound effects in a sort of delay-echo chamber effect.

This is not what happened when I heard the howling effect earlier, by the way. The howling would happen even with nothing else running, and with system processes pared back to the minimum.

Dis game is wack.
I hate to say it, because I love Cyan, but they have goofed up here.

ArienMalfoy
10-12-2005, 10:46 AM
Sorry for the late reply, but I'm working two jobs now, trying to buy a house, and planning a wedding for January. I haven't had the time to play Myst V until yesterday.

Hogarth, I tried your solution, turning off the EAX support, and it worked!! I was able to make quite a bit of progress in the game, and I haven't noticed any other problems while playing. Thanks for the tip!

What the heck is EAX support for anyway?

Bigfootwallace
10-15-2005, 09:21 PM
I also experienced this problem, and was about to uninstall and reinstall, the sound was so loud and disconcerting.

THis is what worked for me, in case there are more folks out there still looking for a fix.

Open the game.
Choose Read Me file.
Scroll down to Audio and pick your poison.
For me, turning down the audio hardware acceleration one click fixed the problem.
Find it in Control Panel; Audio; Advanced.

Heimdall_G
10-16-2005, 09:21 AM
ArienMalfoy,

EAX is the acronym for Environmental Audio Extensions. Here's the whole story on EAX from Creative, who invented it:

EAX 1.0
--------
EAX 1.0 was the first Application Programming Interface (API) for enabling real time environment effects for PC games. It allows gamers to experience the gaming environment as they would in real life. The landscape comes alive by accurately recreating the real-life sound of whatever room your character is in.

Game developers building DirectX games with DirectX 3D were able to not only take advantage of 32 3D voices in hardware, but also to set environment presets for the 3D sound buffers.

EAX 1.0 introduced the fundamental concept of environmental audio effect presets. Developers writing to Microsoft's DirectSound API used its property set mechanism to gain access to the real-time on-board processing capabilities of the Sound Blaster Live! via the EAX 1.0 API. They would first query the system to see if EAX was available on the audio device. If it was, they were then able to choose from, and switch between the various factory-preset environments, designed to simulate different acoustic spaces such as "bathroom", "hall" and "cave".

This API collaboration between Microsoft and Creative quickly gains support from developers. In fact, Creative premiered "Unreal" with full support for EAX on its E3 booth in May 98, one month after the API was released. The DirectSound 3D / EAX effects were the talk of the show, as the Razorjack zipped around the specially designed Cambridge Soundworks 4 channel speaker systems being driven by the Soundblaster Live! Suddenly, two speakers were no longer enough for hardcore Windows PC gamers. Within 3 months of its April 98 launch, over a dozen top PC titles were using EAX to deliver advanced 3D sound. By November that year, Creative showed off over 20 EAX enhanced PC titles and draws massive crowds to their booth in the Sands Convention Center, Las Vegas at Comdex 98.

With the release of EAX 1.0 and CSW's 4.1 speakers, gamers were able to get a true sense of the enemy's whereabouts and the experience intensified significantly when they were enveloped in multi-channel audio.

The first sound card to support EAX 1.0 was the original Sound Blaster Live! , but other audio solutions soon appeared that supported EAX 1.0 via software emulation. This was by design, as Creative Labs made the API specification public shortly after Sound Blaster Live! was released.

EAX 2.0
--------
As 3D audio became more popular, it became clear that there were other aspects of the audio environment that were critical for enhanced game-play. Most importantly this included the need to simulate the effect of a sound being muffled by objects between the player and the source of the sound. With EAX 2.0, Creative set about addressing this need by coming up with the concept of a "listener" object and a number of "source" objects for sound. Sources could be "occluded" or "obstructed" depending on their position relative to the listener and any objects in the game, such as walls, pillars etc., that lay between. EAX 2.0 can also be used to recreate the effect of varying types of materials, such as wood, glass or concrete, accurately recreating how the sounds would be masked.

As with EAX 1.0, Creative decided to make the EAX 2.0 specification public, allowing other sound card manufacturers to support EAX 2.0 via software. At the same time, Creative continued to play a leading role within the Interactive Audio Significant Interest group (IASIG) to help to formalize an advanced 3D audio standard. With its powerful real time effects processing and popularity among developers as the API of choice, EAX 2.0 was soon adopted as the basis for the IASIG level 2 3D audio specification. This specification served a valuable purpose in preventing a fragmentation of approaches to the delivery architecture for advanced 3D audio. And EAX became the de-facto standard for adding environment effects to 3D games on the PC platform.

With the release of the Sound Blaster Live! 5.1, along with 5.1 speaker systems, in September 2000, 3D audio became a truly cinematic experience over 5.1 speakers. EAX 2.0 support drove the total number of games supporting real time effects rendering to over 100.

EAX 3.0
--------
With the introduction of the Sound Blaster Audigy series of soundcards, Creative wanted to create a way for game developers to utilize the additional power that the Audigy processor offered. With the concept of environmental audio now firmly established with games developers, Creative set about the task of creating the next generation, EAX ADVANCED HD.

The EAX 3.0 API was developed around a completely redesigned environmental reverb engine, more sophisticated than its predecessor thanks to the increased DSP power that the Audigy processor offered. One of the major criticisms of previous EAX versions was that there was no easy way to transition smoothly from one audio environment to the next. To solve this, EAX 3.0 provided developers with access to every single one of the reverb engine's parameters. Now, rather than simply switching from one environment to another as the player moved around the game world, the technique of "morphing" from one effect to another became possible. Sound can be transitioned smoothly from one environment to the next as a gamer's character passed through audio boundaries in a game - for instance, from a large cave to a small corridor.

Environment panning allowed developers to place both the early reflections and the late reverb components of an environment anywhere in 3D space. These highly advanced algorithms were processed in real time on dedicated hardware; EAX became EAX ADVANCED HD (ADVANCED HIGH-DEFINITION). In addition to this it was now possible to play 64 voices simultaneously.

EAX 4.0
--------
While EAX 3.0 took advantage of the Audigy processor's increased power, there was still more processing available for rendering additional (secondary / tertiary) environments as well as other effects. The EAX 4.0 API provided developers with access to this additional processing power, and Audigy owners were able to download and install an updated driver that supported it.

The main feature of EAX ADVANCED HD 4.0 is its ability to recreate multiple environments simultaneously, so you can hear an opponent's sounds coming from the correct environment. If you are in a corridor and the enemy is in a cave and shoots at you, you will hear the reverb of the cave as well as the shot. The second feature allows developers to use the full range of hardware effects in real time - for example, to recreate varying degrees of radio static via the distortion hardware effect.

ArienMalfoy
10-16-2005, 01:30 PM
Thanks for the explanation. Sounds really cool. Perhaps some systems just aren't capable of running it, or maybe there's a bug in the game itself that prevents it from working properly?

Heimdall_G
10-16-2005, 04:27 PM
There may be a bug, but more commonly the problem is that sound chipsets either don't support EAX or don't support it properly.

You can determine if your sound chipset supports EAX by running DxDiag, saving the report to a file, and then looking in the file under 'Sound Devices'. (For details on running DxDiag, refer to Myst V: System Requirements and Posting Guidelines (http://forums.ubi.com/eve/forums/a/tpc/f/3471054943/m/4941067943).) If you see something like 'EAX(tm) 2.0 Listen/Src: No, No', then....