PDA

View Full Version : Need help with creating a campfire.



Groucho2
09-30-2009, 06:56 AM
I have added the campfire mesh and added the fire emitter mesh just above it. I believe I have the object attributes configured correctly but I can't seem to get the flames to appear. Anybody know what I might be doing wrong?

Thanks!

seir
09-30-2009, 08:15 AM
In "Mesh browser" select "All" and go do "/selections/fxselections/fire/sel_FX_FireBig_A.eds". Put it on your map where fire should be. Now add sound emitter (that is enabled on start) and look for nice fire sound. Place it very close to FX. After that place object "Fire Damager" on your map and in field "ObjectsToDamage" add Player(PlayerBeingCOJ2).

That damage type works only on SP maps!

Also you can add "FXEmitter" and change its class to "FireEmiter". In "sFXNamePrefix" type fire FX name (but not that from selection but "Firekeg") and turn on "AutoStart" and "IsSequence".

Groucho2
09-30-2009, 11:12 AM
Great help Seir, thanks!

TDtrader
10-09-2009, 09:48 PM
Seir,

Thanks for all the great help! I've been learning quite a bit from all your great posts, thank-you!

wookash_b
10-11-2009, 02:29 PM
For some reason I cannot add Player to the actors being damaged by fire. The field m_objectsToDamage<Actor[]> remains "empty". Any idea what I am doing wrong with my Fire Damager?

Also how can we preview a sound file? They are not accessible outside the editor, are they? Can we also add our own sounds and then what do we need to do to get them running on other people's PCs?

One more thing. How do we know what to put in the field sFXNamePrefix? Can we create other particle based fx? Like water similar in a fountain and so on?

seir
10-12-2009, 01:34 AM
1) Check how to add object to ClutchableObjects field. It works the same way.

2) Find sound you want to play in SoundEmitter and use "Test" checkbox in SoundEmitter

3) Most FX with this field already set are in Selections\FXSelections

wookash_b
10-12-2009, 02:48 PM
Thanks for the reply. I added player to m_bojectsToDamage list but player still does not take any damage when I walk into the fire. I also made the radius of damage bigger but still no effect http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

seir
10-13-2009, 01:03 AM
I think you need to use action act_EnableDisable with _ENABLE on FireDamager.

wookash_b
10-13-2009, 01:34 PM
Originally posted by seir:
I think you need to use action act_EnableDisable with _ENABLE on FireDamager.

This indeed make it work now. I enabled the FireDamager in map settings with an action in cStartAction acions list. I hope this is the right way to do ithttp://forums.ubi.com/groupee_common/emoticons/icon_smile.gif Thanks.

seir
10-13-2009, 02:04 PM
Yes, this fire damager will be enabled from map start.