PDA

View Full Version : Unreadable Menu



Frraksurred
04-27-2010, 05:45 PM
Downloaded the Deluxe Edition from Steam. Went to play it but the menu is unreadable (see screen shots below). Exited Steam, rebooted and tried it again, same thing.

http://img163.imageshack.us/img163/5485/sccmessedup.jpg

http://img163.imageshack.us/img163/20/sccmessedup2.jpg

http://img28.imageshack.us/img28/3170/sccmessedup3.jpg

Specs: i7 960, Evga "Classified" X58, 6Gb Dominator, XFX 5870 XXX, Torx 128Gb SSD, 1Tb WD Black HDD, X-Fi Titanium, Corsair 1000w PSU, 30" XHD3000, Win7 64 Premium, Latest DirectX and ATI 10.4 drivers.

Dxdiag:


------------------
System Information
------------------
Time of this report: 4/27/2010, 18:40:37
Machine name: XXXXXXXXXXXXXXXXXX
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7600) (7600.win7_gdr.100226-1909)
Language: English (Regional Setting: English)
System Manufacturer: OEM
System Model: OEM
BIOS: Phoenix - AwardBIOS v6.00PG
Processor: Intel(R) Core(TM) i7 CPU 960 @ 3.20GHz (8 CPUs), ~2.3GHz
Memory: 6144MB RAM
Available OS Memory: 6136MB RAM
Page File: 2092MB used, 10175MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7600.16385 64bit Unicode



--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: ATI Radeon HD 5800 Series
Manufacturer: ATI Technologies Inc.
Chip type: ATI display adapter (0x6898)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_6898&SUBSYS_29601682&REV_00
Display Memory: 3819 MB
Dedicated Memory: 1012 MB
Shared Memory: 2807 MB
Current Mode: 2560 x 1600 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: XHD3000
Monitor Id: GWYB90B
Native Mode: 1280 x 800(p) (59.810Hz)
Output Type: DVI
Driver Name: atiu9p64.dll,aticfx64.dll,aticfx64.dll,atiu9pag,at icfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64 .dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a. cap,atitmm64.dll
Driver File Version: 8.14.0001.6105 (English)
Driver Version: 8.723.0.0
DDI Version: 10.1
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 4/6/2010 20:22:38, 28160 bytes
WHQL Logo'd: No
WHQL Date Stamp: None
Device Identifier: {D7B71EE2-2BD8-11CF-EB62-6109A1C2C535}
Vendor ID: 0x1002
Device ID: 0x6898
SubSys ID: 0x29601682
Revision ID: 0x0000
Driver Strong Name: oem4.inf:ATI.Mfg.NTamd64.6.1:ati2mtag_Evergreen:8. 723.0.0http://forums.ubi.com/groupee_common/emoticons/icon_razz.gifci\ven_1002&dev_6898
Rank Of Driver: 00E62001
Video Accel: ModeMPEG2_A ModeMPEG2_C
Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
{3C5323C1-6FB7-44F5-9081-056BF2EE449D}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{552C0DAD-CCBC-420B-83C8-74943CF9F1A6}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC1,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC2,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC3,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC4,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(S340,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(S342,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
D3D9 Overlay: Not Supported
DXVA-HD: Not Supported
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled

-------------
Sound Devices
-------------
Description: Speakers (Creative SB X-Fi)
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: PCI\VEN_1102&DEV_000B&SUBSYS_00431102&REV_03
Manufacturer ID: 1
Product ID: 100
Type: WDM
Driver Name: ctaud2k.sys
Driver Version: 6.00.0001.1347 (English)
Driver Attributes: Final Retail
WHQL Logo'd: Yes
Date and Size: 7/14/2009 03:53:54, 696984 bytes
Other Files:
Driver Provider: Creative
HW Accel Level: Basic
Cap Flags: 0xF1F
Min/Max Sample Rate: 100, 200000
Static/Strm HW Mix Bufs: 1, 0
Static/Strm HW 3D Bufs: 0, 0
HW Memory: 0
Voice Management: No
EAX(tm) 2.0 Listen/Src: No, No
I3DL2(tm) Listen/Src: No, No
Sensaura(tm) ZoomFX(tm): No

Description: SPDIF Out (Creative SB X-Fi)
Default Sound Playback: No
Default Voice Playback: No
Hardware ID: PCI\VEN_1102&DEV_000B&SUBSYS_00431102&REV_03
Manufacturer ID: 1
Product ID: 100
Type: WDM
Driver Name: ctaud2k.sys
Driver Version: 6.00.0001.1347 (English)
Driver Attributes: Final Retail
WHQL Logo'd: Yes
Date and Size: 7/14/2009 03:53:54, 696984 bytes
Other Files:
Driver Provider: Creative
HW Accel Level: Basic
Cap Flags: 0xF1F
Min/Max Sample Rate: 100, 200000
Static/Strm HW Mix Bufs: 1, 0
Static/Strm HW 3D Bufs: 0, 0
HW Memory: 0
Voice Management: No
EAX(tm) 2.0 Listen/Src: No, No
I3DL2(tm) Listen/Src: No, No
Sensaura(tm) ZoomFX(tm): No


Any help would be appreciated. Thank you.

BlackFrancis
04-27-2010, 06:58 PM
I'm having the same problem. I think it's the lack of support for most graphics cards. There's a rumored patch (v1.01), but so far nothing has been officially announced. If we make enough noise, maybe they'll fix it.

whiskeynerd
04-27-2010, 07:13 PM
I fixed this by disabling CATALYST AI. search google for how to do this. Good luck!

HH375mag
04-27-2010, 08:21 PM
Originally posted by whiskeynerd:
I fixed this by disabling CATALYST AI. search google for how to do this. Good luck!

For anyone that doesn't know how to do that with an ATI card (don't laugh some of you guys, some people legitimately don't):

1) Right click mouse on desktop and select Catalyst(TM) Control Center.

2) On the furthest left drop down on the top left of the settings page, go to "3D".

3) Click on "All" or "AI".

4) Tick the box that says Disable Catalyst AI.


http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif


It's a shame to hear that you guys are having problems with the game. Itís putting me further into dread of what is going to happen with my copy when I get it this or next week in the U.K. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

Squidxm
04-28-2010, 07:33 PM
Im experiencing the same problem at the menu, except I see less than you.
Im also running an ATI 5870, however AI was already disabled so that isnt the fix for me.

http://img195.imageshack.us/img195/2366/convictiongame201004272.jpg

RedzTime
04-30-2010, 03:17 AM
My screen looks just like that screen shot above. I have ATI 5850 with the 10.4 drivers with AI turned off.

nazarethx
04-30-2010, 03:26 AM
I had the same problem (I use a 4870, however) and solved the problem by actually NOT disabling AI, but rather enabling AI and setting it to Advanced.

RedzTime
04-30-2010, 03:31 AM
Originally posted by nazarethx:
I had the same problem (I use a 4870, however) and solved the problem by actually NOT disabling AI, but rather enabling AI and setting it to Advanced.

Just tried that and it makes no difference on my machine.
Also just tried the campaign, all the textures are messed up and some aren't even there. Tried running around with Fisher and sometimes he's there other times he is invisible.

KingDaniel0
04-30-2010, 07:21 AM
-------------------------------------------------------------------------

Hi Frraksurred,

I'm NOT fully sure, but can you first try Verifying the Integrity of the Game Cache Files (GCF) ? This is Very important if the game was downloaded from STEAM. After that restart the STEAM client, and check whether the game has been downloaded/updated properly.

https://support.steampowered.c...p?ref=2037-QEUH-3335 (https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335)

Anyways, I'm just 'guessing' this from my side.
Cheers.

Others too can try it out, IF the game was downloaded via STEAM. Does this happen ONLY at the game's main MENU ?


-------------------------------------------------------------------------------

Frraksurred
04-30-2010, 04:24 PM
Disabling ATI's "AI" did the trick for me. Menus are all present and the weird 10fps cap I had has been removed. I am now playing at max settings with frames in the 40's.

Much better, thanks gentlemen.

RedzTime
04-30-2010, 06:55 PM
The fix works. Just had to update everything and disable AI. Then had to reinstall for it to show up.