PDA

View Full Version : Hello all! New to IL-2!



Walther00
06-09-2007, 05:28 AM
Hi everyone,

I got IL-2 (FB, AEP, PF) yesterday and am just trying to get to grip with everything at the moment.

I've read Beracatt99's guide for Nuggets and found it very usefull, but I have some questions about the patches.

As my aim is to fly in multiplayer and as such I wish to patch my game up to the lateast version but here I get confused.

Can I just download 4.04? Or do I need to install 4.03 first?

Is there a standalone patch to bring the game up to date with just one patch?

Thanks for any help, and if anyone out there wants to recruit/train me then please post or PM.

Best Regards,

Walther

tigertalon
06-09-2007, 05:48 AM
Hey walther, wellcome to the madness http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Online almost everyone (and there is plenty of us online, 1000 or so every evening) uses version 4.08. You are now at 4.0 if I understood you correctly.

The best option would be to buy IL2 '46 megapack, which includes everything from IL2FB, ACE, PF, etc etc all the patches right up to v4.07 in a single install. After that you just dl and install additional 4.08 patch and you are ready to go.

Now if you don't wanna purchase IL2 1946, then you have to download and install patches v4.01-v4.04 for free, and after that next payable addons:

- Pe2 (v4.05) - adds a "russian mosquito" Pe2 bomber
- '46 (v4.06) - adds plenty of real and whatif jet stuff
- "Sturmoviks over manchuria" (v4.07) which adds IL10, Ki-27 etc etc.

All these patches add a bunch of new maps, ground objects etc.

However, the price of last two addons alone (4.06 and 4.07) is about the same as the entire '46 megapack I mentioned in the begining, and you are still missing 4.05! It costs you more and you need 1 day to install and patch it correctly!

Consensus: get IL2 1946.

By the way, yes, patches are not interchangeable and later do not include early ones. To install 4.04 you need to patch the game up to 4.03 first.

SithSpeeder
06-09-2007, 11:32 AM
Hey Walther--

Welcome to our community. Glad you found us. This is a great place.

Unfortunately, whomever sold you IL-2 (FB, AEP, PF) sold you the "old" version. IL-2:1946 is where online multiplayer is at (version 4.07/4.08). TigerT summed it up nicely so I won't repeat it. It can be had for about $30.

As far as recruiting/training options, there are a lot of squads (some pickier than others), there is even some non-squad training available. If you are truly serious about the online multiplayer environment, get Hyperlobby, comms software (Teamspeak typically), and fly for a few weeks. Figure out which days you fly, the times you fly, and meet people. You will get to know the "regulars" and then you will find who amongst them you like (and vice-versa). There are also different game settings (full switch vs. everyone else) and different game types (dogfighters, co-ops, online wars, mission objective maps, team competition, etc.) that divide our community into different interest groups--explore them all and see what floats your boat (or sets you flying).

* _54th_Speeder *

Skycat_2
06-09-2007, 11:55 AM
If you use the individual FB, AEP and PF discs to install, you'll need the patch that brings the game up to v3.03m as your first patch. Then the 4.01m through 4.04m patches. The 4.04m patch was really just some tweaks to 4.03m.

Here is a patching guide with links (http://forums.ubi.com/eve/forums/a/tpc/f/23110283/m/4721047273).

However, I saw a thread just yesterday at the Pacific Fighters forum that had a link to a 'Mega Patch' at Mission4Today that will get you up to 4.04m with just one patch. That was an unofficial patch made within the community but it works ... I'll look for the link for you.

As everybody has said, though, the 1946 game is the way to go now. You can't jump from 4.04m to 4.07m/4.08m any other way.

Skycat_2
06-09-2007, 12:00 PM
Here is the link to the 4.04m Mega Patch (http://mission4today.com/index.php?name=Downloads&c=564).

Skycat_2
06-09-2007, 12:24 PM
There is a digital download version for the full 1946 game as well as the retail DVD version of the full game sold in stores. I was looking for the UbiSoft digital download store and stumbled over the link for the "Addons Only" version of 1946 (http://shop.ubi.com/Prod_ExtDesc.asp?catalogid=528&id=97), which may be useful to you ... It only has the material of 4.05m to 4.07m (and maybe includes the patch upgrade to 4.08m).

The download is through the UbiSoft France site; convert the page to English by using the UK flag. A credit card should convert the exchange rate for you. Warning: The download manager, Boontybox, is not much liked and I get the impression that purchasing from this link isn't always successful.

The full 1946 game download can be found here (http://digitalstore.ubi.com/3021/product/Buy-IL-2-Sturmovik:-1946-Download). In the US, it is the same price as the DVD which is easily found at Wal-Marts anyhow.

Xiolablu3
06-09-2007, 12:28 PM
I would buy 1946 if you want to get online mate, its well worth it, I got mine at 19,99.

It makes installing the series much easier than the many many patchs and addons.

Many of us here bought 1946 even after owning the rest of the series, purely because its such a great package.

The addons would cost you more than buying 1946 would, because with the 1946 series you get all the older games for free.

I wouldnt recommend buying the download version unless you get good reports form other users first. Often these downloadable version are not copatible with upgrades or new patches released.

tigertalon
06-09-2007, 01:13 PM
Originally posted by Skycat_2:
If you use the individual FB, AEP and PF discs to install, you'll need the patch that brings the game up to v3.03m as your first patch.


Ah true, I always forgot PF was NOT 4.00 version, but rather 3.00, so patching is even longer "stations of the cross"... tx for correction. Yeah, confusing all these patches. http://forums.ubi.com/images/smilies/53.gif